diff options
author | Yogesh Siraswar <yogeshs@ti.com> | 2021-12-15 16:10:59 -0500 |
---|---|---|
committer | Ryan Eatmon <reatmon@ti.com> | 2021-12-15 15:21:36 -0600 |
commit | a2df9cee2b75c2b418c0ff90497b293c2069cf78 (patch) | |
tree | b94147ed9680a3c5b14aa03e0f954ec90300a683 | |
parent | f8aba53e210c53e09d81b46cbf9782573ef4f716 (diff) | |
download | meta-ti-a2df9cee2b75c2b418c0ff90497b293c2069cf78.tar.gz |
ti-sci-fw: Fix for k3-image-gen issue for combined boot images
This is temporary fix for combined boot images for KIG in meta-ti till
the patch is integrated.
Signed-off-by: Yogesh Siraswar <yogeshs@ti.com>
Signed-off-by: Denys Dmytriyenko <denys@konsulko.com>
Signed-off-by: Ryan Eatmon <reatmon@ti.com>
-rw-r--r-- | recipes-bsp/ti-sci-fw/files/0001-Makefile-Skip-signing-of-binaries-for-combined-boot-.patch | 64 | ||||
-rw-r--r-- | recipes-bsp/ti-sci-fw/ti-sci-fw_git.bb | 5 |
2 files changed, 69 insertions, 0 deletions
diff --git a/recipes-bsp/ti-sci-fw/files/0001-Makefile-Skip-signing-of-binaries-for-combined-boot-.patch b/recipes-bsp/ti-sci-fw/files/0001-Makefile-Skip-signing-of-binaries-for-combined-boot-.patch new file mode 100644 index 00000000..196f3d3f --- /dev/null +++ b/recipes-bsp/ti-sci-fw/files/0001-Makefile-Skip-signing-of-binaries-for-combined-boot-.patch | |||
@@ -0,0 +1,64 @@ | |||
1 | From 2efc79702a47f9cbbeecbb2f604577f1ec8c95ba Mon Sep 17 00:00:00 2001 | ||
2 | From: Yogesh Siraswar <yogeshs@ti.com> | ||
3 | Date: Wed, 8 Dec 2021 17:50:19 -0600 | ||
4 | Subject: [KIG PATCH] Makefile: Skip signing of binaries for combined boot hs | ||
5 | images | ||
6 | |||
7 | Combined sysfw binaries used in tiboot.bin do not require signed images. | ||
8 | This fixes issues with AM64x HS and J7200 HS boot images | ||
9 | |||
10 | Upstream-Status: Submitted | ||
11 | Signed-off-by: Yogesh Siraswar <yogeshs@ti.com> | ||
12 | --- | ||
13 | Makefile | 8 +++++++- | ||
14 | soc/am64x/Makefile | 1 + | ||
15 | soc/j7200/Makefile | 1 + | ||
16 | 3 files changed, 9 insertions(+), 1 deletion(-) | ||
17 | |||
18 | diff --git a/Makefile b/Makefile | ||
19 | index 47b3b20..ab465df 100644 | ||
20 | --- a/Makefile | ||
21 | +++ b/Makefile | ||
22 | @@ -215,8 +215,14 @@ $(soc_objroot)/%.o: %.c | ||
23 | $(CROSS_COMPILE)gcc $(CFLAGS) -c -o $@-pre-validated $< | ||
24 | python3 ./scripts/sysfw_boardcfg_validator.py -b $@-pre-validated -i -o $@ -s $(SOC) -l $@.log | ||
25 | |||
26 | -# On HS board configuration binaries must be signed | ||
27 | +# On HS board configuration binaries must be signed unless it is combined boot image | ||
28 | ifdef HS | ||
29 | +ifndef COMBINED_BOOT_IMAGE | ||
30 | +SIGN_BINARY=1 | ||
31 | +endif | ||
32 | +endif | ||
33 | + | ||
34 | +ifdef SIGN_BINARY | ||
35 | %.bin.unsigned: %.o | ||
36 | $(CROSS_COMPILE)objcopy -S -O binary $< $@ | ||
37 | %.bin: %.bin.unsigned | ||
38 | diff --git a/soc/am64x/Makefile b/soc/am64x/Makefile | ||
39 | index bfbe3e5..33ebbd0 100644 | ||
40 | --- a/soc/am64x/Makefile | ||
41 | +++ b/soc/am64x/Makefile | ||
42 | @@ -31,6 +31,7 @@ | ||
43 | # | ||
44 | |||
45 | SBL_LOADADDDR ?= 0x70000000 | ||
46 | +COMBINED_BOOT_IMAGE = 1 | ||
47 | COMBINED_SYSFW_BRDCFG_LOADADDR ?= 0x7b000 | ||
48 | LOADADDR ?= 0x44000 | ||
49 | SCIFS = sci | ||
50 | diff --git a/soc/j7200/Makefile b/soc/j7200/Makefile | ||
51 | index 3b754f7..0baef51 100644 | ||
52 | --- a/soc/j7200/Makefile | ||
53 | +++ b/soc/j7200/Makefile | ||
54 | @@ -31,6 +31,7 @@ | ||
55 | # | ||
56 | |||
57 | SBL_LOADADDDR ?= 0x41c00000 | ||
58 | +COMBINED_BOOT_IMAGE = 1 | ||
59 | COMBINED_TIFS_BRDCFG_LOADADDR ?= 0x7f000 | ||
60 | COMBINED_DM_BRDCFG_LOADADDR ?= 0x41c80000 | ||
61 | LOADADDR ?= 0x40000 | ||
62 | -- | ||
63 | 2.17.1 | ||
64 | |||
diff --git a/recipes-bsp/ti-sci-fw/ti-sci-fw_git.bb b/recipes-bsp/ti-sci-fw/ti-sci-fw_git.bb index 59dd3ee1..2dad0fe0 100644 --- a/recipes-bsp/ti-sci-fw/ti-sci-fw_git.bb +++ b/recipes-bsp/ti-sci-fw/ti-sci-fw_git.bb | |||
@@ -47,6 +47,11 @@ LD[unexport] = "1" | |||
47 | 47 | ||
48 | do_configure[noexec] = "1" | 48 | do_configure[noexec] = "1" |
49 | 49 | ||
50 | SRC_URI:append:j7200-hs-evm-k3r5 = " \ | ||
51 | file://0001-Makefile-Skip-signing-of-binaries-for-combined-boot-.patch;patchdir=../imggen" | ||
52 | SRC_URI:append:am64xx-hs-evm-k3r5 = " \ | ||
53 | file://0001-Makefile-Skip-signing-of-binaries-for-combined-boot-.patch;patchdir=../imggen" | ||
54 | |||
50 | EXTRA_OEMAKE = "\ | 55 | EXTRA_OEMAKE = "\ |
51 | CROSS_COMPILE=${TARGET_PREFIX} SYSFW_DL_URL='' SYSFW_HS_DL_URL='' SYSFW_HS_INNER_CERT_DL_URL='' \ | 56 | CROSS_COMPILE=${TARGET_PREFIX} SYSFW_DL_URL='' SYSFW_HS_DL_URL='' SYSFW_HS_INNER_CERT_DL_URL='' \ |
52 | SYSFW_PATH="${SYSFW_TISCI}" SOC=${SYSFW_SOC} CONFIG=${SYSFW_CONFIG} \ | 57 | SYSFW_PATH="${SYSFW_TISCI}" SOC=${SYSFW_SOC} CONFIG=${SYSFW_CONFIG} \ |