diff options
author | Denys Dmytriyenko <denys@ti.com> | 2020-05-16 08:45:12 +0000 |
---|---|---|
committer | Denys Dmytriyenko <denys@ti.com> | 2020-05-16 15:47:47 +0000 |
commit | 8fb8109f0407aaaf48e955205d05656984449c10 (patch) | |
tree | c1b337590dd72619aaaa995d98b994db40b932c9 | |
parent | d8a79f2437fc81c5561a04c92eeb4025bb7f518d (diff) | |
download | meta-ti-8fb8109f0407aaaf48e955205d05656984449c10.tar.gz |
ti-sci-fw: introduce recipe to package sources for MAINMACHINE
ti-sci-fw builds multiple config variants via multiconfig and the number
is expected to grow. Provide a recipe to package a single set of sources
for MAINMACHINE.
Signed-off-by: Denys Dmytriyenko <denys@ti.com>
-rw-r--r-- | recipes-bsp/ti-sci-fw/ti-sci-fw-source_2020.04.bb | 45 | ||||
-rw-r--r-- | recipes-bsp/ti-sci-fw/ti-sci-fw_2020.04.bb | 17 | ||||
-rw-r--r-- | recipes-bsp/ti-sci-fw/ti-sci-fw_2020.04.inc | 16 |
3 files changed, 62 insertions, 16 deletions
diff --git a/recipes-bsp/ti-sci-fw/ti-sci-fw-source_2020.04.bb b/recipes-bsp/ti-sci-fw/ti-sci-fw-source_2020.04.bb new file mode 100644 index 00000000..becf893e --- /dev/null +++ b/recipes-bsp/ti-sci-fw/ti-sci-fw-source_2020.04.bb | |||
@@ -0,0 +1,45 @@ | |||
1 | # ti-sci-fw builds and packages multiple config variants via multiconfig | ||
2 | # Let's take a page from gcc-source as a common recipe for all gcc stages, | ||
3 | # but also to provide a single package for MAINMACHINE of all multiconfigs | ||
4 | |||
5 | require recipes-bsp/ti-sci-fw/ti-sci-fw_${PV}.inc | ||
6 | |||
7 | SUMMARY += "- sources" | ||
8 | |||
9 | COMPATIBLE_MACHINE = "k3" | ||
10 | |||
11 | EXCLUDE_FROM_WORLD = "1" | ||
12 | INHIBIT_DEFAULT_DEPS = "1" | ||
13 | DEPENDS = "" | ||
14 | |||
15 | PACKAGES = "${PN}" | ||
16 | PACKAGE_ARCH = "${MACHINE_ARCH}" | ||
17 | |||
18 | do_configure[noexec] = "1" | ||
19 | do_compile[noexec] = "1" | ||
20 | |||
21 | SRCIPK_SRC_DIR = "${WORKDIR}/imggen" | ||
22 | SRCIPK_INSTALL_DIR = "board-support/k3-image-gen-${PV}" | ||
23 | FILES_${PN} = "${SRCIPK_INSTALL_DIR}" | ||
24 | |||
25 | do_install() { | ||
26 | # Copy sources for packaging | ||
27 | mkdir -p ${D}/${SRCIPK_INSTALL_DIR} | ||
28 | if [ -e ${SRCIPK_SRC_DIR} ]; then | ||
29 | if [ "${SRCIPK_SRC_DIR}" = "${WORKDIR}" ]; then | ||
30 | excludes='--exclude ./temp --exclude ${D}' | ||
31 | fi | ||
32 | tar -C ${SRCIPK_SRC_DIR} -cO $excludes . | tar -C ${D}/${SRCIPK_INSTALL_DIR} -xpf - | ||
33 | fi | ||
34 | |||
35 | # Fix up patches/ directory to contain actual patches instead of symlinks | ||
36 | if [ -e ${D}/${SRCIPK_INSTALL_DIR}/patches ] | ||
37 | then | ||
38 | mv ${D}/${SRCIPK_INSTALL_DIR}/patches ${D}/${SRCIPK_INSTALL_DIR}/patches-links | ||
39 | cp -rL ${D}/${SRCIPK_INSTALL_DIR}/patches-links ${D}/${SRCIPK_INSTALL_DIR}/patches | ||
40 | rm -rf ${D}/${SRCIPK_INSTALL_DIR}/patches-links | ||
41 | fi | ||
42 | } | ||
43 | |||
44 | # Do not perform any QA checks on source package | ||
45 | INSANE_SKIP_${PN} += "${ALL_QA}" | ||
diff --git a/recipes-bsp/ti-sci-fw/ti-sci-fw_2020.04.bb b/recipes-bsp/ti-sci-fw/ti-sci-fw_2020.04.bb index add4ee93..b5588265 100644 --- a/recipes-bsp/ti-sci-fw/ti-sci-fw_2020.04.bb +++ b/recipes-bsp/ti-sci-fw/ti-sci-fw_2020.04.bb | |||
@@ -1,7 +1,4 @@ | |||
1 | SUMMARY = "TI SCI firmware (SYSFW)" | 1 | require recipes-bsp/ti-sci-fw/ti-sci-fw_${PV}.inc |
2 | |||
3 | LICENSE = "TI-TFL" | ||
4 | LIC_FILES_CHKSUM = "file://LICENSE.ti;md5=b5aebf0668bdf95621259288c4a46d76" | ||
5 | 2 | ||
6 | DEPENDS = "openssl-native u-boot-mkimage-native dtc-native" | 3 | DEPENDS = "openssl-native u-boot-mkimage-native dtc-native" |
7 | 4 | ||
@@ -17,18 +14,6 @@ PACKAGE_ARCH = "${MACHINE_ARCH}" | |||
17 | TI_SECURE_DEV_PKG ?= "" | 14 | TI_SECURE_DEV_PKG ?= "" |
18 | export TI_SECURE_DEV_PKG | 15 | export TI_SECURE_DEV_PKG |
19 | 16 | ||
20 | SRCREV = "6b02b1ea07da65a68444e86439ad5b031e9fd5a2" | ||
21 | BRANCH ?= "ti-linux-firmware" | ||
22 | SRCREV_imggen = "a7d3909ed8ae23a7c90f7ef821713a8b0c3c061d" | ||
23 | SRCREV_FORMAT = "imggen" | ||
24 | |||
25 | SRC_URI = " \ | ||
26 | git://git.ti.com/processor-firmware/ti-linux-firmware.git;protocol=git;branch=${BRANCH} \ | ||
27 | git://git.ti.com/k3-image-gen/k3-image-gen.git;protocol=git;branch=master;destsuffix=imggen;name=imggen \ | ||
28 | " | ||
29 | |||
30 | S = "${WORKDIR}/git" | ||
31 | |||
32 | SYSFW_SOC ?= "unknown" | 17 | SYSFW_SOC ?= "unknown" |
33 | SYSFW_CONFIG ?= "unknown" | 18 | SYSFW_CONFIG ?= "unknown" |
34 | 19 | ||
diff --git a/recipes-bsp/ti-sci-fw/ti-sci-fw_2020.04.inc b/recipes-bsp/ti-sci-fw/ti-sci-fw_2020.04.inc new file mode 100644 index 00000000..429d077b --- /dev/null +++ b/recipes-bsp/ti-sci-fw/ti-sci-fw_2020.04.inc | |||
@@ -0,0 +1,16 @@ | |||
1 | SUMMARY = "TI SCI firmware (SYSFW)" | ||
2 | |||
3 | LICENSE = "TI-TFL" | ||
4 | LIC_FILES_CHKSUM = "file://LICENSE.ti;md5=b5aebf0668bdf95621259288c4a46d76" | ||
5 | |||
6 | SRCREV = "6b02b1ea07da65a68444e86439ad5b031e9fd5a2" | ||
7 | BRANCH ?= "ti-linux-firmware" | ||
8 | SRCREV_imggen = "a7d3909ed8ae23a7c90f7ef821713a8b0c3c061d" | ||
9 | SRCREV_FORMAT = "imggen" | ||
10 | |||
11 | SRC_URI = " \ | ||
12 | git://git.ti.com/processor-firmware/ti-linux-firmware.git;protocol=git;branch=${BRANCH} \ | ||
13 | git://git.ti.com/k3-image-gen/k3-image-gen.git;protocol=git;branch=master;destsuffix=imggen;name=imggen \ | ||
14 | " | ||
15 | |||
16 | S = "${WORKDIR}/git" | ||