summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorRandolph Sapp <rs@ti.com>2024-05-02 14:18:43 -0500
committerRyan Eatmon <reatmon@ti.com>2024-05-02 15:01:10 -0500
commitc7f07f1bf01fc691ac5be5cb73a16009a569f0d5 (patch)
tree52b1e2885d4aadb7c6e37b39ca28b6106e58599a
parentc4bee16aaa2b387bbbdec0ebe69d4472323ea89e (diff)
downloadmeta-ti-c7f07f1bf01fc691ac5be5cb73a16009a569f0d5.tar.gz
mesa-pvr_23.2.1: add recipe for 23.2.1
Add a recipe for mesa-pvr to use a newer branch based on mesa 23.2.1. This branch does not currently contain SGX patches so it is also being masked by the ltsprep branding to prevent regressing those devices currently. Please note that may run into sstate errors when switching to or away from the ltsprep tag. Please issue a clean to mesa and ti-img-rogue-umlibs if you get warnings from either package's do_create_runtime_spdx step. Signed-off-by: Randolph Sapp <rs@ti.com> Signed-off-by: Ryan Eatmon <reatmon@ti.com>
-rw-r--r--meta-ti-bsp/recipes-graphics/mesa/mesa-pvr_23.2.1.bb58
1 files changed, 58 insertions, 0 deletions
diff --git a/meta-ti-bsp/recipes-graphics/mesa/mesa-pvr_23.2.1.bb b/meta-ti-bsp/recipes-graphics/mesa/mesa-pvr_23.2.1.bb
new file mode 100644
index 00000000..1e66acd2
--- /dev/null
+++ b/meta-ti-bsp/recipes-graphics/mesa/mesa-pvr_23.2.1.bb
@@ -0,0 +1,58 @@
1# PowerVR Graphics require several patches that have not made their way
2# upstream yet. This allows us to build the shims we need without completely
3# clobbering mesa.
4
5DEFAULT_PREFERENCE = "-1"
6
7require recipes-graphics/mesa/mesa.inc
8
9SUMMARY += " (with PowerVR support for TI platforms)"
10
11LIC_FILES_CHKSUM = "file://docs/license.rst;md5=63779ec98d78d823a9dc533a0735ef10"
12
13BRANCH = "powervr/${PV}"
14
15SRC_URI = " \
16 git://gitlab.freedesktop.org/StaticRocket/mesa.git;protocol=https;branch=${BRANCH} \
17 file://0001-meson.build-check-for-all-linux-host_os-combinations.patch \
18 file://0001-meson-misdetects-64bit-atomics-on-mips-clang.patch \
19 file://0001-gallium-Fix-build-with-llvm-17.patch \
20 file://0001-meson-Disable-cmake-dependency-detector-for-llvm.patch \
21"
22
23S = "${WORKDIR}/git"
24
25PACKAGECONFIG:append = " \
26 ${@bb.utils.contains('PREFERRED_PROVIDER_virtual/gpudriver', 'ti-img-rogue-driver', 'pvr', '', d)} \
27 ${@bb.utils.contains('PREFERRED_PROVIDER_virtual/gpudriver', 'ti-sgx-ddk-km', 'sgx', '', d)} \
28"
29
30SRCREV = "b12290126ba6a154f0e8b0a8c8b2b0d64f98e427"
31
32PVR_DISPLAY_CONTROLLER_ALIAS ??= "tidss"
33PACKAGECONFIG[pvr] = "-Dgallium-pvr-alias=${PVR_DISPLAY_CONTROLLER_ALIAS},"
34PACKAGECONFIG[sgx] = "-Dgallium-sgx-alias=${PVR_DISPLAY_CONTROLLER_ALIAS},"
35
36PACKAGECONFIG:remove = "video-codecs"
37PACKAGECONFIG[video-codecs] = ""
38PACKAGECONFIG:remove = "elf-tls"
39PACKAGECONFIG[elf-tls] = ""
40PACKAGECONFIG:remove = "xvmc"
41PACKAGECONFIG[xvmc] = ""
42
43PACKAGE_ARCH = "${MACHINE_ARCH}"
44
45GALLIUMDRIVERS:append = "${@bb.utils.contains('PACKAGECONFIG', 'pvr', ',pvr', '', d)}"
46GALLIUMDRIVERS:append = "${@bb.utils.contains('PACKAGECONFIG', 'sgx', ',sgx', '', d)}"
47
48VULKAN_DRIVERS:append = "${@bb.utils.contains('PACKAGECONFIG', 'pvr', ',pvr', '', d)}"
49
50do_install:append () {
51 # remove pvr custom pkgconfig
52 rm -rf ${D}${datadir}/pkgconfig
53}
54
55FILES:${PN}-dev += "${datadir}/mesa/wayland-drm.xml"
56FILES:mesa-vulkan-drivers += "${libdir}/libpvr_mesa_wsi.so"
57
58RRECOMMENDS:mesa-megadriver:append:class-target = " ${@d.getVar('PREFERRED_PROVIDER_virtual/gpudriver')}"