summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorBrandon Brnich <b-brnich@ti.com>2025-03-06 14:37:48 -0600
committerRyan Eatmon <reatmon@ti.com>2025-03-07 09:24:08 -0600
commit7399e278f43a5ef859b89dca473b84eb518668e9 (patch)
tree939e1353b03b9cb29a413e31571fa2fd4ab84bac
parenta7009ced679e620710fabf4590ccb99fc01876f1 (diff)
downloadmeta-ti-7399e278f43a5ef859b89dca473b84eb518668e9.tar.gz
ti-bsp: ti-img-encode-decode: Add Recipe for Building VXE-VXD Out-of-Tree Module
During 10.0 LTS bringup, the decision was made that it would be the last LTS that carried the IMG VXE and VXD driver in tree. Driver is now hosted on git.ti.com. This recipe is responsible for pulling in the driver, building it, and packaging it within the J721e SDK. Signed-off-by: Brandon Brnich <b-brnich@ti.com> Signed-off-by: Ryan Eatmon <reatmon@ti.com>
-rw-r--r--meta-ti-bsp/recipes-bsp/ti-img-encode-decode/ti-vxe-vxd-driver_6.12.bb23
1 files changed, 23 insertions, 0 deletions
diff --git a/meta-ti-bsp/recipes-bsp/ti-img-encode-decode/ti-vxe-vxd-driver_6.12.bb b/meta-ti-bsp/recipes-bsp/ti-img-encode-decode/ti-vxe-vxd-driver_6.12.bb
new file mode 100644
index 00000000..fa2d3792
--- /dev/null
+++ b/meta-ti-bsp/recipes-bsp/ti-img-encode-decode/ti-vxe-vxd-driver_6.12.bb
@@ -0,0 +1,23 @@
1DESCRIPTION = "Kernel drivers for the VXE384 and D5500 Video Accelerators found in the J721E TI SoC"
2LICENSE = "GPL-2.0-only"
3LIC_FILES_CHKSUM = "file://README;beginline=11;endline=12;md5=ad10b552e357ac443ec5dd2e02912b1b"
4
5inherit module
6
7PACKAGE_ARCH = "${MACHINE_ARCH}"
8
9COMPATIBLE_MACHINE = "j721e"
10
11DEPENDS += "virtual/kernel"
12
13BRANCH = "scarthgap/k${PV}"
14
15SRC_URI = "git://git.ti.com/multimedia/img-vxe-vxd.git;protocol=https;branch=${BRANCH}"
16
17SRCREV = "99d063aa0ef53633057042570411b84bd967624b"
18
19TARGET_PRODUCT:j721e = "j721e_linux"
20
21S = "${WORKDIR}/git"
22
23EXTRA_OEMAKE += 'KERNEL_DIR="${STAGING_KERNEL_DIR}" PREFIX="${D}"'