summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorDenys Dmytriyenko <denys@konsulko.com>2025-02-19 16:48:01 -0500
committerRyan Eatmon <reatmon@ti.com>2025-02-20 09:24:51 -0600
commit235e3d5543f88fd46baa75ae6c9157dfa25db0b2 (patch)
treec25385d0f8b3338cac0d92574110254c1756c666
parentc3d050c2c9db34e250b4b61e90a67bacbfa45066 (diff)
downloadmeta-ti-235e3d5543f88fd46baa75ae6c9157dfa25db0b2.tar.gz
trusted-firmware-a: simplify TI customizations
The original .bbappend started with just a few customizations behind a :k3 SoC override, but eventually grew in size. It got converted into a .inc file, which is behind the same SoC override and hence it gets included by .bbappend only for K3 platforms: https://git.yoctoproject.org/meta-ti/commit/?id=389f9a8b726868768a8bed6cbe0b2a1f18c05410 It doesn't make sense to use the same :k3 override inside this .inc file for every variable. Moreover, it makes it harder to change those variables downstream for any derivative platform or even for upstream testing. This change drops redundant :k3 SoC overrides, w/o changing existing behavior. It allows easier modifications of such customizations from downstream layers or a local.conf, e.g. SRC_URI_TRUSTED_FIRMWARE_A Note that SRC_URI is set exactly the same as in upstream base .inc file, but version-specific recipes in meta-arm tend to add extra patches directly to SRC_URI, which is undesirable here. Thus, reset SRC_URI back to its default. Signed-off-by: Denys Dmytriyenko <denys@konsulko.com> Signed-off-by: Ryan Eatmon <reatmon@ti.com>
-rw-r--r--meta-ti-bsp/recipes-bsp/trusted-firmware-a/trusted-firmware-a-ti.inc26
1 files changed, 16 insertions, 10 deletions
diff --git a/meta-ti-bsp/recipes-bsp/trusted-firmware-a/trusted-firmware-a-ti.inc b/meta-ti-bsp/recipes-bsp/trusted-firmware-a/trusted-firmware-a-ti.inc
index 9971e960..21aef489 100644
--- a/meta-ti-bsp/recipes-bsp/trusted-firmware-a/trusted-firmware-a-ti.inc
+++ b/meta-ti-bsp/recipes-bsp/trusted-firmware-a/trusted-firmware-a-ti.inc
@@ -1,14 +1,20 @@
1PV:k3 = "2.12+git" 1# NOTE: This .inc file with customizations only gets included for K3 platforms
2SRCREV_tfa:k3 = "5227171c079d0c7d22a6d37b5cec079c8c5bb4b1" 2
3LIC_FILES_CHKSUM:k3 = "file://docs/license.rst;md5=1118e32884721c0be33267bd7ae11130" 3PV = "2.12+git"
4SRC_URI:k3 = "git://github.com/TexasInstruments/arm-trusted-firmware.git;protocol=https;name=tfa;branch=ti-master" 4SRCREV_tfa = "5227171c079d0c7d22a6d37b5cec079c8c5bb4b1"
5COMPATIBLE_MACHINE:k3 = "k3" 5SRC_URI_TRUSTED_FIRMWARE_A = "git://github.com/TexasInstruments/arm-trusted-firmware.git;protocol=https"
6TFA_BUILD_TARGET:k3 = "all" 6SRCBRANCH = "ti-master"
7TFA_INSTALL_TARGET:k3 = "bl31" 7SRC_URI = "${SRC_URI_TRUSTED_FIRMWARE_A};name=tfa;branch=${SRCBRANCH}"
8TFA_SPD:k3 = "opteed" 8
9LIC_FILES_CHKSUM = "file://docs/license.rst;md5=1118e32884721c0be33267bd7ae11130"
10COMPATIBLE_MACHINE = "k3"
11
12TFA_BUILD_TARGET = "all"
13TFA_INSTALL_TARGET = "bl31"
14TFA_SPD = "opteed"
9 15
10# For am62lxx, install bl1 & bl31 using TFA_INSTALL_TARGET 16# For am62lxx, install bl1 & bl31 using TFA_INSTALL_TARGET
11TFA_INSTALL_TARGET:am62lxx = "bl31 bl1" 17TFA_INSTALL_TARGET:am62lxx = "bl31 bl1"
12 18
13EXTRA_OEMAKE:append:k3 = "${@ ' K3_USART=' + d.getVar('TFA_K3_USART') if d.getVar('TFA_K3_USART') else ''}" 19EXTRA_OEMAKE += "${@ 'K3_USART=' + d.getVar('TFA_K3_USART') if d.getVar('TFA_K3_USART') else ''}"
14EXTRA_OEMAKE:append:k3 = "${@ ' K3_PM_SYSTEM_SUSPEND=' + d.getVar('TFA_K3_SYSTEM_SUSPEND') if d.getVar('TFA_K3_SYSTEM_SUSPEND') else ''}" 20EXTRA_OEMAKE += "${@ 'K3_PM_SYSTEM_SUSPEND=' + d.getVar('TFA_K3_SYSTEM_SUSPEND') if d.getVar('TFA_K3_SYSTEM_SUSPEND') else ''}"