summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorSam Nelson <sam.nelson@ti.com>2017-03-14 03:13:02 +0000
committerDenys Dmytriyenko <denys@ti.com>2017-03-15 17:44:01 -0400
commitb31bb0462bf8a1ae70fb6141b02b32778996e640 (patch)
treee66d26df42ec6a5362c68e126557a5fddb4aa743
parent2a474f9f2cc6972f337f09805f0af17b371033d5 (diff)
downloadmeta-ti-b31bb0462bf8a1ae70fb6141b02b32778996e640.tar.gz
ti-ipc-rtos: Update to remove host-user-contaminated warnings
Update to copy NOT to preserve ownership (but to preserve mode and timestamps) Signed-off-by: Sam Nelson <sam.nelson@ti.com> Signed-off-by: Denys Dmytriyenko <denys@ti.com>
-rw-r--r--recipes-ti/ipc/ti-ipc-rtos.inc2
-rw-r--r--recipes-ti/ipc/ti-ipc-rtos_git.bb5
2 files changed, 4 insertions, 3 deletions
diff --git a/recipes-ti/ipc/ti-ipc-rtos.inc b/recipes-ti/ipc/ti-ipc-rtos.inc
index 7f029a72..b29e984a 100644
--- a/recipes-ti/ipc/ti-ipc-rtos.inc
+++ b/recipes-ti/ipc/ti-ipc-rtos.inc
@@ -37,7 +37,7 @@ S_ipc-metadata = "${WORKDIR}/git/ipc-metadata"
37RELEASE_TYPE = "GA" 37RELEASE_TYPE = "GA"
38RELEASE_SUFFIX = "" 38RELEASE_SUFFIX = ""
39 39
40PR = "${INC_PR}.2" 40PR = "${INC_PR}.3"
41 41
42DEPENDS_append_keystone = " ti-cgt6x-native \ 42DEPENDS_append_keystone = " ti-cgt6x-native \
43 gcc-arm-none-eabi-native \ 43 gcc-arm-none-eabi-native \
diff --git a/recipes-ti/ipc/ti-ipc-rtos_git.bb b/recipes-ti/ipc/ti-ipc-rtos_git.bb
index f0ccb104..018634c2 100644
--- a/recipes-ti/ipc/ti-ipc-rtos_git.bb
+++ b/recipes-ti/ipc/ti-ipc-rtos_git.bb
@@ -62,13 +62,14 @@ do_compile() {
62} 62}
63 63
64do_install() { 64do_install() {
65 CP_ARGS="-Prf --preserve=mode,timestamps --no-preserve=ownership"
65 IPC_VERSION=`echo ${PV}${RELEASE_SUFFIX} | sed -e 's|\.|_|g'` 66 IPC_VERSION=`echo ${PV}${RELEASE_SUFFIX} | sed -e 's|\.|_|g'`
66 # Copy docs and other meta files 67 # Copy docs and other meta files
67 install -d ${D}${IPC_INSTALL_DIR_RECIPE} 68 install -d ${D}${IPC_INSTALL_DIR_RECIPE}
68 cp -pPrf ${IPC_PACKAGE_DIR}/* -d ${D}${IPC_INSTALL_DIR_RECIPE} 69 cp ${CP_ARGS} ${IPC_PACKAGE_DIR}/* -d ${D}${IPC_INSTALL_DIR_RECIPE}
69 70
70 install -d ${D}${base_libdir}/firmware/ipc 71 install -d ${D}${base_libdir}/firmware/ipc
71 cp -pPrf ${S}/packages/ti/ipc/tests/bin/* ${D}${base_libdir}/firmware/ipc || true 72 cp ${CP_ARGS} ${S}/packages/ti/ipc/tests/bin/* ${D}${base_libdir}/firmware/ipc || true
72} 73}
73 74
74ALTERNATIVE_PRIORITY = "5" 75ALTERNATIVE_PRIORITY = "5"