summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorKarthik Ramanan <a0393906@ti.com>2017-10-27 21:59:32 +0000
committerDenys Dmytriyenko <denys@ti.com>2017-11-02 21:44:12 -0400
commita001bbba99a9c1a06e9f7e3084ec670c304b73c9 (patch)
tree9e751cc5aa793f7bab41c519984e4e73b0455f36
parent0edce56657b38e45ec171bf884b2d6172d0379a0 (diff)
downloadmeta-ti-a001bbba99a9c1a06e9f7e3084ec670c304b73c9.tar.gz
ti-cgt-arm: add recipe for 16.9.2
Signed-off-by: Karthik Ramanan <a0393906@ti.com> Signed-off-by: Denys Dmytriyenko <denys@ti.com> from: meta-ti/morty 5df5bd9 Signed-off-by: Karthik Ramanan <a0393906@ti.com> Signed-off-by: Denys Dmytriyenko <denys@ti.com>
-rw-r--r--recipes-ti/devtools/ti-cgt-arm-native_16.9.2.bb6
-rw-r--r--recipes-ti/devtools/ti-cgt-arm.inc34
2 files changed, 40 insertions, 0 deletions
diff --git a/recipes-ti/devtools/ti-cgt-arm-native_16.9.2.bb b/recipes-ti/devtools/ti-cgt-arm-native_16.9.2.bb
new file mode 100644
index 00000000..8ff29ca8
--- /dev/null
+++ b/recipes-ti/devtools/ti-cgt-arm-native_16.9.2.bb
@@ -0,0 +1,6 @@
1include ti-cgt-arm.inc
2
3LIC_FILES_CHKSUM = "file://ti-cgt-arm_${PV}.LTS/README.txt;md5=c32eadd03472353c042a8a7c4568438b"
4
5BINFILE_MD5 = "7b73e51e9548a4a0bf3923a336b1a974"
6BINFILE_SHA256 = "d1a5c255319088be7d75b3fce1b16a2e3d60c75023db7dad16cab6d4d3425d06"
diff --git a/recipes-ti/devtools/ti-cgt-arm.inc b/recipes-ti/devtools/ti-cgt-arm.inc
new file mode 100644
index 00000000..436fab12
--- /dev/null
+++ b/recipes-ti/devtools/ti-cgt-arm.inc
@@ -0,0 +1,34 @@
1SUMMARY = "TI ARM Code Generation Tools"
2HOMEPAGE = "https://www-a.ti.com/downloads/sds_support/TICodegenerationTools/download.htm"
3LICENSE = "(TI-TSPA & Thai-Open-Source-Software-Center) & BSD-3-Clause & BSL-1.0 & Hewlett-Packard & AFL-3.0 & MIT & BSD-2-Clause & PD & BSD-4-Clause"
4
5inherit native
6require recipes-ti/includes/ti-unpack.inc
7require recipes-ti/includes/ti-staging.inc
8require recipes-ti/includes/ti-paths.inc
9
10S = "${WORKDIR}/ti-cgt-arm-${PV}"
11
12SRC_URI = "http://software-dl.ti.com/codegen/esd/cgt_public_sw/TMS470/${PV}.LTS/${BINFILE};name=${BINFILE_NAME}"
13
14BINFILE = "ti_cgt_tms470_${PV}.LTS_linux_installer_x86.bin"
15TI_BIN_UNPK_ARGS = "--prefix ${S}"
16TI_BIN_UNPK_CMDS = ""
17
18do_install() {
19 install -d ${D}${M4_TOOLCHAIN_INSTALL_DIR_RECIPE}
20 cp -r ${S}/ti-cgt-arm*/. ${D}${M4_TOOLCHAIN_INSTALL_DIR_RECIPE}
21}
22
23SRC_URI[cgt_arm_installer.md5sum] = "${BINFILE_MD5}"
24SRC_URI[cgt_arm_installer.sha256sum] = "${BINFILE_SHA256}"
25
26BINFILE_NAME = "cgt_arm_installer"
27
28FILES_${PN} += "${M4_TOOLCHAIN_INSTALL_DIR_RECIPE}"
29
30INHIBIT_PACKAGE_STRIP = "1"
31INHIBIT_SYSROOT_STRIP = "1"
32INHIBIT_PACKAGE_DEBUG_SPLIT = "1"
33
34INSANE_SKIP_${PN} += "arch staticdev"