summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorChirag Shilwant <c-shilwant@ti.com>2024-02-12 15:15:52 +0530
committerRyan Eatmon <reatmon@ti.com>2024-02-12 08:52:55 -0600
commitc19e78af502d89af00cf0239952a76a284e03b68 (patch)
tree769d1fe769996ff609917c67071d878906fa5a53
parent75cb95609f08fd493edff59ce2888c95b1c73643 (diff)
downloadmeta-ti-c19e78af502d89af00cf0239952a76a284e03b68.tar.gz
conf: machine: Apply U-boot fragment configs for AM62P Display Cluster Image
- For AM62P tisdk-display-cluster image[1], Splash Screen is handled by SBL[2]. Hence, disable the A53 based U-boot Splash Screen using the am62px_evm_prune_splashscreen.config fragment present in ti-u-boot tree. - Apply a check on DISPLAY_CLUSTER_ENABLE variable[3] to ensure we apply am62px_evm_prune_splashscreen.config only incase of tisdk-display-cluster image as tisdk-default-image will still have the A53 based U-boot Splash Screen. References ---------- [1] https://git.ti.com/cgit/ti-sdk-linux/meta-tisdk/tree/recipes-core/images/tisdk-display-cluster-image.bb?h=kirkstone [2] https://software-dl.ti.com/mcu-plus-sdk/esd/AM62PX/09_01_00_39/exports/docs/api_guide_am62px/EXAMPLES_DRIVERS_DSS_DISPLAY_SHARE.html [3] https://software-dl.ti.com/processor-sdk-linux/esd/AM62PX/09_01_00_08/exports/docs/linux/Overview_Building_the_SDK.html#build-steps Signed-off-by: Chirag Shilwant <c-shilwant@ti.com> Signed-off-by: Ryan Eatmon <reatmon@ti.com>
-rw-r--r--meta-ti-bsp/conf/machine/am62pxx-evm.conf7
1 files changed, 7 insertions, 0 deletions
diff --git a/meta-ti-bsp/conf/machine/am62pxx-evm.conf b/meta-ti-bsp/conf/machine/am62pxx-evm.conf
index d7c9f589..95602116 100644
--- a/meta-ti-bsp/conf/machine/am62pxx-evm.conf
+++ b/meta-ti-bsp/conf/machine/am62pxx-evm.conf
@@ -16,3 +16,10 @@ KERNEL_DEVICETREE = " \
16" 16"
17 17
18UBOOT_MACHINE = "am62px_evm_a53_defconfig" 18UBOOT_MACHINE = "am62px_evm_a53_defconfig"
19
20# UBOOT_CONFIG_FRAGMENTS holds the list of u-boot config fragments which has to be build
21# along with the base defconfig mentioned in UBOOT_MACHINE. Refer u-boot-mergeconfig.inc
22# under meta-ti-bsp/recipes-bsp/u-boot/ for more details.
23# For AM62P tisdk-display-cluster image, splash screen is handled by SBL.
24# Hence, disable the A53 based splash screen using the am62px_evm_prune_splashscreen.config fragment present in ti-u-boot tree
25UBOOT_CONFIG_FRAGMENTS = "${@oe.utils.conditional('DISPLAY_CLUSTER_ENABLE', '1', 'am62px_evm_prune_splashscreen.config', '', d)}"