summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorRandolph Sapp <rs@ti.com>2023-10-27 17:21:59 -0500
committerRyan Eatmon <reatmon@ti.com>2023-10-28 14:57:06 -0500
commitb14173ea0a4fe06c298f54b65c5dead02c237315 (patch)
treeda74fb4aea8c7eb9b6f3e3bce72e669ac7c1737c
parent29346b7a3c935ad8daf13242e0d8fa5b33d3c425 (diff)
downloadmeta-ti-b14173ea0a4fe06c298f54b65c5dead02c237315.tar.gz
ti-img-rogue-*: add am62p support
Add the configuration options for am62pxx-evm. This also adds support for new devicetree properties to override the clock value of the device. See the kernel module modifications [1] and dt bindings for more information. [1] https://git.ti.com/cgit/graphics/ti-img-rogue-driver/log/?h=linuxws/kirkstone/k6.1/23.2.6460340 Signed-off-by: Randolph Sapp <rs@ti.com> Signed-off-by: Ryan Eatmon <reatmon@ti.com>
-rw-r--r--meta-ti-bsp/recipes-bsp/powervr-drivers/ti-img-rogue-driver_23.2.6460340.bb3
-rw-r--r--meta-ti-bsp/recipes-graphics/powervr-umlibs/ti-img-rogue-umlibs_23.2.6460340.bb3
2 files changed, 4 insertions, 2 deletions
diff --git a/meta-ti-bsp/recipes-bsp/powervr-drivers/ti-img-rogue-driver_23.2.6460340.bb b/meta-ti-bsp/recipes-bsp/powervr-drivers/ti-img-rogue-driver_23.2.6460340.bb
index d46699ca..a74cc7b8 100644
--- a/meta-ti-bsp/recipes-bsp/powervr-drivers/ti-img-rogue-driver_23.2.6460340.bb
+++ b/meta-ti-bsp/recipes-bsp/powervr-drivers/ti-img-rogue-driver_23.2.6460340.bb
@@ -12,7 +12,7 @@ PR = "${MACHINE_KERNEL_PR}"
12 12
13PACKAGE_ARCH = "${MACHINE_ARCH}" 13PACKAGE_ARCH = "${MACHINE_ARCH}"
14 14
15COMPATIBLE_MACHINE = "j721e|j721s2|j784s4|am62xx" 15COMPATIBLE_MACHINE = "j721e|j721s2|j784s4|am62xx|am62pxx"
16 16
17DEPENDS = "virtual/kernel" 17DEPENDS = "virtual/kernel"
18 18
@@ -28,6 +28,7 @@ TARGET_PRODUCT:j721e = "j721e_linux"
28TARGET_PRODUCT:j721s2 = "j721s2_linux" 28TARGET_PRODUCT:j721s2 = "j721s2_linux"
29TARGET_PRODUCT:j784s4 = "j784s4_linux" 29TARGET_PRODUCT:j784s4 = "j784s4_linux"
30TARGET_PRODUCT:am62xx = "am62_linux" 30TARGET_PRODUCT:am62xx = "am62_linux"
31TARGET_PRODUCT:am62pxx = "am62p_linux"
31PVR_BUILD = "release" 32PVR_BUILD = "release"
32PVR_WS = "lws-generic" 33PVR_WS = "lws-generic"
33 34
diff --git a/meta-ti-bsp/recipes-graphics/powervr-umlibs/ti-img-rogue-umlibs_23.2.6460340.bb b/meta-ti-bsp/recipes-graphics/powervr-umlibs/ti-img-rogue-umlibs_23.2.6460340.bb
index 121c4cc5..447812d3 100644
--- a/meta-ti-bsp/recipes-graphics/powervr-umlibs/ti-img-rogue-umlibs_23.2.6460340.bb
+++ b/meta-ti-bsp/recipes-graphics/powervr-umlibs/ti-img-rogue-umlibs_23.2.6460340.bb
@@ -6,7 +6,7 @@ LIC_FILES_CHKSUM = "file://${WORKDIR}/git/LICENSE;md5=7232b98c1c58f99e3baa03de52
6inherit bin_package 6inherit bin_package
7 7
8PACKAGE_ARCH = "${MACHINE_ARCH}" 8PACKAGE_ARCH = "${MACHINE_ARCH}"
9COMPATIBLE_MACHINE = "j721e|j721s2|j784s4|am62xx" 9COMPATIBLE_MACHINE = "j721e|j721s2|j784s4|am62xx|am62pxx"
10 10
11PR = "r2" 11PR = "r2"
12 12
@@ -19,6 +19,7 @@ TARGET_PRODUCT:j721e = "j721e_linux"
19TARGET_PRODUCT:j721s2 = "j721s2_linux" 19TARGET_PRODUCT:j721s2 = "j721s2_linux"
20TARGET_PRODUCT:j784s4 = "j784s4_linux" 20TARGET_PRODUCT:j784s4 = "j784s4_linux"
21TARGET_PRODUCT:am62xx = "am62_linux" 21TARGET_PRODUCT:am62xx = "am62_linux"
22TARGET_PRODUCT:am62pxx = "am62p_linux"
22PVR_BUILD = "release" 23PVR_BUILD = "release"
23PVR_WS = "lws-generic" 24PVR_WS = "lws-generic"
24 25