summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorJacob Stiffler <j-stiffler@ti.com>2016-03-22 04:00:45 +0000
committerDenys Dmytriyenko <denys@ti.com>2016-03-22 15:09:54 -0400
commite39016cdd1542980c4dd2203566b952662b6ffcc (patch)
tree9d4e60cd9aa10b9f5923b9f9e1b6e7dd5618e95d
parent971e06dea5cdd4606189b4d7368040bc47407e50 (diff)
downloadmeta-ti-e39016cdd1542980c4dd2203566b952662b6ffcc.tar.gz
edma3-lld: Upgrade to version 2.12.1.23 and add k2g-evm support
Signed-off-by: Jacob Stiffler <j-stiffler@ti.com> Signed-off-by: Denys Dmytriyenko <denys@ti.com>
-rw-r--r--recipes-bsp/edma3-lld/edma3-lld-rtos_git.bb3
-rw-r--r--recipes-bsp/edma3-lld/edma3-lld.inc6
-rw-r--r--recipes-bsp/edma3-lld/edma3-lld_git.bb2
3 files changed, 7 insertions, 4 deletions
diff --git a/recipes-bsp/edma3-lld/edma3-lld-rtos_git.bb b/recipes-bsp/edma3-lld/edma3-lld-rtos_git.bb
index b1cedd08..1f1483ed 100644
--- a/recipes-bsp/edma3-lld/edma3-lld-rtos_git.bb
+++ b/recipes-bsp/edma3-lld/edma3-lld-rtos_git.bb
@@ -2,7 +2,7 @@ require edma3-lld.inc
2require recipes-ti/includes/ti-paths.inc 2require recipes-ti/includes/ti-paths.inc
3require recipes-ti/includes/ti-staging.inc 3require recipes-ti/includes/ti-staging.inc
4 4
5PR = "${INC_PR}.2" 5PR = "${INC_PR}.0"
6 6
7DEPENDS = "ti-sysbios ti-xdctools gcc-arm-none-eabi-native ti-ccsv6-native ti-cgt6x-native" 7DEPENDS = "ti-sysbios ti-xdctools gcc-arm-none-eabi-native ti-ccsv6-native ti-cgt6x-native"
8 8
@@ -43,6 +43,7 @@ PLATFORMLIST_keystone = " \
43 tci6638k2k-evm \ 43 tci6638k2k-evm \
44 tci6630k2l-evm \ 44 tci6630k2l-evm \
45 c66ak2e-evm \ 45 c66ak2e-evm \
46 tci66ak2g02-evm \
46" 47"
47 48
48TARGETLIST_keystone = " \ 49TARGETLIST_keystone = " \
diff --git a/recipes-bsp/edma3-lld/edma3-lld.inc b/recipes-bsp/edma3-lld/edma3-lld.inc
index 533de83e..ff0ad479 100644
--- a/recipes-bsp/edma3-lld/edma3-lld.inc
+++ b/recipes-bsp/edma3-lld/edma3-lld.inc
@@ -6,12 +6,12 @@ EDMA3_LLD_GIT_URI = "git://git.ti.com/keystone-rtos/edma3_lld.git"
6EDMA3_LLD_GIT_PROTOCOL = "git" 6EDMA3_LLD_GIT_PROTOCOL = "git"
7EDMA3_LLD_GIT_BRANCH = "master" 7EDMA3_LLD_GIT_BRANCH = "master"
8 8
9# The following commit corresponds to tag DEV_EDMA3_LLD_02_12_01_21_RC1 9# The following commit corresponds to tag DEV_EDMA3_LLD_02_12_01_23A
10EDMA3_LLD_SRCREV = "9a94177958b9269b1b8aeeb2a5d362ca4e64dafa" 10EDMA3_LLD_SRCREV = "84c84a82332b30ece3b00f7d769270466ae836e0"
11 11
12BRANCH = "${EDMA3_LLD_GIT_BRANCH}" 12BRANCH = "${EDMA3_LLD_GIT_BRANCH}"
13SRC_URI = "${EDMA3_LLD_GIT_URI};protocol=${EDMA3_LLD_GIT_PROTOCOL};branch=${BRANCH}" 13SRC_URI = "${EDMA3_LLD_GIT_URI};protocol=${EDMA3_LLD_GIT_PROTOCOL};branch=${BRANCH}"
14SRCREV = "${EDMA3_LLD_SRCREV}" 14SRCREV = "${EDMA3_LLD_SRCREV}"
15 15
16PV = "2.12.01.22" 16PV = "2.12.01.23"
17INC_PR = "r0" 17INC_PR = "r0"
diff --git a/recipes-bsp/edma3-lld/edma3-lld_git.bb b/recipes-bsp/edma3-lld/edma3-lld_git.bb
index ec6ca47b..e197d0b1 100644
--- a/recipes-bsp/edma3-lld/edma3-lld_git.bb
+++ b/recipes-bsp/edma3-lld/edma3-lld_git.bb
@@ -7,9 +7,11 @@ COMPATIBLE_MACHINE = "keystone"
7DEPENDS = "common-csl-ip" 7DEPENDS = "common-csl-ip"
8 8
9PLATFORMLIST = "tci6636k2h-evm \ 9PLATFORMLIST = "tci6636k2h-evm \
10 tci6636k2h-evm \
10 tci6638k2k-evm \ 11 tci6638k2k-evm \
11 tci6630k2l-evm \ 12 tci6630k2l-evm \
12 c66ak2e-evm \ 13 c66ak2e-evm \
14 tci66ak2g02-evm \
13 " 15 "
14 16
15PACKAGES =+ "${PN}-test" 17PACKAGES =+ "${PN}-test"