diff options
author | Gou, Hongmei <h-gou@ti.com> | 2015-12-04 01:21:57 +0000 |
---|---|---|
committer | Denys Dmytriyenko <denys@ti.com> | 2015-12-04 22:24:18 -0500 |
commit | bc10ffc2e4637a3c0cc020b686c93e92c93ee756 (patch) | |
tree | db668bc5a9fda760462822f90c067742b9513294 | |
parent | 05b45d714594ce81b35c6c089a960bbd4e698cf3 (diff) | |
download | meta-ti-bc10ffc2e4637a3c0cc020b686c93e92c93ee756.tar.gz |
imglib-c66x: add version 3.1.1.0
Signed-off-by: Hongmei Gou <h-gou@ti.com>
Signed-off-by: Denys Dmytriyenko <denys@ti.com>
-rw-r--r-- | recipes-ti/imglib/imglib-c66x.inc | 29 | ||||
-rw-r--r-- | recipes-ti/imglib/imglib-c66x_3.1.1.0.bb | 9 | ||||
-rw-r--r-- | recipes-ti/includes/ti-paths.inc | 2 |
3 files changed, 40 insertions, 0 deletions
diff --git a/recipes-ti/imglib/imglib-c66x.inc b/recipes-ti/imglib/imglib-c66x.inc new file mode 100644 index 00000000..3c76ad5e --- /dev/null +++ b/recipes-ti/imglib/imglib-c66x.inc | |||
@@ -0,0 +1,29 @@ | |||
1 | DESCRIPTION = "IMGLIB contains optimized general-purpose image/video processing routines for TI DSPs" | ||
2 | HOMEPAGE = "http://www.ti.com/tool/sprc264" | ||
3 | SECTION = "devel" | ||
4 | LICENSE = "BSD-3-Clause" | ||
5 | |||
6 | require ../includes/ti-paths.inc | ||
7 | require ../includes/ti-staging.inc | ||
8 | require ../includes/ti-unpack.inc | ||
9 | |||
10 | COMPATIBLE_MACHINE = "omap-a15|keystone" | ||
11 | |||
12 | SRC_URI = "http://software-dl.ti.com/sdoemb/sdoemb_public_sw/imglib/${PV}/exports/${BINFILE};name=imglib" | ||
13 | |||
14 | S = "${WORKDIR}/imglib-c66x-${PV}" | ||
15 | |||
16 | BINFILE = "imglib_c66x_${PV}_Linux.bin" | ||
17 | TI_BIN_UNPK_ARGS = "--mode silent --prefix ${S}" | ||
18 | TI_BIN_UNPK_CMDS = "" | ||
19 | |||
20 | do_install() { | ||
21 | install -d ${D}${IMGLIB_C66_INSTALL_DIR_RECIPE} | ||
22 | cp -pPrf ${S}/* ${D}${IMGLIB_C66_INSTALL_DIR_RECIPE} | ||
23 | } | ||
24 | |||
25 | ALLOW_EMPTY_${PN} = "1" | ||
26 | FILES_${PN}-dev += "${IMGLIB_C66_INSTALL_DIR_RECIPE}" | ||
27 | |||
28 | RDEPENDS_${PN}-dev += "perl" | ||
29 | INSANE_SKIP_${PN}-dev = "arch" | ||
diff --git a/recipes-ti/imglib/imglib-c66x_3.1.1.0.bb b/recipes-ti/imglib/imglib-c66x_3.1.1.0.bb new file mode 100644 index 00000000..e614352c --- /dev/null +++ b/recipes-ti/imglib/imglib-c66x_3.1.1.0.bb | |||
@@ -0,0 +1,9 @@ | |||
1 | require imglib-c66x.inc | ||
2 | |||
3 | PV = "3_1_1_0" | ||
4 | PR = "r1" | ||
5 | |||
6 | LIC_FILES_CHKSUM = "file://packages/ti/imglib/src/common/IMG_profile.h;beginline=1;endline=35;md5=a21fc16da34b650ce33a9a7143908667" | ||
7 | |||
8 | SRC_URI[imglib.md5sum] = "9d64f213e040899048446df5055deeca" | ||
9 | SRC_URI[imglib.sha256sum] = "f3153e51530f26cfc638efca7ca6ae1bbaf7736daf287fc972592372a676ed21" | ||
diff --git a/recipes-ti/includes/ti-paths.inc b/recipes-ti/includes/ti-paths.inc index 7d2211aa..2f253a03 100644 --- a/recipes-ti/includes/ti-paths.inc +++ b/recipes-ti/includes/ti-paths.inc | |||
@@ -51,6 +51,7 @@ export GCC_ARM_NONE_TOOLCHAIN_RECIPE = "${installdir}/gcc-arm-none-eabi" | |||
51 | export TI_CGT_PRU_INSTALL_DIR_RECIPE = "${installdir}/cgt-pru" | 51 | export TI_CGT_PRU_INSTALL_DIR_RECIPE = "${installdir}/cgt-pru" |
52 | export DSPLIB_C66_INSTALL_DIR_RECIPE = "${installdir}/ti-dsplib-c66x-tree" | 52 | export DSPLIB_C66_INSTALL_DIR_RECIPE = "${installdir}/ti-dsplib-c66x-tree" |
53 | export MATHLIB_C66_INSTALL_DIR_RECIPE = "${installdir}/ti-mathlib-c66x-tree" | 53 | export MATHLIB_C66_INSTALL_DIR_RECIPE = "${installdir}/ti-mathlib-c66x-tree" |
54 | export IMGLIB_C66_INSTALL_DIR_RECIPE = "${installdir}/ti-imglib-c66x-tree" | ||
54 | 55 | ||
55 | 56 | ||
56 | # This is where the tools will end up in sysroot | 57 | # This is where the tools will end up in sysroot |
@@ -93,6 +94,7 @@ export GCC_ARM_NONE_TOOLCHAIN = "${STAGING_DIR_NATIVE}${GCC_ARM_NONE_TOOLCH | |||
93 | export TI_CGT_PRU_INSTALL_DIR = "${STAGING_DIR_NATIVE}${TI_CGT_PRU_INSTALL_DIR_RECIPE}" | 94 | export TI_CGT_PRU_INSTALL_DIR = "${STAGING_DIR_NATIVE}${TI_CGT_PRU_INSTALL_DIR_RECIPE}" |
94 | export DSPLIB_C66_INSTALL_DIR = "${STAGING_DIR_TARGET}${DSPLIB_C66_INSTALL_DIR_RECIPE}" | 95 | export DSPLIB_C66_INSTALL_DIR = "${STAGING_DIR_TARGET}${DSPLIB_C66_INSTALL_DIR_RECIPE}" |
95 | export MATHLIB_C66_INSTALL_DIR = "${STAGING_DIR_TARGET}${MATHLIB_C66_INSTALL_DIR_RECIPE}" | 96 | export MATHLIB_C66_INSTALL_DIR = "${STAGING_DIR_TARGET}${MATHLIB_C66_INSTALL_DIR_RECIPE}" |
97 | export IMGLIB_C66_INSTALL_DIR = "${STAGING_DIR_TARGET}${IMGLIB_C66_INSTALL_DIR_RECIPE}" | ||
96 | 98 | ||
97 | DSPSUFFIX_omapl137 = "x674" | 99 | DSPSUFFIX_omapl137 = "x674" |
98 | DSPSUFFIX_omapl138 = "x674" | 100 | DSPSUFFIX_omapl138 = "x674" |