summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorHao Zhang <hzhang@ti.com>2014-05-19 19:51:43 +0000
committerDenys Dmytriyenko <denys@ti.com>2014-05-21 15:15:45 -0400
commitd8ca0d973948f0465f177d790d30e3dbba5cc2e9 (patch)
treeedcaf06541d913f17f376ccf84ae2c22618bf3a4
parent4be60cf6cf44ac270bf5a106d63830a03cba1d76 (diff)
downloadmeta-ti-d8ca0d973948f0465f177d790d30e3dbba5cc2e9.tar.gz
keystone: k2l-evm conf: add k2l-evm machine config
k2l-evm machine config shares the same Keystone SoC family, it has K2L EVM specific machine configuration for UBI image, boot monitor, U-boot, etc. Signed-off-by: Hao Zhang <hzhang@ti.com> Signed-off-by: Denys Dmytriyenko <denys@ti.com>
-rw-r--r--conf/machine/include/keystone.inc2
-rw-r--r--conf/machine/k2hk-evm.conf4
-rw-r--r--conf/machine/k2l-evm.conf30
-rw-r--r--recipes-bsp/boot-monitor/boot-monitor_git.bb7
4 files changed, 37 insertions, 6 deletions
diff --git a/conf/machine/include/keystone.inc b/conf/machine/include/keystone.inc
index 63f069ce..a9449b28 100644
--- a/conf/machine/include/keystone.inc
+++ b/conf/machine/include/keystone.inc
@@ -12,8 +12,6 @@ MACHINE_KERNEL_PR = "r7"
12 12
13KERNEL_IMAGETYPE = "uImage" 13KERNEL_IMAGETYPE = "uImage"
14 14
15UBOOT_MACHINE = "k2hk_evm_config"
16
17UBOOT_ENTRYPOINT = "0x80008000" 15UBOOT_ENTRYPOINT = "0x80008000"
18UBOOT_LOADADDRESS = "0x80008000" 16UBOOT_LOADADDRESS = "0x80008000"
19 17
diff --git a/conf/machine/k2hk-evm.conf b/conf/machine/k2hk-evm.conf
index 4b05f402..0ef6ad08 100644
--- a/conf/machine/k2hk-evm.conf
+++ b/conf/machine/k2hk-evm.conf
@@ -4,6 +4,10 @@
4 4
5require conf/machine/include/keystone.inc 5require conf/machine/include/keystone.inc
6 6
7UBOOT_MACHINE = "k2hk_evm_config"
8
9BOOT_MONITOR_MAKE_TARGET = "k2hk"
10
7IMAGE_FSTYPES += "ubi tar.gz cpio" 11IMAGE_FSTYPES += "ubi tar.gz cpio"
8 12
9SERIAL_CONSOLE = "115200 ttyS0" 13SERIAL_CONSOLE = "115200 ttyS0"
diff --git a/conf/machine/k2l-evm.conf b/conf/machine/k2l-evm.conf
new file mode 100644
index 00000000..0824a09b
--- /dev/null
+++ b/conf/machine/k2l-evm.conf
@@ -0,0 +1,30 @@
1#@TYPE: Machine
2#@NAME: Keystone 2 K2L machine
3#@DESCRIPTION: Machine configuration for the TI Keystone 2 K2L EVM
4
5require conf/machine/include/keystone.inc
6
7UBOOT_MACHINE = "k2l_evm_config"
8
9BOOT_MONITOR_MAKE_TARGET = "k2hk"
10
11IMAGE_FSTYPES += "ubi tar.gz cpio"
12
13SERIAL_CONSOLE = "115200 ttyS0"
14
15SYSVINIT_ENABLED_GETTYS = ""
16
17# do ubiattach /dev/ubi_ctrl -m 4
18# From dmesg:
19# UBI: smallest flash I/O unit: 4096
20# UBI: logical eraseblock size: 253952 bytes
21# from ubiattach stdout:
22# UBI device number 0, total 1926 LEBs
23MKUBIFS_ARGS = "-F -m 4096 -e 253952 -c 1926"
24
25# do ubiattach /dev/ubi_ctrl -m 4
26# from dmesg:
27# UBI: smallest flash I/O unit: 4096
28# UBI: physical eraseblock size: 256 KiB
29# UBI: sub-page size: 4096
30UBINIZE_ARGS = "-m 4096 -p 256KiB -s 4096 -O 4096"
diff --git a/recipes-bsp/boot-monitor/boot-monitor_git.bb b/recipes-bsp/boot-monitor/boot-monitor_git.bb
index c3d41f54..6e682138 100644
--- a/recipes-bsp/boot-monitor/boot-monitor_git.bb
+++ b/recipes-bsp/boot-monitor/boot-monitor_git.bb
@@ -5,7 +5,6 @@ LICENSE = "BSD"
5 5
6BOOT_MONITOR_BINARY ?= "skern.bin" 6BOOT_MONITOR_BINARY ?= "skern.bin"
7BOOT_MONITOR_IMAGE ?= "skern-${MACHINE}.bin" 7BOOT_MONITOR_IMAGE ?= "skern-${MACHINE}.bin"
8BOOT_MONITOR_MAKE_TARGET ?= "all"
9 8
10LIC_FILES_CHKSUM = "file://COPYING;md5=25fe219a6febf6e5bb45beda1b2eb315" 9LIC_FILES_CHKSUM = "file://COPYING;md5=25fe219a6febf6e5bb45beda1b2eb315"
11 10
@@ -14,14 +13,14 @@ COMPATIBLE_MACHINE = "keystone"
14SRC_URI = "git://git.ti.com/keystone-linux/boot-monitor.git;protocol=git;branch=${BRANCH}" 13SRC_URI = "git://git.ti.com/keystone-linux/boot-monitor.git;protocol=git;branch=${BRANCH}"
15 14
16PV = "2.0" 15PV = "2.0"
17PR = "r0+gitr${SRCPV}" 16PR = "r1+gitr${SRCPV}"
18 17
19BRANCH = "master" 18BRANCH = "master"
20 19
21S = "${WORKDIR}/git" 20S = "${WORKDIR}/git"
22 21
23#Tag "K2_BM_13.11" 22#Tag "K2_BM_14.05"
24SRCREV = "ba597d183423971e63295cdd59d3c90245e9170a" 23SRCREV = "0e3ffe1ea4a0cee38ae2406901b7cf4d5324b5e9"
25 24
26do_compile () { 25do_compile () {
27 unset LDFLAGS 26 unset LDFLAGS