summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorChase Maupin <Chase.Maupin@ti.com>2014-01-13 17:33:05 -0600
committerDenys Dmytriyenko <denys@ti.com>2014-01-14 14:45:32 -0500
commitc0de04584082d127643389bf529a60335c3bb52b (patch)
tree7dbc3cb9d9ecbc21cac18578c115a268d75ff045
parent3d32a8e70192660c0bfe49d4475d3d619e4712dd (diff)
downloadmeta-ti-c0de04584082d127643389bf529a60335c3bb52b.tar.gz
vpe-vpdma: Package for VPE DMA FW and test app
* This recipe will create the firmware and test application packages. Signed-off-by: Chase Maupin <Chase.Maupin@ti.com> Signed-off-by: Denys Dmytriyenko <denys@ti.com>
-rw-r--r--recipes-bsp/ti/vpe-vpdma_git.bb29
1 files changed, 29 insertions, 0 deletions
diff --git a/recipes-bsp/ti/vpe-vpdma_git.bb b/recipes-bsp/ti/vpe-vpdma_git.bb
new file mode 100644
index 00000000..d5067915
--- /dev/null
+++ b/recipes-bsp/ti/vpe-vpdma_git.bb
@@ -0,0 +1,29 @@
1DESCRIPTION = "VPE VPDMA firmware and test program"
2
3DEPENDS += "virtual/kernel"
4
5LICENSE = "BSD"
6LIC_FILES_CHKSUM = "file://COPYING;md5=74d2f71d8898c54e3d1c9d0058c484aa"
7
8COMPATIBLE_MACHINE = "dra7xx-evm"
9
10PV = "1b8"
11PR = "r0"
12
13SRCREV = "24a5487ec13bf560f0e7fb24a9d4747f9f358be2"
14BRANCH ?= "master"
15
16SRC_URI = "git://git.ti.com/vpe_tests/vpe_tests.git;protocol=git;branch=${BRANCH}"
17
18S = "${WORKDIR}/git"
19
20# The test application needs additional include headers from the kernel
21EXTRA_OEMAKE = 'KDIR="${STAGING_KERNEL_DIR}/include/uapi -I${STAGING_KERNEL_DIR}/include"'
22
23do_install() {
24 oe_runmake DESTDIR="${D}" install
25}
26
27# Separate the firmware into it's own package.
28PACKAGES =+ "${PN}-fw"
29FILES_${PN}-fw += "${base_libdir}/firmware"