summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorMrinmayee Hingolikar <mrinmayee@ti.com>2013-10-21 18:29:23 +0530
committerDenys Dmytriyenko <denys@ti.com>2013-11-21 23:17:55 -0500
commita3932f6c66047007dc6c6be7cc5ae19c314b05f6 (patch)
tree5bbd222c3be2bee3c23c35c241e1127cd101ea3b
parentd6b47b7cd7e80ff7c55882fd358e9af5f0fc744c (diff)
downloadmeta-ti-a3932f6c66047007dc6c6be7cc5ae19c314b05f6.tar.gz
abefw: firmware for OMAP4 and OMAP5 ABE
The OMAP5 Audio Backend requires a 'firmware' to enable sound. This recipe installs a prebuilt firmware. This part is a hack, as in the current form, the firmware cannot be cross-compiled. There is a plan to fix this and hopefully, this recipe is short-lived. Once the code is fixed, we should have new recipes that build the firmware and clean up this recipe. Signed-off-by: Denys Dmytriyenko <denys@ti.com>
-rw-r--r--recipes-bsp/abefw/abefw_1.0.14.bb23
1 files changed, 23 insertions, 0 deletions
diff --git a/recipes-bsp/abefw/abefw_1.0.14.bb b/recipes-bsp/abefw/abefw_1.0.14.bb
new file mode 100644
index 00000000..302bdcde
--- /dev/null
+++ b/recipes-bsp/abefw/abefw_1.0.14.bb
@@ -0,0 +1,23 @@
1SUMMARY = "Firmware for OMAP4 and OMAP5 ABE"
2HOMEPAGE = "http://git.ti.com"
3LICENSE = "BSD | GPLv2"
4LIC_FILES_CHKSUM = "file://COPYING;md5=923db086ed9463ab3215b24d87e05ec5"
5
6PACKAGE_ARCH = "${MACHINE_ARCH}"
7
8COMPATIBLE_MACHINE = "pandaboard|omap5-evm"
9
10SRC_URI = "git://git.ti.com/glsdk/abefw-omap4plus.git;protocol=git"
11
12S = "${WORKDIR}/git"
13
14SRCREV = "ceccc0332264e39bdc51e54f80ea7256a3886c58"
15
16PR = "r0"
17
18do_install() {
19 mkdir -p ${D}/lib/firmware
20 cp ${S}/firmware/omap4_abe_new ${D}/lib/firmware/
21}
22
23FILES_${PN} += "/lib/firmware/omap4_abe_new"