summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorDenys Dmytriyenko <denys@ti.com>2013-11-22 02:46:17 -0500
committerDenys Dmytriyenko <denys@ti.com>2013-11-22 02:38:04 -0500
commit8d8b62c1377cabb3ef7aa1831b3b0c4aeffd19f7 (patch)
tree3c4f0f931eb5fed124486450dcace691ee1c562e
parent8f881dd9655a4c213c425065498d58193d9ba014 (diff)
downloadmeta-ti-8d8b62c1377cabb3ef7aa1831b3b0c4aeffd19f7.tar.gz
recipes-bsp: add recipe for PowerVR SGX544MP2 kernel drivers
* The PowerVR SGX544MP2 is found on omap5 and dra7xx devices. This recipe adds support for the PowerVR graphics subsystem. Signed-off-by: Mrinmayee Hingolikar <mrinmayee@ti.com> Signed-off-by: Siddharth Heroor <heroor@ti.com> Signed-off-by: Denys Dmytriyenko <denys@ti.com>
-rw-r--r--recipes-bsp/powervr-drivers/omapdrm-pvr_1.9.2253347.bb24
1 files changed, 24 insertions, 0 deletions
diff --git a/recipes-bsp/powervr-drivers/omapdrm-pvr_1.9.2253347.bb b/recipes-bsp/powervr-drivers/omapdrm-pvr_1.9.2253347.bb
new file mode 100644
index 00000000..24aadd52
--- /dev/null
+++ b/recipes-bsp/powervr-drivers/omapdrm-pvr_1.9.2253347.bb
@@ -0,0 +1,24 @@
1DESCRIPTION = "Kernel drivers for the PowerVR SGX chipset found in the omap5 SoCs"
2HOMEPAGE = "http://git.ti.com"
3LICENSE = "GPLv2"
4LIC_FILES_CHKSUM = "file://MIT-COPYING;md5=8c2810fa6bfdc5ae5c15a0c1ade34054"
5
6inherit module
7
8SRC_URI = "git://git.ti.com/graphics/omap5-sgx-ddk-linux.git;protocol=git"
9S = "${WORKDIR}/git"
10
11SRCREV = "86a4ffae3458c51f0a58e44b17b7a4fd92d2b8c6"
12PR = "${MACHINE_KERNEL_PR}"
13
14EXTRA_OEMAKE += 'KERNELDIR="${STAGING_KERNEL_DIR}"'
15
16do_compile_prepend() {
17 cd ${S}/eurasiacon/build/linux2/omap5430_linux
18}
19
20do_install() {
21 mkdir -p ${D}/lib/modules/${KERNEL_VERSION}/extra/
22 cp ${S}/eurasiacon/binary2_omap5430_linux_release/target/kbuild/omapdrm_pvr.ko \
23 ${D}/lib/modules/${KERNEL_VERSION}/extra/
24}