summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorDenys Dmytriyenko <denys@ti.com>2014-02-24 18:52:55 -0500
committerDenys Dmytriyenko <denys@ti.com>2014-02-24 20:53:21 -0500
commit726a67e38f1e58ddf5b41cd3c169dc0d59596ddd (patch)
tree000ca3d848af8f1d7d8d62d31555b05dc44c165b
parentb5216d7f9c8b2153f5878c0f1320a32f77e733e5 (diff)
downloadmeta-ti-726a67e38f1e58ddf5b41cd3c169dc0d59596ddd.tar.gz
linux-ti-staging: ARM_SCU patch got merged, add PREEMPT_VOLUNTARY patch, reshuffle
Signed-off-by: Denys Dmytriyenko <denys@ti.com>
-rw-r--r--recipes-kernel/linux/linux-ti-staging/0002-ARM-config-Add-HAVE_ARM_SCU-for-AM43XX.patch37
-rw-r--r--recipes-kernel/linux/linux-ti-staging/0004-ARM-config-omap-Change-PREEMPTion-to-voluntary.patch33
-rw-r--r--recipes-kernel/linux/linux-ti-staging/0005-Not-for-merge-ARM-config-omap-Disable-SMP-for-AM335x.patch (renamed from recipes-kernel/linux/linux-ti-staging/0004-Not-for-merge-ARM-config-omap-Disable-SMP-for-AM335x.patch)16
-rw-r--r--recipes-kernel/linux/linux-ti-staging_3.12.bb10
4 files changed, 47 insertions, 49 deletions
diff --git a/recipes-kernel/linux/linux-ti-staging/0002-ARM-config-Add-HAVE_ARM_SCU-for-AM43XX.patch b/recipes-kernel/linux/linux-ti-staging/0002-ARM-config-Add-HAVE_ARM_SCU-for-AM43XX.patch
deleted file mode 100644
index 8137bb30..00000000
--- a/recipes-kernel/linux/linux-ti-staging/0002-ARM-config-Add-HAVE_ARM_SCU-for-AM43XX.patch
+++ /dev/null
@@ -1,37 +0,0 @@
1From 5b2aa64ccdeef659a9688730753199ba5b8e60b1 Mon Sep 17 00:00:00 2001
2From: Dave Gerlach <d-gerlach@ti.com>
3Date: Fri, 21 Feb 2014 10:25:33 +0000
4Subject: [PATCH 2/4] ARM: config: Add HAVE_ARM_SCU for AM43XX
5
6CONFIG_HAVE_ARM_SCU only gets selected if CONFIG_SMP is selected in an OMAP
7system however AM43XX needs this option regardless of CONFIG_SMP as it is
8important for controlling power in the SoC. Without this suspend will
9not work as scu_power_mode becomes an empty function.
10
11AM43XX requires SCU CPU Power Status bits for A9 core to be set to off mode
12in order for the MSTANDBY signal to be asserted from the MPU during WFI.
13This signal is used by the PRCM to determine when it is appropriate to
14clock gate the MPU clock domain and also trigger M3_IRQ2 to tell the wkup_m3
15firmware to put the part into the desired sleep more.
16
17Signed-off-by: Dave Gerlach <d-gerlach@ti.com>
18Tested-by: Sekhar Nori <nsekhar@ti.com>
19---
20 arch/arm/mach-omap2/Kconfig | 1 +
21 1 files changed, 1 insertions(+), 0 deletions(-)
22
23diff --git a/arch/arm/mach-omap2/Kconfig b/arch/arm/mach-omap2/Kconfig
24index 959f6fc..373d576 100644
25--- a/arch/arm/mach-omap2/Kconfig
26+++ b/arch/arm/mach-omap2/Kconfig
27@@ -85,6 +85,7 @@ config SOC_AM43XX
28 depends on ARCH_MULTI_V7
29 select CPU_V7
30 select ARCH_OMAP2PLUS
31+ select HAVE_ARM_SCU
32 select MULTI_IRQ_HANDLER
33 select ARM_GIC
34 select COMMON_CLK
35--
361.7.0.4
37
diff --git a/recipes-kernel/linux/linux-ti-staging/0004-ARM-config-omap-Change-PREEMPTion-to-voluntary.patch b/recipes-kernel/linux/linux-ti-staging/0004-ARM-config-omap-Change-PREEMPTion-to-voluntary.patch
new file mode 100644
index 00000000..469a0c7e
--- /dev/null
+++ b/recipes-kernel/linux/linux-ti-staging/0004-ARM-config-omap-Change-PREEMPTion-to-voluntary.patch
@@ -0,0 +1,33 @@
1From 54821ed9f986a0023bbc3fa08060e1f2c8efb6b5 Mon Sep 17 00:00:00 2001
2From: Chase Maupin <Chase.Maupin@ti.com>
3Date: Mon, 24 Feb 2014 13:16:20 -0600
4Subject: [PATCH 1/2] ARM: config: omap: Change PREEMPTion to voluntary
5
6* Change the default PREEMPT mode to voluntary which reduces the
7 overhead and increases performance for many use cases such as
8 UDP networking and cryptography.
9* Based on recommendations from Joel Fernandes <joelf@ti.com>
10
11Signed-off-by: Joel Fernandes <joelf@ti.com>
12Signed-off-by: Chase Maupin <Chase.Maupin@ti.com>
13Signed-off-by: Denys Dmytriyenko <denys@ti.com>
14---
15 arch/arm/configs/omap2plus_defconfig | 2 +-
16 1 file changed, 1 insertion(+), 1 deletion(-)
17
18diff --git a/arch/arm/configs/omap2plus_defconfig b/arch/arm/configs/omap2plus_defconfig
19index 3975b08..a34b45a 100644
20--- a/arch/arm/configs/omap2plus_defconfig
21+++ b/arch/arm/configs/omap2plus_defconfig
22@@ -38,7 +38,7 @@ CONFIG_ARM_ERRATA_411920=y
23 CONFIG_PCIE_DRA7XX=y
24 CONFIG_SMP=y
25 CONFIG_NR_CPUS=2
26-CONFIG_PREEMPT=y
27+CONFIG_PREEMPT_VOLUNTARY=y
28 CONFIG_CMA=y
29 CONFIG_ZBOOT_ROM_TEXT=0x0
30 CONFIG_ZBOOT_ROM_BSS=0x0
31--
321.8.3.2
33
diff --git a/recipes-kernel/linux/linux-ti-staging/0004-Not-for-merge-ARM-config-omap-Disable-SMP-for-AM335x.patch b/recipes-kernel/linux/linux-ti-staging/0005-Not-for-merge-ARM-config-omap-Disable-SMP-for-AM335x.patch
index b01c4d0c..8e016b4b 100644
--- a/recipes-kernel/linux/linux-ti-staging/0004-Not-for-merge-ARM-config-omap-Disable-SMP-for-AM335x.patch
+++ b/recipes-kernel/linux/linux-ti-staging/0005-Not-for-merge-ARM-config-omap-Disable-SMP-for-AM335x.patch
@@ -1,7 +1,8 @@
1From 89783143b64210e8f159fd875b23aa9af1fd51b0 Mon Sep 17 00:00:00 2001 1From 2f6cbe000b1d31c91eee0248f24b0c306aadeb63 Mon Sep 17 00:00:00 2001
2From: Santosh Shilimkar <santosh.shilimkar@ti.com> 2From: Santosh Shilimkar <santosh.shilimkar@ti.com>
3Date: Thu, 13 Feb 2014 08:52:41 -0500 3Date: Thu, 13 Feb 2014 08:52:41 -0500
4Subject: [PATCH 4/4] Not-for-merge: ARM: config: omap: Disable SMP for AM335x build 4Subject: [PATCH 2/2] Not-for-merge: ARM: config: omap: Disable SMP for AM335x
5 build
5 6
6SMP and SMP_ON_UP introduces some extra barriers and code many fast paths 7SMP and SMP_ON_UP introduces some extra barriers and code many fast paths
7including kernel lock functions. 8including kernel lock functions.
@@ -21,12 +22,13 @@ Disabling SMP in the build introduces one warining in cpuidle44xx.c driver
21and fix is included in the series 22and fix is included in the series
22 23
23Signed-off-by: Santosh Shilimkar <santosh.shilimkar@ti.com> 24Signed-off-by: Santosh Shilimkar <santosh.shilimkar@ti.com>
25Signed-off-by: Denys Dmytriyenko <denys@ti.com>
24--- 26---
25 arch/arm/configs/omap2plus_defconfig | 2 -- 27 arch/arm/configs/omap2plus_defconfig | 2 --
26 1 files changed, 0 insertions(+), 2 deletions(-) 28 1 file changed, 2 deletions(-)
27 29
28diff --git a/arch/arm/configs/omap2plus_defconfig b/arch/arm/configs/omap2plus_defconfig 30diff --git a/arch/arm/configs/omap2plus_defconfig b/arch/arm/configs/omap2plus_defconfig
29index 3975b08..cfbc2d0 100644 31index a34b45a..bb6beb2 100644
30--- a/arch/arm/configs/omap2plus_defconfig 32--- a/arch/arm/configs/omap2plus_defconfig
31+++ b/arch/arm/configs/omap2plus_defconfig 33+++ b/arch/arm/configs/omap2plus_defconfig
32@@ -36,8 +36,6 @@ CONFIG_OMAP4_ERRATA_I688=y 34@@ -36,8 +36,6 @@ CONFIG_OMAP4_ERRATA_I688=y
@@ -35,9 +37,9 @@ index 3975b08..cfbc2d0 100644
35 CONFIG_PCIE_DRA7XX=y 37 CONFIG_PCIE_DRA7XX=y
36-CONFIG_SMP=y 38-CONFIG_SMP=y
37-CONFIG_NR_CPUS=2 39-CONFIG_NR_CPUS=2
38 CONFIG_PREEMPT=y 40 CONFIG_PREEMPT_VOLUNTARY=y
39 CONFIG_CMA=y 41 CONFIG_CMA=y
40 CONFIG_ZBOOT_ROM_TEXT=0x0 42 CONFIG_ZBOOT_ROM_TEXT=0x0
41-- 43--
421.7.0.4 441.8.3.2
43 45
diff --git a/recipes-kernel/linux/linux-ti-staging_3.12.bb b/recipes-kernel/linux/linux-ti-staging_3.12.bb
index 32cc5c5d..9f39a723 100644
--- a/recipes-kernel/linux/linux-ti-staging_3.12.bb
+++ b/recipes-kernel/linux/linux-ti-staging_3.12.bb
@@ -36,11 +36,11 @@ S = "${WORKDIR}/git"
36 36
37BRANCH = "ti-linux-3.12.y" 37BRANCH = "ti-linux-3.12.y"
38 38
39SRCREV = "d5e4bfd196e114c885c5c42cf0a7b3edc7e54829" 39SRCREV = "c559824b17bfc194cc072dac0720ac8e23373871"
40PV = "3.12.10" 40PV = "3.12.10"
41 41
42# Append to the MACHINE_KERNEL_PR so that a new SRCREV will cause a rebuild 42# Append to the MACHINE_KERNEL_PR so that a new SRCREV will cause a rebuild
43MACHINE_KERNEL_PR_append = "h+gitr${SRCPV}" 43MACHINE_KERNEL_PR_append = "i+gitr${SRCPV}"
44PR = "${MACHINE_KERNEL_PR}" 44PR = "${MACHINE_KERNEL_PR}"
45 45
46SRC_URI = "git://git.ti.com/ti-linux-kernel/ti-linux-kernel.git;protocol=git;branch=${BRANCH} \ 46SRC_URI = "git://git.ti.com/ti-linux-kernel/ti-linux-kernel.git;protocol=git;branch=${BRANCH} \
@@ -49,9 +49,9 @@ SRC_URI = "git://git.ti.com/ti-linux-kernel/ti-linux-kernel.git;protocol=git;bra
49 49
50# Latest critical fixes 50# Latest critical fixes
51SRC_URI += "file://0001-Revert-usb-musb-musb_cppi41-Revert-the-Advisory-1.0..patch \ 51SRC_URI += "file://0001-Revert-usb-musb-musb_cppi41-Revert-the-Advisory-1.0..patch \
52 file://0002-ARM-config-Add-HAVE_ARM_SCU-for-AM43XX.patch \
53 file://0003-ARM-OMAP-Kill-warning-in-CPUIDLE-code-with-CONFIG_SM.patch \ 52 file://0003-ARM-OMAP-Kill-warning-in-CPUIDLE-code-with-CONFIG_SM.patch \
53 file://0004-ARM-config-omap-Change-PREEMPTion-to-voluntary.patch \
54 " 54 "
55 55
56SRC_URI_append_ti33x = "file://0004-Not-for-merge-ARM-config-omap-Disable-SMP-for-AM335x.patch" 56SRC_URI_append_ti33x = "file://0005-Not-for-merge-ARM-config-omap-Disable-SMP-for-AM335x.patch"
57SRC_URI_append_ti43x = "file://0004-Not-for-merge-ARM-config-omap-Disable-SMP-for-AM335x.patch" 57SRC_URI_append_ti43x = "file://0005-Not-for-merge-ARM-config-omap-Disable-SMP-for-AM335x.patch"