summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorDenys Dmytriyenko <denys@ti.com>2013-11-21 21:03:16 -0500
committerDenys Dmytriyenko <denys@ti.com>2013-11-21 21:49:40 -0500
commit5ae405999c4fde790e68379d1b744a2173645872 (patch)
tree927cf0c98eb0ee5259c3ac6281320c07bcc76afa
parentdd58f81f9275cc77ca981f4214bc787a8731dd2e (diff)
downloadmeta-ti-5ae405999c4fde790e68379d1b744a2173645872.tar.gz
libgles-omap3: update cputype to support 3.12 and AM43x device
Signed-off-by: Franklin S. Cooper Jr <fcooper@ti.com> Signed-off-by: Denys Dmytriyenko <denys@ti.com>
-rwxr-xr-xrecipes-graphics/libgles/libgles-omap3/cputype18
-rw-r--r--recipes-graphics/libgles/libgles-omap3_5.00.00.01.bb2
2 files changed, 14 insertions, 6 deletions
diff --git a/recipes-graphics/libgles/libgles-omap3/cputype b/recipes-graphics/libgles/libgles-omap3/cputype
index 4448c300..35268a80 100755
--- a/recipes-graphics/libgles/libgles-omap3/cputype
+++ b/recipes-graphics/libgles/libgles-omap3/cputype
@@ -1,17 +1,25 @@
1#!/bin/sh 1#!/bin/sh
2 2
3machine_id() { # return the machine ID 3legacy_machine_id() { # return the machine ID
4 awk 'BEGIN { FS=": " } /Hardware/ \ 4 awk 'BEGIN { FS=": " } /Hardware/ \
5 { gsub(" ", "_", $2); print tolower($2) } ' </proc/cpuinfo 5 { gsub(" ", "_", $2); print tolower($2) } ' </proc/cpuinfo
6} 6}
7 7
8if [ "$(machine_id)" = "ti8168evm" ] ; then 8machine_id() { # return the machine ID
9 cat /proc/cpuinfo | grep Hardware | awk -F" " '{ print $4 }'
10}
11
12if [ "$(machine_id)" = "ti8168evm" -o "$(legacy_machine_id)" = "ti8168evm" ] ; then
9 echo TI816x 13 echo TI816x
10elif [ "$(machine_id)" = "am335xevm" ] ; then 14elif [ "$(machine_id)" = "AM33XX" -o "$(legacy_machine_id)" = "am335xevm" ] ; then
11 echo TI33XX 15 echo TI33XX
16elif [ "$(machine_id)" = "AM43" ] ; then
17 echo TI43XX
12else 18else
13 devmem2 0x4800244c | \ 19 devmem2 0x4800244c | \
14 grep 'Read at address' | \ 20 grep 'Read at address' | \
15 sed -e 's/.*): //' | \ 21 sed -e 's/.*): //' | \
16 sed -e 's/0x00005C00/OMAP3503/' -e 's/0x00001C00/OMAP3515/' -e 's/0x00004C00/OMAP3525/' -e 's/0x00000C00/OMAP3530/' -e 's/0x00005E00/OMAP3503/' -e 's/0x00001E00/OMAP3515/' -e 's/0x00004E00/OMAP3525/' -e 's/0x00000E00/OMAP3530/' -e 's/0x00000CC0/OMAP3530/' 22 sed -e 's/0x00005C00/OMAP3503/' -e 's/0x00001C00/OMAP3515/' -e 's/0x00004C00/OMAP3525/' -e 's/0x00000C00/OMAP3530/' \
23 -e 's/0x00005E00/OMAP3503/' -e 's/0x00001E00/OMAP3515/' -e 's/0x00004E00/OMAP3525/' -e 's/0x00000E00/OMAP3530/' \
24 -e 's/0x00000CC0/OMAP3530/'
17fi 25fi
diff --git a/recipes-graphics/libgles/libgles-omap3_5.00.00.01.bb b/recipes-graphics/libgles/libgles-omap3_5.00.00.01.bb
index be09ffa6..7af67eb6 100644
--- a/recipes-graphics/libgles/libgles-omap3_5.00.00.01.bb
+++ b/recipes-graphics/libgles/libgles-omap3_5.00.00.01.bb
@@ -2,7 +2,7 @@ require libgles-omap3-no-x.inc
2 2
3LICENSE = "TSPA" 3LICENSE = "TSPA"
4 4
5PR = "${INC_PR}.0" 5PR = "${INC_PR}.1"
6 6
7DEFAULT_PREFERENCE = "-1" 7DEFAULT_PREFERENCE = "-1"
8 8