summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorEtheridge, Darren <detheridge@ti.com>2022-03-23 14:37:07 -0500
committerRyan Eatmon <reatmon@ti.com>2022-04-07 07:48:39 -0500
commited94c75b436f2f8c5c3a8a6ebed45d7276cc35e4 (patch)
tree400e4a95765e82581637257d28607fb087357392
parent1ab91bcc154909f5ba8e04a866836773fa9430e4 (diff)
downloadmeta-ti-ed94c75b436f2f8c5c3a8a6ebed45d7276cc35e4.tar.gz
ti-graphics: gpu enable and move all platforms to ddk 1.15
Enable the GPU for am62xx and j721s2 and use IMG DDK 1.15 Migrate Imagination DDK 1.13 to DDK 1.15 for J721e Signed-off-by: Darren Etheridge <detheridge@ti.com> Signed-off-by: Ryan Eatmon <reatmon@ti.com>
-rw-r--r--conf/machine/am62xx-evm.conf2
-rw-r--r--conf/machine/j721s2-evm.conf2
-rw-r--r--recipes-bsp/powervr-drivers/ti-img-rogue-driver_1.13.5776728.bb40
-rw-r--r--recipes-bsp/powervr-drivers/ti-img-rogue-driver_1.15.6133109.bb44
-rw-r--r--recipes-graphics/libgles/ti-img-rogue-umlibs_1.15.6133109.bb (renamed from recipes-graphics/libgles/ti-img-rogue-umlibs_1.13.5776728.bb)13
5 files changed, 55 insertions, 46 deletions
diff --git a/conf/machine/am62xx-evm.conf b/conf/machine/am62xx-evm.conf
index 0588d34c..eb1563f8 100644
--- a/conf/machine/am62xx-evm.conf
+++ b/conf/machine/am62xx-evm.conf
@@ -4,6 +4,8 @@
4 4
5require conf/machine/include/am62xx.inc 5require conf/machine/include/am62xx.inc
6 6
7MACHINE_FEATURES += "gpu"
8
7KERNEL_DEVICETREE = " \ 9KERNEL_DEVICETREE = " \
8 ti/k3-am625-sk.dtb \ 10 ti/k3-am625-sk.dtb \
9" 11"
diff --git a/conf/machine/j721s2-evm.conf b/conf/machine/j721s2-evm.conf
index 82fd33da..e5ed0b73 100644
--- a/conf/machine/j721s2-evm.conf
+++ b/conf/machine/j721s2-evm.conf
@@ -4,6 +4,8 @@
4 4
5require conf/machine/include/j7.inc 5require conf/machine/include/j7.inc
6 6
7MACHINE_FEATURES += "gpu"
8
7SERIAL_CONSOLES = "115200;ttyS10" 9SERIAL_CONSOLES = "115200;ttyS10"
8SERIAL_CONSOLES_CHECK = "${SERIAL_CONSOLES}" 10SERIAL_CONSOLES_CHECK = "${SERIAL_CONSOLES}"
9TFA_K3_USART = "0x8" 11TFA_K3_USART = "0x8"
diff --git a/recipes-bsp/powervr-drivers/ti-img-rogue-driver_1.13.5776728.bb b/recipes-bsp/powervr-drivers/ti-img-rogue-driver_1.13.5776728.bb
deleted file mode 100644
index a05de0f2..00000000
--- a/recipes-bsp/powervr-drivers/ti-img-rogue-driver_1.13.5776728.bb
+++ /dev/null
@@ -1,40 +0,0 @@
1DESCRIPTION = "Kernel drivers for the PowerVR Rogue GPU found in the TI SoCs"
2HOMEPAGE = "http://git.ti.com/graphics/ti-img-rogue-driver"
3LICENSE = "MIT | GPLv2"
4LIC_FILES_CHKSUM = "file://README;beginline=14;endline=19;md5=0403c7dea01a2b8232261e805325fac2"
5
6inherit module features_check
7
8REQUIRED_MACHINE_FEATURES = "gpu"
9
10MACHINE_KERNEL_PR_append = "b"
11PR = "${MACHINE_KERNEL_PR}"
12
13PACKAGE_ARCH = "${MACHINE_ARCH}"
14COMPATIBLE_MACHINE = "j7"
15
16DEPENDS = "virtual/kernel"
17
18PROVIDES = "virtual/gpudriver"
19
20BRANCH = "1.13-5776728/linux-k5.10"
21
22SRC_URI = " \
23 git://git.ti.com/graphics/ti-img-rogue-driver.git;branch=${BRANCH} \
24 file://0001-compiler-support-OpenEmbedded-nodistro-internal-aarc.patch \
25"
26
27S = "${WORKDIR}/git"
28
29SRCREV = "35a25875ae8738f82c7cabc6b077ef992b0cca84"
30
31PVR_SOC = "j721e_linux"
32PVR_BVNC = "22.104.208.318"
33PVR_BUILD = "release"
34PVR_WS = "wayland"
35
36EXTRA_OEMAKE += 'KERNELDIR="${STAGING_KERNEL_DIR}" RGX_BVNC=${PVR_BVNC} BUILD=${PVR_BUILD} PVR_BUILD_DIR=${PVR_SOC} WINDOW_SYSTEM=${PVR_WS}'
37
38do_install() {
39 make -C ${STAGING_KERNEL_DIR} M=${B}/binary_${PVR_SOC}_${PVR_WS}_${PVR_BUILD}/target_aarch64/kbuild INSTALL_MOD_PATH=${D}${root_prefix} PREFIX=${STAGING_DIR_HOST} modules_install
40}
diff --git a/recipes-bsp/powervr-drivers/ti-img-rogue-driver_1.15.6133109.bb b/recipes-bsp/powervr-drivers/ti-img-rogue-driver_1.15.6133109.bb
new file mode 100644
index 00000000..fbff6c51
--- /dev/null
+++ b/recipes-bsp/powervr-drivers/ti-img-rogue-driver_1.15.6133109.bb
@@ -0,0 +1,44 @@
1DESCRIPTION = "Kernel drivers for the PowerVR Rogue GPU found in the TI SoCs"
2HOMEPAGE = "http://git.ti.com/graphics/ti-img-rogue-driver"
3LICENSE = "MIT | GPLv2"
4LIC_FILES_CHKSUM = "file://README;beginline=14;endline=19;md5=0403c7dea01a2b8232261e805325fac2"
5
6inherit module features_check
7
8REQUIRED_MACHINE_FEATURES = "gpu"
9
10MACHINE_KERNEL_PR_append = "a"
11PR = "${MACHINE_KERNEL_PR}"
12
13PACKAGE_ARCH = "${MACHINE_ARCH}"
14COMPATIBLE_MACHINE = "j7-evm|j721s2-evm|am62xx"
15
16DEPENDS = "virtual/kernel"
17
18PROVIDES = "virtual/gpudriver"
19
20BRANCH = "linuxws/dunfell/k5.10/${PV}"
21
22SRC_URI = " \
23 git://git.ti.com/graphics/ti-img-rogue-driver.git;branch=${BRANCH} \
24 file://0001-compiler-support-OpenEmbedded-nodistro-internal-aarc.patch \
25"
26
27S = "${WORKDIR}/git"
28
29SRCREV = "ee0674adccac16f5b2f7cb8d5d05948706080cb5"
30
31TARGET_PRODUCT_j7-evm = "j721e_linux"
32TARGET_PRODUCT_j721s2-evm = "j721s2_linux"
33TARGET_PRODUCT_am62xx = "am62_linux"
34TARGET_BVNC_j7-evm = "22.104.208.318"
35TARGET_BVNC_j721s2-evm = "36.53.104.796"
36TARGET_BVNC_am62xx = "33.15.11.3"
37PVR_BUILD = "release"
38PVR_WS = "wayland"
39
40EXTRA_OEMAKE += 'KERNELDIR="${STAGING_KERNEL_DIR}" RGX_BVNC=${TARGET_BVNC} BUILD=${PVR_BUILD} PVR_BUILD_DIR=${TARGET_PRODUCT} WINDOW_SYSTEM=${PVR_WS}'
41
42do_install() {
43 make -C ${STAGING_KERNEL_DIR} M=${B}/binary_${TARGET_PRODUCT}_${PVR_WS}_${PVR_BUILD}/target_aarch64/kbuild INSTALL_MOD_PATH=${D}${root_prefix} PREFIX=${STAGING_DIR_HOST} modules_install
44}
diff --git a/recipes-graphics/libgles/ti-img-rogue-umlibs_1.13.5776728.bb b/recipes-graphics/libgles/ti-img-rogue-umlibs_1.15.6133109.bb
index 5194015e..e00dce99 100644
--- a/recipes-graphics/libgles/ti-img-rogue-umlibs_1.13.5776728.bb
+++ b/recipes-graphics/libgles/ti-img-rogue-umlibs_1.15.6133109.bb
@@ -8,17 +8,18 @@ inherit features_check
8REQUIRED_MACHINE_FEATURES = "gpu" 8REQUIRED_MACHINE_FEATURES = "gpu"
9 9
10PACKAGE_ARCH = "${MACHINE_ARCH}" 10PACKAGE_ARCH = "${MACHINE_ARCH}"
11COMPATIBLE_MACHINE = "j7" 11COMPATIBLE_MACHINE = "j7-evm|j721s2-evm|am62xx"
12 12
13PR = "r3" 13PR = "r1"
14 14
15BRANCH = "linuxws/dunfell/k5.10/${PV}" 15BRANCH = "linuxws/dunfell/k5.10/${PV}"
16 16
17SRC_URI = "git://git.ti.com/graphics/ti-img-rogue-umlibs.git;branch=${BRANCH}" 17SRC_URI = "git://git.ti.com/graphics/ti-img-rogue-umlibs.git;branch=${BRANCH}"
18SRCREV = "47c3ffc44f2881397d45c8a2b5dfa7d6c58b79fb"
18 19
19SRCREV = "5ef38353c38d921a65ea6df75c7b6ce710b66034" 20TARGET_PRODUCT_j7-evm = "j721e_linux"
20 21TARGET_PRODUCT_j721s2-evm = "j721s2_linux"
21PVR_SOC ?= "j721e_linux" 22TARGET_PRODUCT_am62xx = "am62_linux"
22PVR_BUILD ?= "release" 23PVR_BUILD ?= "release"
23PVR_WS = "wayland" 24PVR_WS = "wayland"
24 25
@@ -50,7 +51,7 @@ RRECOMMENDS_${PN} += "ti-img-rogue-driver"
50S = "${WORKDIR}/git" 51S = "${WORKDIR}/git"
51 52
52do_install () { 53do_install () {
53 oe_runmake install DESTDIR=${D} TARGET_PRODUCT=${PVR_SOC} BUILD=${PVR_BUILD} WINDOW_SYSTEM=${PVR_WS} 54 oe_runmake install DESTDIR=${D} TARGET_PRODUCT=${TARGET_PRODUCT} BUILD=${PVR_BUILD} WINDOW_SYSTEM=${PVR_WS}
54 chown -R root:root ${D} 55 chown -R root:root ${D}
55} 56}
56 57