summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorRyan Eatmon <reatmon@ti.com>2022-02-09 10:51:49 -0600
committerRyan Eatmon <reatmon@ti.com>2022-02-09 10:54:50 -0600
commit9bb0a8e53bc2838fdbbb058d675d3b6a6bedd71b (patch)
treeaae97aca569f53e2304b8a1501dea7b8947d8f05
parentb7d5a253790d91b2db5ed1294b7ca5fcbe641743 (diff)
downloadmeta-ti-9bb0a8e53bc2838fdbbb058d675d3b6a6bedd71b.tar.gz
cnm-wave-fw: Split firmware name into target and source
We need to control both the source name of the firmware and the target name, so split the current variable into two and update the install command. Signed-off-by: Ryan Eatmon <reatmon@ti.com>
-rw-r--r--recipes-bsp/cnm-wave-fw/cnm-wave-fw_git.bb6
1 files changed, 4 insertions, 2 deletions
diff --git a/recipes-bsp/cnm-wave-fw/cnm-wave-fw_git.bb b/recipes-bsp/cnm-wave-fw/cnm-wave-fw_git.bb
index 28f3440e..0c432de2 100644
--- a/recipes-bsp/cnm-wave-fw/cnm-wave-fw_git.bb
+++ b/recipes-bsp/cnm-wave-fw/cnm-wave-fw_git.bb
@@ -19,7 +19,9 @@ PACKAGE_ARCH = "${MACHINE_ARCH}"
19 19
20S = "${WORKDIR}/git" 20S = "${WORKDIR}/git"
21TARGET_WAVE521C = "wave521c_codec_fw.bin" 21TARGET_WAVE521C = "wave521c_codec_fw.bin"
22TARGET_WAVE521C_j721s2-evm = "wave521c_j721s2_codec_fw.bin" 22
23SOURCE_WAVE521C = "wave521c_codec_fw.bin"
24SOURCE_WAVE521C_j721s2-evm = "wave521c_j721s2_codec_fw.bin"
23 25
24ALTERNATIVE_LINK_NAME[wave521c_codec_fw.bin] = "${base_libdir}/firmware/${TARGET_WAVE521C}" 26ALTERNATIVE_LINK_NAME[wave521c_codec_fw.bin] = "${base_libdir}/firmware/${TARGET_WAVE521C}"
25ALTERNATIVE_TARGET[wave521c_codec_fw.bin] = "${base_libdir}/firmware/cnm/${TARGET_WAVE521C}" 27ALTERNATIVE_TARGET[wave521c_codec_fw.bin] = "${base_libdir}/firmware/cnm/${TARGET_WAVE521C}"
@@ -31,7 +33,7 @@ ALTERNATIVE_${PN}_j7 = "\
31 33
32do_install() { 34do_install() {
33 install -d ${D}${base_libdir}/firmware/cnm 35 install -d ${D}${base_libdir}/firmware/cnm
34 install -m 0644 ${S}/cnm/${TARGET_WAVE521C} ${D}${base_libdir}/firmware/cnm/${TARGET_WAVE521C} 36 install -m 0644 ${S}/cnm/${SOURCE_WAVE521C} ${D}${base_libdir}/firmware/cnm/${TARGET_WAVE521C}
35} 37}
36 38
37# make sure that lib/firmware, and all its contents are part of the package 39# make sure that lib/firmware, and all its contents are part of the package