summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorRyan Eatmon <reatmon@ti.com>2022-02-02 12:08:40 -0600
committerRyan Eatmon <reatmon@ti.com>2022-02-02 12:08:40 -0600
commit7cc936a4955ff4873b31c0f69e8e7d2eb803d05b (patch)
treee3f0785fe2ef128b5ed3c4b557615037df08153f
parent1a24b10249856704a21e40f47fb07a94d56266c4 (diff)
downloadmeta-ti-7cc936a4955ff4873b31c0f69e8e7d2eb803d05b.tar.gz
cnm-wave-fw: Fix name of firmware for j721s2
Update the name of the firmware for j721s2 as the file was renamed. Also, fix a typo in the variable name. Signed-off-by: Ryan Eatmon <reatmon@ti.com>
-rw-r--r--recipes-bsp/cnm-wave-fw/cnm-wave-fw_git.bb11
1 files changed, 6 insertions, 5 deletions
diff --git a/recipes-bsp/cnm-wave-fw/cnm-wave-fw_git.bb b/recipes-bsp/cnm-wave-fw/cnm-wave-fw_git.bb
index 6a36d733..3dd0f4f4 100644
--- a/recipes-bsp/cnm-wave-fw/cnm-wave-fw_git.bb
+++ b/recipes-bsp/cnm-wave-fw/cnm-wave-fw_git.bb
@@ -9,7 +9,7 @@ LICENSE = "BSD-3-Clause"
9LIC_FILES_CHKSUM = "file://LICENCE.cnm;md5=93b67e6bac7f8fec22b96b8ad0a1a9d0" 9LIC_FILES_CHKSUM = "file://LICENCE.cnm;md5=93b67e6bac7f8fec22b96b8ad0a1a9d0"
10 10
11PV = "${CNM_WAVE521_FW_VERSION}" 11PV = "${CNM_WAVE521_FW_VERSION}"
12PR = "${INC_PR}.0" 12PR = "${INC_PR}.1"
13 13
14CLEANBROKEN = "1" 14CLEANBROKEN = "1"
15 15
@@ -18,10 +18,11 @@ COMPATIBLE_MACHINE = "j7"
18PACKAGE_ARCH = "${MACHINE_ARCH}" 18PACKAGE_ARCH = "${MACHINE_ARCH}"
19 19
20S = "${WORKDIR}/git" 20S = "${WORKDIR}/git"
21TARGET_WAVE215C = "wave521c_codec_fw.bin" 21TARGET_WAVE521C = "wave521c_codec_fw.bin"
22TARGET_WAVE521C_j721s2-evm = "wave521c_j721s2_codec_fw.bin"
22 23
23ALTERNATIVE_LINK_NAME[wave521c_codec_fw.bin] = "${base_libdir}/firmware/${TARGET_WAVE215C}" 24ALTERNATIVE_LINK_NAME[wave521c_codec_fw.bin] = "${base_libdir}/firmware/${TARGET_WAVE521C}"
24ALTERNATIVE_TARGET[wave521c_codec_fw.bin] = "${base_libdir}/firmware/cnm/${TARGET_WAVE215C}" 25ALTERNATIVE_TARGET[wave521c_codec_fw.bin] = "${base_libdir}/firmware/cnm/${TARGET_WAVE521C}"
25ALTERNATIVE_PRIORITY = "10" 26ALTERNATIVE_PRIORITY = "10"
26 27
27# Set up names for the firmwares 28# Set up names for the firmwares
@@ -30,7 +31,7 @@ ALTERNATIVE_${PN}_j7 = "\
30 31
31do_install() { 32do_install() {
32 install -d ${D}${base_libdir}/firmware/cnm 33 install -d ${D}${base_libdir}/firmware/cnm
33 install -m 0644 ${S}/cnm/${TARGET_WAVE215C} ${D}${base_libdir}/firmware/cnm/${TARGET_WAVE215C} 34 install -m 0644 ${S}/cnm/${TARGET_WAVE521C} ${D}${base_libdir}/firmware/cnm/${TARGET_WAVE521C}
34} 35}
35 36
36# make sure that lib/firmware, and all its contents are part of the package 37# make sure that lib/firmware, and all its contents are part of the package