summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorNishanth Menon <nm@ti.com>2021-10-26 21:22:09 +0000
committerRyan Eatmon <reatmon@ti.com>2022-02-01 09:06:28 -0600
commit641b49c6a8977e8723441be5b97a36cdd14bcc06 (patch)
tree0e39b275582017e07130eac7a4a287ec75cbb554
parent687dae43026314c4a649bb2c7b1d53dde0bdb3c4 (diff)
downloadmeta-ti-641b49c6a8977e8723441be5b97a36cdd14bcc06.tar.gz
recipes-bsp: Add cnm-wave-fw firmware recipe
Add firmware recipe to add the Wave521cl firmware pieces in for j7 platform. Signed-off-by: Nishanth Menon <nm@ti.com> Signed-off-by: Ryan Eatmon <reatmon@ti.com>
-rw-r--r--recipes-bsp/cnm-wave-fw/cnm-wave-fw_git.bb41
-rw-r--r--recipes-bsp/ti-linux-fw/ti-linux-fw.inc1
-rw-r--r--recipes-kernel/linux/kernel-rdepends.inc3
3 files changed, 45 insertions, 0 deletions
diff --git a/recipes-bsp/cnm-wave-fw/cnm-wave-fw_git.bb b/recipes-bsp/cnm-wave-fw/cnm-wave-fw_git.bb
new file mode 100644
index 00000000..6a36d733
--- /dev/null
+++ b/recipes-bsp/cnm-wave-fw/cnm-wave-fw_git.bb
@@ -0,0 +1,41 @@
1SUMMARY = "Chips&Media codec firmware files"
2
3require recipes-bsp/ti-linux-fw/ti-linux-fw.inc
4
5inherit deploy
6inherit update-alternatives
7
8LICENSE = "BSD-3-Clause"
9LIC_FILES_CHKSUM = "file://LICENCE.cnm;md5=93b67e6bac7f8fec22b96b8ad0a1a9d0"
10
11PV = "${CNM_WAVE521_FW_VERSION}"
12PR = "${INC_PR}.0"
13
14CLEANBROKEN = "1"
15
16COMPATIBLE_MACHINE = "j7"
17
18PACKAGE_ARCH = "${MACHINE_ARCH}"
19
20S = "${WORKDIR}/git"
21TARGET_WAVE215C = "wave521c_codec_fw.bin"
22
23ALTERNATIVE_LINK_NAME[wave521c_codec_fw.bin] = "${base_libdir}/firmware/${TARGET_WAVE215C}"
24ALTERNATIVE_TARGET[wave521c_codec_fw.bin] = "${base_libdir}/firmware/cnm/${TARGET_WAVE215C}"
25ALTERNATIVE_PRIORITY = "10"
26
27# Set up names for the firmwares
28ALTERNATIVE_${PN}_j7 = "\
29 wave521c_codec_fw.bin"
30
31do_install() {
32 install -d ${D}${base_libdir}/firmware/cnm
33 install -m 0644 ${S}/cnm/${TARGET_WAVE215C} ${D}${base_libdir}/firmware/cnm/${TARGET_WAVE215C}
34}
35
36# make sure that lib/firmware, and all its contents are part of the package
37FILES_${PN} = "${base_libdir}/firmware"
38
39# we don't want to configure and build the source code
40do_compile[noexec] = "1"
41do_configure[noexec] = "1"
diff --git a/recipes-bsp/ti-linux-fw/ti-linux-fw.inc b/recipes-bsp/ti-linux-fw/ti-linux-fw.inc
index f1607686..9bd2d0a8 100644
--- a/recipes-bsp/ti-linux-fw/ti-linux-fw.inc
+++ b/recipes-bsp/ti-linux-fw/ti-linux-fw.inc
@@ -17,6 +17,7 @@ PRUETH_FW_AM65X_SR2_VERSION = "02.02.09.07"
17GOODIX_FW_VERSION = "1.0.0.0" 17GOODIX_FW_VERSION = "1.0.0.0"
18CADENCE_MHDP_FW_VERSION = "1.2.17" 18CADENCE_MHDP_FW_VERSION = "1.2.17"
19IMG_DEC_FW_VERSION = "1.0" 19IMG_DEC_FW_VERSION = "1.0"
20CNM_WAVE521_FW_VERSION = "1.0.00"
20 21
21TI_LINUX_FW_SRCREV ?= "c96a734a059889e571dcf30c0638157c690a6e6e" 22TI_LINUX_FW_SRCREV ?= "c96a734a059889e571dcf30c0638157c690a6e6e"
22SRCREV = "${TI_LINUX_FW_SRCREV}" 23SRCREV = "${TI_LINUX_FW_SRCREV}"
diff --git a/recipes-kernel/linux/kernel-rdepends.inc b/recipes-kernel/linux/kernel-rdepends.inc
index 76b7a508..2a6302af 100644
--- a/recipes-kernel/linux/kernel-rdepends.inc
+++ b/recipes-kernel/linux/kernel-rdepends.inc
@@ -42,3 +42,6 @@ RDEPENDS_${KERNEL_PACKAGE_NAME}-base_append_j7 = " cadence-mhdp-fw"
42 42
43# Add run-time dependency for Video Decoding firmware to the rootfs 43# Add run-time dependency for Video Decoding firmware to the rootfs
44RDEPENDS_${KERNEL_PACKAGE_NAME}-base_append_j7 = " vxd-dec-fw" 44RDEPENDS_${KERNEL_PACKAGE_NAME}-base_append_j7 = " vxd-dec-fw"
45
46# Add run-time dependency for Chips&Media Wave521 firmware to the rootfs
47RDEPENDS_${KERNEL_PACKAGE_NAME}-base_append_j7 = " cnm-wave-fw"