diff options
author | Chirag Shilwant <c-shilwant@ti.com> | 2023-02-13 20:12:20 +0530 |
---|---|---|
committer | Ryan Eatmon <reatmon@ti.com> | 2023-02-13 13:10:38 -0600 |
commit | a80c06916068456bc6c56c4bf68a3f8d784b819d (patch) | |
tree | cf80db91cfed88e6283d2524002f58a6eee740b5 | |
parent | 3f029434bccb80f7fd042d2c94cbaf1f1b2aaa59 (diff) | |
download | meta-ti-a80c06916068456bc6c56c4bf68a3f8d784b819d.tar.gz |
am62xx-evm: Add AM62x HS-FS evm configuration
Lets add the basic AM62x HS-FS configuration
- Add machine conf for AM62x HS-FS.
- The wic images will boot on AM62x HS-FS devices by default. The sysfw image for GP and HS-SE will be packaged in the wic image as tiboot3-am62x-gp-evm.bin and tiboot3-am62x-hs-evm.bin respectively.
- Add ti-sci-firmware overrides.
Signed-off-by: Chirag Shilwant <c-shilwant@ti.com>
Signed-off-by: Ryan Eatmon <reatmon@ti.com>
-rw-r--r-- | conf/machine/am62xx-evm-k3r5-gp.conf | 4 | ||||
-rw-r--r-- | conf/machine/am62xx-evm-k3r5-hs-fs.conf | 14 | ||||
-rw-r--r-- | conf/machine/include/am62xx.inc | 15 | ||||
-rw-r--r-- | conf/multiconfig/k3r5-hs-fs.conf | 3 | ||||
-rw-r--r-- | recipes-bsp/ti-sci-fw/ti-sci-fw_git.bb | 1 |
5 files changed, 33 insertions, 4 deletions
diff --git a/conf/machine/am62xx-evm-k3r5-gp.conf b/conf/machine/am62xx-evm-k3r5-gp.conf index d9867bc7..ab18301a 100644 --- a/conf/machine/am62xx-evm-k3r5-gp.conf +++ b/conf/machine/am62xx-evm-k3r5-gp.conf | |||
@@ -8,7 +8,11 @@ SYSFW_SOC = "am62x" | |||
8 | SYSFW_CONFIG = "evm" | 8 | SYSFW_CONFIG = "evm" |
9 | SYSFW_SUFFIX = "gp" | 9 | SYSFW_SUFFIX = "gp" |
10 | 10 | ||
11 | SYSFW_TIBOOT3_SYMLINK = "" | ||
12 | |||
11 | UBOOT_MACHINE = "am62x_evm_r5_defconfig" | 13 | UBOOT_MACHINE = "am62x_evm_r5_defconfig" |
12 | 14 | ||
15 | SPL_BINARY = "" | ||
13 | UBOOT_BINARY = "u-boot-spl.${UBOOT_SUFFIX}" | 16 | UBOOT_BINARY = "u-boot-spl.${UBOOT_SUFFIX}" |
14 | UBOOT_IMAGE = "u-boot-r5spl-gp-${MAINMACHINE}-${PV}-${PR}.${UBOOT_SUFFIX}" | 17 | UBOOT_IMAGE = "u-boot-r5spl-gp-${MAINMACHINE}-${PV}-${PR}.${UBOOT_SUFFIX}" |
18 | UBOOT_SYMLINK = "u-boot-r5spl-gp.${UBOOT_SUFFIX}" | ||
diff --git a/conf/machine/am62xx-evm-k3r5-hs-fs.conf b/conf/machine/am62xx-evm-k3r5-hs-fs.conf new file mode 100644 index 00000000..0f016547 --- /dev/null +++ b/conf/machine/am62xx-evm-k3r5-hs-fs.conf | |||
@@ -0,0 +1,14 @@ | |||
1 | #@TYPE: Machine | ||
2 | #@NAME: AM62xx HS-FS EVM (R5F) | ||
3 | #@DESCRIPTION: Machine configuration for the TI AM62xx HS-FS EVM (R5F core) | ||
4 | |||
5 | # Booting HS-FS requires different SYSFW, the rest is handled at runtime | ||
6 | |||
7 | require conf/machine/include/k3r5.inc | ||
8 | SOC_FAMILY_append = ":k3r5-hs-fs" | ||
9 | |||
10 | SYSFW_SOC = "am62x" | ||
11 | SYSFW_CONFIG = "evm" | ||
12 | SYSFW_SUFFIX = "hs-fs" | ||
13 | |||
14 | UBOOT_MACHINE = "am62x_evm_r5_defconfig" | ||
diff --git a/conf/machine/include/am62xx.inc b/conf/machine/include/am62xx.inc index 912318e9..6b2c0da3 100644 --- a/conf/machine/include/am62xx.inc +++ b/conf/machine/include/am62xx.inc | |||
@@ -8,11 +8,18 @@ SERIAL_CONSOLES_CHECK = "${SERIAL_CONSOLES}" | |||
8 | 8 | ||
9 | TFA_K3_SYSTEM_SUSPEND = "1" | 9 | TFA_K3_SYSTEM_SUSPEND = "1" |
10 | 10 | ||
11 | BBMULTICONFIG = "k3r5-gp" | 11 | # Default tiboot3.bin on AM62x is for HS-FS |
12 | do_image_wic[mcdepends] = "mc::k3r5-gp:ti-sci-fw:do_deploy" | 12 | BBMULTICONFIG = "k3r5-hs-fs" |
13 | do_image_tar[mcdepends] = "mc::k3r5-gp:ti-sci-fw:do_deploy" | 13 | do_image_wic[mcdepends] = "mc::k3r5-hs-fs:ti-sci-fw:do_deploy" |
14 | do_image_tar[mcdepends] = "mc::k3r5-hs-fs:ti-sci-fw:do_deploy" | ||
14 | 15 | ||
15 | # Since default tiboot3.bin on AM62x is for GP, add a version for HS-SE | 16 | # Since default tiboot3.bin on AM62x is for HS-FS, add a version for GP |
17 | BBMULTICONFIG += "k3r5-gp" | ||
18 | IMAGE_BOOT_FILES += " tiboot3-am62x-gp-evm.bin" | ||
19 | do_image_wic[mcdepends] += "mc::k3r5-gp:ti-sci-fw:do_deploy" | ||
20 | do_image_tar[mcdepends] += "mc::k3r5-gp:ti-sci-fw:do_deploy" | ||
21 | |||
22 | # Since default tiboot3.bin on AM62x is for HS-FS, add a version for HS-SE | ||
16 | BBMULTICONFIG += "k3r5-hs-se" | 23 | BBMULTICONFIG += "k3r5-hs-se" |
17 | IMAGE_BOOT_FILES += " tiboot3-am62x-hs-evm.bin" | 24 | IMAGE_BOOT_FILES += " tiboot3-am62x-hs-evm.bin" |
18 | do_image_wic[mcdepends] += "mc::k3r5-hs-se:ti-sci-fw:do_deploy" | 25 | do_image_wic[mcdepends] += "mc::k3r5-hs-se:ti-sci-fw:do_deploy" |
diff --git a/conf/multiconfig/k3r5-hs-fs.conf b/conf/multiconfig/k3r5-hs-fs.conf new file mode 100644 index 00000000..c6d58ead --- /dev/null +++ b/conf/multiconfig/k3r5-hs-fs.conf | |||
@@ -0,0 +1,3 @@ | |||
1 | require k3r5.conf | ||
2 | |||
3 | MACHINE_append = "-hs-fs" | ||
diff --git a/recipes-bsp/ti-sci-fw/ti-sci-fw_git.bb b/recipes-bsp/ti-sci-fw/ti-sci-fw_git.bb index 7896c366..7d046750 100644 --- a/recipes-bsp/ti-sci-fw/ti-sci-fw_git.bb +++ b/recipes-bsp/ti-sci-fw/ti-sci-fw_git.bb | |||
@@ -39,6 +39,7 @@ SYSFW_PREFIX_j784s4-evm-k3r5 = "fs" | |||
39 | SYSFW_PREFIX_j784s4-hs-evm-k3r5 = "fs" | 39 | SYSFW_PREFIX_j784s4-hs-evm-k3r5 = "fs" |
40 | SYSFW_PREFIX_am62xx-evm-k3r5-gp = "fs" | 40 | SYSFW_PREFIX_am62xx-evm-k3r5-gp = "fs" |
41 | SYSFW_PREFIX_am62xx-evm-k3r5-hs-se = "fs" | 41 | SYSFW_PREFIX_am62xx-evm-k3r5-hs-se = "fs" |
42 | SYSFW_PREFIX_am62xx-evm-k3r5-hs-fs = "fs" | ||
42 | SYSFW_PREFIX_am62xx-lp-evm-k3r5 = "fs" | 43 | SYSFW_PREFIX_am62xx-lp-evm-k3r5 = "fs" |
43 | SYSFW_PREFIX_am62xx-lp-evm-k3r5-hs-se = "fs" | 44 | SYSFW_PREFIX_am62xx-lp-evm-k3r5-hs-se = "fs" |
44 | SYSFW_PREFIX_am62axx-evm-k3r5 = "fs" | 45 | SYSFW_PREFIX_am62axx-evm-k3r5 = "fs" |