summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorSai Sree Kartheek Adivi <s-adivi@ti.com>2023-02-14 17:18:24 +0530
committerRyan Eatmon <reatmon@ti.com>2023-02-14 07:45:02 -0600
commit2bf12f5449405c6e1600775dee7e3a08f3ab623b (patch)
treece24c9e6efd851544aa8df996110c3b23a71f042
parent937b57b6d63a4267b96f25ec15c2809f7f288f76 (diff)
downloadmeta-ti-2bf12f5449405c6e1600775dee7e3a08f3ab623b.tar.gz
am62axx-evm: Add AM62A HS-FS evm configuration
Lets add the basic AM62A configuration - Add machine conf for AM62A. - The wic images will boot on AM62A HS-FS devices by default. The sysfw image for GP and HS-SE will be packaged in the wic image as tiboot3-am62ax-gp-evm.bin and tiboot3-am62ax-hs-evm.bin respectively. - Add ti-sci-firmware overrides. - Sign ATF, OPTEE and RTOS Firmware. Signed-off-by: Chirag Shilwant <c-shilwant@ti.com> Signed-off-by: Ryan Eatmon <reatmon@ti.com>
-rw-r--r--conf/machine/am62axx-evm-k3r5-gp.conf19
-rw-r--r--conf/machine/am62axx-evm-k3r5-hs-fs.conf14
-rw-r--r--conf/machine/am62axx-evm-k3r5-hs-se.conf22
-rw-r--r--conf/machine/am62axx-evm-k3r5.conf11
-rw-r--r--conf/machine/am62axx-evm.conf4
-rw-r--r--conf/machine/include/am62axx.inc18
-rw-r--r--recipes-bsp/ti-sci-fw/ti-sci-fw_git.bb4
-rw-r--r--recipes-bsp/trusted-firmware-a/trusted-firmware-a_%.bbappend4
-rw-r--r--recipes-security/optee/optee-os_%.bbappend4
-rw-r--r--recipes-ti/ti-rtos-bin/ti-rtos-firmware.bb16
10 files changed, 102 insertions, 14 deletions
diff --git a/conf/machine/am62axx-evm-k3r5-gp.conf b/conf/machine/am62axx-evm-k3r5-gp.conf
new file mode 100644
index 00000000..962413c3
--- /dev/null
+++ b/conf/machine/am62axx-evm-k3r5-gp.conf
@@ -0,0 +1,19 @@
1#@TYPE: Machine
2#@NAME: AM62A GP EVM (R5F)
3#@DESCRIPTION: Machine configuration for the TI AM62A GP EVM (R5F core)
4
5require conf/machine/include/k3r5.inc
6
7SYSFW_SOC = "am62ax"
8SYSFW_CONFIG = "evm"
9SYSFW_SUFFIX = "gp"
10
11SYSFW_TIBOOT3_SYMLINK = ""
12SYSFW_SYMLINK = ""
13
14UBOOT_MACHINE = "am62ax_evm_r5_defconfig"
15
16SPL_BINARY = ""
17UBOOT_BINARY = "u-boot-spl.${UBOOT_SUFFIX}"
18UBOOT_IMAGE = "u-boot-r5spl-gp-${MAINMACHINE}-${PV}-${PR}.${UBOOT_SUFFIX}"
19UBOOT_SYMLINK = "u-boot-r5spl-gp.${UBOOT_SUFFIX}"
diff --git a/conf/machine/am62axx-evm-k3r5-hs-fs.conf b/conf/machine/am62axx-evm-k3r5-hs-fs.conf
new file mode 100644
index 00000000..2d69d06c
--- /dev/null
+++ b/conf/machine/am62axx-evm-k3r5-hs-fs.conf
@@ -0,0 +1,14 @@
1#@TYPE: Machine
2#@NAME: AM62A HS-FS EVM (R5F)
3#@DESCRIPTION: Machine configuration for the TI AM62A HS-FS EVM (R5F core)
4
5# Booting HS-FS requires different SYSFW, the rest is handled at runtime
6
7require conf/machine/include/k3r5.inc
8SOC_FAMILY_append = ":k3r5-hs-fs"
9
10SYSFW_SOC = "am62ax"
11SYSFW_CONFIG = "evm"
12SYSFW_SUFFIX = "hs-fs"
13
14UBOOT_MACHINE = "am62ax_evm_r5_defconfig"
diff --git a/conf/machine/am62axx-evm-k3r5-hs-se.conf b/conf/machine/am62axx-evm-k3r5-hs-se.conf
new file mode 100644
index 00000000..c828606c
--- /dev/null
+++ b/conf/machine/am62axx-evm-k3r5-hs-se.conf
@@ -0,0 +1,22 @@
1#@TYPE: Machine
2#@NAME: AM62A HS-SE EVM (R5F)
3#@DESCRIPTION: Machine configuration for the TI AM62A HS-SE EVM (R5F core)
4
5# Booting HS-SE requires different SYSFW, the rest is handled at runtime
6
7require conf/machine/include/k3r5.inc
8SOC_FAMILY_append = ":k3r5-hs-se"
9
10SYSFW_SOC = "am62ax"
11SYSFW_CONFIG = "evm"
12SYSFW_SUFFIX = "hs"
13
14SYSFW_TIBOOT3_SYMLINK = ""
15SYSFW_SYMLINK = ""
16
17UBOOT_MACHINE = "am62ax_evm_r5_defconfig"
18
19SPL_BINARY = ""
20UBOOT_BINARY = "u-boot-spl.${UBOOT_SUFFIX}"
21UBOOT_IMAGE = "u-boot-r5spl-hs-se-${MAINMACHINE}-${PV}-${PR}.${UBOOT_SUFFIX}"
22UBOOT_SYMLINK = "u-boot-r5spl-hs-se.${UBOOT_SUFFIX}"
diff --git a/conf/machine/am62axx-evm-k3r5.conf b/conf/machine/am62axx-evm-k3r5.conf
deleted file mode 100644
index ca30537f..00000000
--- a/conf/machine/am62axx-evm-k3r5.conf
+++ /dev/null
@@ -1,11 +0,0 @@
1#@TYPE: Machine
2#@NAME: AM62AXX EVM (R5F)
3#@DESCRIPTION: Machine configuration for the TI AM62Axx EVM (R5F core)
4
5require conf/machine/include/k3r5.inc
6
7SYSFW_SOC = "am62ax"
8SYSFW_CONFIG = "evm"
9SYSFW_SUFFIX = "gp"
10
11UBOOT_MACHINE = "am62ax_evm_r5_defconfig"
diff --git a/conf/machine/am62axx-evm.conf b/conf/machine/am62axx-evm.conf
index e7a59d2e..9dcb6e55 100644
--- a/conf/machine/am62axx-evm.conf
+++ b/conf/machine/am62axx-evm.conf
@@ -23,3 +23,7 @@ KERNEL_DEVICETREE = " \
23" 23"
24 24
25UBOOT_MACHINE = "am62ax_evm_a53_defconfig" 25UBOOT_MACHINE = "am62ax_evm_a53_defconfig"
26
27SPL_BINARY = "tispl.bin_HS"
28UBOOT_BINARY = "u-boot.img_HS"
29UBOOT_SYMLINK = "u-boot.img"
diff --git a/conf/machine/include/am62axx.inc b/conf/machine/include/am62axx.inc
index 383d1c3f..6ee3accc 100644
--- a/conf/machine/include/am62axx.inc
+++ b/conf/machine/include/am62axx.inc
@@ -8,8 +8,22 @@ SERIAL_CONSOLES_CHECK = "${SERIAL_CONSOLES}"
8 8
9TFA_K3_SYSTEM_SUSPEND = "1" 9TFA_K3_SYSTEM_SUSPEND = "1"
10 10
11do_image_wic[mcdepends] = "mc::k3r5:ti-sci-fw:do_deploy" 11# Default tiboot3.bin on AM62A is for HS-FS
12do_image_tar[mcdepends] = "mc::k3r5:ti-sci-fw:do_deploy" 12BBMULTICONFIG = "k3r5-hs-fs"
13do_image_wic[mcdepends] = "mc::k3r5-hs-fs:ti-sci-fw:do_deploy"
14do_image_tar[mcdepends] = "mc::k3r5-hs-fs:ti-sci-fw:do_deploy"
15
16# Since default tiboot3.bin on AM62A is for HS-FS, add a version for GP
17BBMULTICONFIG += "k3r5-gp"
18IMAGE_BOOT_FILES += " tiboot3-am62ax-gp-evm.bin"
19do_image_wic[mcdepends] += "mc::k3r5-gp:ti-sci-fw:do_deploy"
20do_image_tar[mcdepends] += "mc::k3r5-gp:ti-sci-fw:do_deploy"
21
22# Since default tiboot3.bin on AM62A is for HS-FS, add a version for HS-SE
23BBMULTICONFIG += "k3r5-hs-se"
24IMAGE_BOOT_FILES += " tiboot3-am62ax-hs-evm.bin"
25do_image_wic[mcdepends] += "mc::k3r5-hs-se:ti-sci-fw:do_deploy"
26do_image_tar[mcdepends] += "mc::k3r5-hs-se:ti-sci-fw:do_deploy"
13 27
14TFA_BOARD = "lite" 28TFA_BOARD = "lite"
15OPTEEMACHINE = "k3-am62x" 29OPTEEMACHINE = "k3-am62x"
diff --git a/recipes-bsp/ti-sci-fw/ti-sci-fw_git.bb b/recipes-bsp/ti-sci-fw/ti-sci-fw_git.bb
index e3ffef37..96929286 100644
--- a/recipes-bsp/ti-sci-fw/ti-sci-fw_git.bb
+++ b/recipes-bsp/ti-sci-fw/ti-sci-fw_git.bb
@@ -44,7 +44,9 @@ SYSFW_PREFIX_am62xx-evm-k3r5-hs-fs = "fs"
44SYSFW_PREFIX_am62xx-lp-evm-k3r5 = "fs" 44SYSFW_PREFIX_am62xx-lp-evm-k3r5 = "fs"
45SYSFW_PREFIX_am62xx-lp-evm-k3r5-hs-se = "fs" 45SYSFW_PREFIX_am62xx-lp-evm-k3r5-hs-se = "fs"
46SYSFW_PREFIX_am62xx-lp-evm-k3r5-hs-fs = "fs" 46SYSFW_PREFIX_am62xx-lp-evm-k3r5-hs-fs = "fs"
47SYSFW_PREFIX_am62axx-evm-k3r5 = "fs" 47SYSFW_PREFIX_am62axx-evm-k3r5-gp = "fs"
48SYSFW_PREFIX_am62axx-evm-k3r5-hs-fs = "fs"
49SYSFW_PREFIX_am62axx-evm-k3r5-hs-se = "fs"
48 50
49SYSFW_TISCI = "${S}/ti-sysfw/ti-${SYSFW_PREFIX}-firmware-${SYSFW_SOC}-*.bin" 51SYSFW_TISCI = "${S}/ti-sysfw/ti-${SYSFW_PREFIX}-firmware-${SYSFW_SOC}-*.bin"
50 52
diff --git a/recipes-bsp/trusted-firmware-a/trusted-firmware-a_%.bbappend b/recipes-bsp/trusted-firmware-a/trusted-firmware-a_%.bbappend
index 41071676..70406724 100644
--- a/recipes-bsp/trusted-firmware-a/trusted-firmware-a_%.bbappend
+++ b/recipes-bsp/trusted-firmware-a/trusted-firmware-a_%.bbappend
@@ -39,6 +39,10 @@ do_compile_append_am62xx-lp-evm() {
39 tfa_sign_k3hs 39 tfa_sign_k3hs
40} 40}
41 41
42do_compile_append_am62axx-evm() {
43 tfa_sign_k3hs
44}
45
42do_compile_append_j7-hs-evm() { 46do_compile_append_j7-hs-evm() {
43 tfa_sign_k3hs 47 tfa_sign_k3hs
44} 48}
diff --git a/recipes-security/optee/optee-os_%.bbappend b/recipes-security/optee/optee-os_%.bbappend
index 5c6c9d4a..7a22b1d7 100644
--- a/recipes-security/optee/optee-os_%.bbappend
+++ b/recipes-security/optee/optee-os_%.bbappend
@@ -80,6 +80,10 @@ do_compile_append_am62xx-lp-evm() {
80 optee_sign_k3hs 80 optee_sign_k3hs
81} 81}
82 82
83do_compile_append_am62axx-evm() {
84 optee_sign_k3hs
85}
86
83do_compile_append_j7-hs-evm() { 87do_compile_append_j7-hs-evm() {
84 optee_sign_k3hs 88 optee_sign_k3hs
85} 89}
diff --git a/recipes-ti/ti-rtos-bin/ti-rtos-firmware.bb b/recipes-ti/ti-rtos-bin/ti-rtos-firmware.bb
index 982171e6..e2703070 100644
--- a/recipes-ti/ti-rtos-bin/ti-rtos-firmware.bb
+++ b/recipes-ti/ti-rtos-bin/ti-rtos-firmware.bb
@@ -186,6 +186,20 @@ do_install_prepend_am62xx() {
186 ) 186 )
187} 187}
188 188
189do_install_prepend_am62axx-evm() {
190 export TI_SECURE_DEV_PKG=${TI_SECURE_DEV_PKG}
191 ( cd ${RTOS_DM_FW_DIR}; \
192 mv ${DM_FIRMWARE} ${DM_FIRMWARE}.unsigned; \
193 ${TI_SECURE_DEV_PKG}/scripts/secure-binary-image.sh ${DM_FIRMWARE}.unsigned ${DM_FIRMWARE}; \
194 )
195 ( cd ${RTOS_IPC_FW_DIR}; \
196 ${TI_SECURE_DEV_PKG}/scripts/secure-binary-image.sh am62a-mcu-r5f0_0-fw \
197 am62a-mcu-r5f0_0-fw.signed; \
198 ${TI_SECURE_DEV_PKG}/scripts/secure-binary-image.sh ipc_echo_test_c7x_1_release_strip.xe71 \
199 ipc_echo_test_c7x_1_release_strip.xe71.signed; \
200 )
201}
202
189#Install all R5 & DSP ipc echo test binaries in lib/firmware/pdk-ipc, with softlinks up a level 203#Install all R5 & DSP ipc echo test binaries in lib/firmware/pdk-ipc, with softlinks up a level
190do_install() { 204do_install() {
191 205
@@ -367,8 +381,10 @@ do_install_am62axx() {
367 install -d ${LEGACY_IPC_FW_DIR} 381 install -d ${LEGACY_IPC_FW_DIR}
368 # DM+IPC Firmware 382 # DM+IPC Firmware
369 install -m 0644 ${RTOS_IPC_FW_DIR}/am62a-mcu-r5f0_0-fw ${LEGACY_IPC_FW_DIR} 383 install -m 0644 ${RTOS_IPC_FW_DIR}/am62a-mcu-r5f0_0-fw ${LEGACY_IPC_FW_DIR}
384 install -m 0644 ${RTOS_IPC_FW_DIR}/am62a-mcu-r5f0_0-fw.signed ${LEGACY_IPC_FW_DIR}
370 install -m 0644 ${RTOS_DM_FW_DIR}/ipc_echo_testb_mcu1_0_release_strip.xer5f ${LEGACY_DM_FW_DIR} 385 install -m 0644 ${RTOS_DM_FW_DIR}/ipc_echo_testb_mcu1_0_release_strip.xer5f ${LEGACY_DM_FW_DIR}
371 install -m 0644 ${RTOS_IPC_FW_DIR}/ipc_echo_test_c7x_1_release_strip.xe71 ${LEGACY_IPC_FW_DIR} 386 install -m 0644 ${RTOS_IPC_FW_DIR}/ipc_echo_test_c7x_1_release_strip.xe71 ${LEGACY_IPC_FW_DIR}
387 install -m 0644 ${RTOS_IPC_FW_DIR}/ipc_echo_test_c7x_1_release_strip.xe71.signed ${LEGACY_IPC_FW_DIR}
372} 388}
373 389
374do_deploy() { 390do_deploy() {