summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorMrinmayee Hingolikar <mrinmayee@ti.com>2014-05-22 02:23:23 +0000
committerDenys Dmytriyenko <denys@ti.com>2014-05-21 16:23:41 -0400
commitf79abadb2b0c8ae178be904f8e19f50117e0a015 (patch)
treeb214e46cef45d91c9c4a4603511c8ef7794d0a97
parentf9253dc88fc9cfe36e39d4b8f1e233eb3f4eaa3f (diff)
downloadmeta-ti-f79abadb2b0c8ae178be904f8e19f50117e0a015.tar.gz
omap5-sgx-ddk-um-linux: Add version 1.9.0.12
* Pulled in latest version 1.9.0.12 from meta-ti-gsldk and preserved authorship for Mrinmayee * Mark this recipe as providing the gles1, gles2, and egl libraries so that it doesn't conflict with other recipes like mesa and will be pulled in to satisfy those dependencies Signed-off-by: Mrinmayee Hingolikar <mrinmayee@ti.com> Signed-off-by: Chase Maupin <Chase.Maupin@ti.com> Signed-off-by: Denys Dmytriyenko <denys@ti.com>
-rw-r--r--recipes-graphics/libgles/omap5-sgx-ddk-um-linux_1.9.0.12.bb28
1 files changed, 28 insertions, 0 deletions
diff --git a/recipes-graphics/libgles/omap5-sgx-ddk-um-linux_1.9.0.12.bb b/recipes-graphics/libgles/omap5-sgx-ddk-um-linux_1.9.0.12.bb
new file mode 100644
index 00000000..b875328b
--- /dev/null
+++ b/recipes-graphics/libgles/omap5-sgx-ddk-um-linux_1.9.0.12.bb
@@ -0,0 +1,28 @@
1DESCRIPTION = "Userspace libraries for SGX"
2HOMEPAGE = "http://downloads.ti.com/dsps/dsps_public_sw/gfxsdk"
3LICENSE = "TI-TSPA"
4LIC_FILES_CHKSUM = "file://OMAP5-Linux-Graphics-DDK-UM-Manifest.doc;md5=360d293df455e4f2d363bb4014a49603"
5
6SRC_URI = "git://git.ti.com/graphics/omap5-sgx-ddk-um-linux.git;protocol=git"
7SRCREV = "994922a5655c63b05343a9238cb30e6ef61744be"
8
9PR = "r2"
10PROVIDES += "virtual/egl virtual/libgles1 virtual/libgles2"
11
12RREPLACES_${PN} = "libegl libgles1 libgles2"
13RREPLACES_${PN}-dev = "libegl-dev libgles1-dev libgles2-dev"
14RREPLACES_${PN}-dbg = "libegl-dbg"
15
16S = "${WORKDIR}/git"
17
18do_install () {
19 oe_runmake install DESTDIR=${D}
20}
21
22FILES_${PN} = "${bindir}/*"
23FILES_${PN} += " ${libdir}/*"
24FILES_${PN} += "${includedir}/* /usr/share/sgx-lib/"
25
26INHIBIT_PACKAGE_STRIP = "1"
27
28INSANE_SKIP_${PN} += "dev-so"