summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorMrinmayee Hingolikar <mrinmayee@ti.com>2014-05-20 01:19:46 +0000
committerDenys Dmytriyenko <denys@ti.com>2014-05-21 15:40:15 -0400
commitc5c384d009a166d2636d48a6e23241950f19105b (patch)
tree145490fc81f69afc7299ad5772249320d9c58bc5
parentd607e15547967195b14a6552060fc163591e23a8 (diff)
downloadmeta-ti-c5c384d009a166d2636d48a6e23241950f19105b.tar.gz
bltsville: Add TI BLTsville library
* Migrated from meta-ti-glsdk and preserved authorship for Mrinmayee * This library allows use of the GC320 2D blitter * Modified for upstream: * LICENSE was changed to BSD-3-Clause but the TI-TSPA license is still present as well so modified this to be a dual license package. Signed-off-by: Chase Maupin <Chase.Maupin@ti.com> Signed-off-by: Denys Dmytriyenko <denys@ti.com>
-rw-r--r--recipes-graphics/bltsville/bltsville_git.bb22
1 files changed, 22 insertions, 0 deletions
diff --git a/recipes-graphics/bltsville/bltsville_git.bb b/recipes-graphics/bltsville/bltsville_git.bb
new file mode 100644
index 00000000..158d189f
--- /dev/null
+++ b/recipes-graphics/bltsville/bltsville_git.bb
@@ -0,0 +1,22 @@
1DESCRIPTION = "Userspace libraries and headers for TI BLTsville implementation"
2HOMEPAGE = "http://omapzoom.org/?p=platform/external/bltsville.git;a=summary"
3LICENSE = "BSD-3-Clause & TI-TSPA"
4LIC_FILES_CHKSUM = "file://COPYING;md5=10a9abb9c5bb19edd83a8cf66eef7148 \
5 file://ticpu/license;md5=0bb831850a0de80e32a63772d89c6562"
6
7PR = "r2"
8
9SRCREV = "016586280ecdae201fd6e340ec8c4f8a9605cc94"
10
11inherit autotools pkgconfig
12
13SRC_URI = "git://git.omapzoom.org/platform/external/bltsville.git;protocol=git"
14
15S = "${WORKDIR}/git"
16
17do_configure() {
18 chmod +x autogen.sh
19 ./autogen.sh --prefix=${prefix} --with-libtool-sysroot=${STAGING_DIR_TARGET}
20}
21
22FILES_${PN} += "${libdir}/libbltsville_ticpu_license.txt"