summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorChase Maupin <Chase.Maupin@ti.com>2013-12-12 18:12:54 -0600
committerDenys Dmytriyenko <denys@ti.com>2013-12-14 02:29:59 -0500
commitbe7a5b8c579417ae03598c8415fa2fc573a7cd9a (patch)
tree36c65f4547070558842d5c1fe3ffc6ffaf404baa
parent05bbc5ff52b97835fd4862d15663f8559d6eefd8 (diff)
downloadmeta-ti-be7a5b8c579417ae03598c8415fa2fc573a7cd9a.tar.gz
am33x-cm3: Add support for ti43x devices
* The ti43x devices use the same firmware image but load it slightly differently. * Add a different init script to load the firmware image for ti43x devices. * Because there are different init script make the package machine specific. Signed-off-by: Chase Maupin <Chase.Maupin@ti.com> Signed-off-by: Denys Dmytriyenko <denys@ti.com>
-rw-r--r--recipes-bsp/ti/am33x-cm3/init-am43x-cm36
-rw-r--r--recipes-bsp/ti/am33x-cm3_git.bb11
2 files changed, 15 insertions, 2 deletions
diff --git a/recipes-bsp/ti/am33x-cm3/init-am43x-cm3 b/recipes-bsp/ti/am33x-cm3/init-am43x-cm3
new file mode 100644
index 00000000..0a75c1fd
--- /dev/null
+++ b/recipes-bsp/ti/am33x-cm3/init-am43x-cm3
@@ -0,0 +1,6 @@
1#!/bin/sh
2
3# Load the PM CM3 firmware
4echo 1 > /sys/devices/44000000.ocp/44d00000.wkup_m3/firmware/am335x-pm-firmware.bin/loading
5cat /lib/firmware/am335x-pm-firmware.bin > /sys/devices/44000000.ocp/44d00000.wkup_m3/firmware/am335x-pm-firmware.bin/data
6echo 0 > /sys/devices/44000000.ocp/44d00000.wkup_m3/firmware/am335x-pm-firmware.bin/loading
diff --git a/recipes-bsp/ti/am33x-cm3_git.bb b/recipes-bsp/ti/am33x-cm3_git.bb
index 260db163..75b6c732 100644
--- a/recipes-bsp/ti/am33x-cm3_git.bb
+++ b/recipes-bsp/ti/am33x-cm3_git.bb
@@ -4,7 +4,10 @@ LICENSE = "TI-BSD"
4LIC_FILES_CHKSUM = "file://License.txt;md5=858099c817e47ea63559fc6b67ae8d91" 4LIC_FILES_CHKSUM = "file://License.txt;md5=858099c817e47ea63559fc6b67ae8d91"
5 5
6PV = "05.00.00.01" 6PV = "05.00.00.01"
7PR = "r0" 7PR = "r1"
8
9# Make package machine specific due to different init scripts
10PACKAGE_ARCH = "${MACHINE_ARCH}"
8 11
9# SRCREV corresponds to tag v05.00.00.01 12# SRCREV corresponds to tag v05.00.00.01
10SRCREV = "40cb75b9dd9ba15c6de1c15cbb7cce8f1a6588b8" 13SRCREV = "40cb75b9dd9ba15c6de1c15cbb7cce8f1a6588b8"
@@ -21,8 +24,12 @@ RDEPENDS_${PN}-initscript = "am33x-cm3"
21 24
22SRC_URI = "git://arago-project.org/git/projects/am33x-cm3.git;protocol=git;branch=${BRANCH} \ 25SRC_URI = "git://arago-project.org/git/projects/am33x-cm3.git;protocol=git;branch=${BRANCH} \
23 file://init-am33x-cm3 \ 26 file://init-am33x-cm3 \
27 file://init-am43x-cm3 \
24 " 28 "
25 29
30SCRIPT_ti33x = "init-am33x-cm3"
31SCRIPT_ti43x = "init-am43x-cm3"
32
26S = "${WORKDIR}/git" 33S = "${WORKDIR}/git"
27 34
28do_compile() { 35do_compile() {
@@ -35,7 +42,7 @@ do_install() {
35 42
36 # Install the init script to load the PM firmware at boot 43 # Install the init script to load the PM firmware at boot
37 install -d ${D}${sysconfdir}/init.d 44 install -d ${D}${sysconfdir}/init.d
38 install -m 0755 ${WORKDIR}/init-am33x-cm3 ${D}${sysconfdir}/init.d/${INITSCRIPT_NAME} 45 install -m 0755 ${WORKDIR}/${SCRIPT} ${D}${sysconfdir}/init.d/${INITSCRIPT_NAME}
39} 46}
40 47
41PACKAGES =+ "${PN}-initscript" 48PACKAGES =+ "${PN}-initscript"