summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorMrinmayee Hingolikar <mrinmayee@ti.com>2014-05-20 01:19:41 +0000
committerDenys Dmytriyenko <denys@ti.com>2014-05-21 15:39:34 -0400
commit5e740e406e0bb28a7aad9389eb0af44c306302ad (patch)
tree7e7fc64b4255b28929c91d871ca45832772b7a7b
parent983dd84d53436d3e73f589e83f7412c226e2236b (diff)
downloadmeta-ti-5e740e406e0bb28a7aad9389eb0af44c306302ad.tar.gz
ti-ipc: Add version 3.21.00.07
* Added version 3.21.00.07 from the meta-ti-glsdk layer. Preserved authorship by Mrinmayee * Cleaned up the recipe for upstream by removing the sed lines in do_configure and instead using EXTRA_OEMAKE values passed into the make process. Signed-off-by: Chase Maupin <Chase.Maupin@ti.com> Signed-off-by: Denys Dmytriyenko <denys@ti.com>
-rw-r--r--recipes-ti/ipc/ti-ipc/0002-ipc-Added-installation-prefix-feature-to-products.ma.patch38
-rw-r--r--recipes-ti/ipc/ti-ipc_3.21.00.07.bb31
2 files changed, 69 insertions, 0 deletions
diff --git a/recipes-ti/ipc/ti-ipc/0002-ipc-Added-installation-prefix-feature-to-products.ma.patch b/recipes-ti/ipc/ti-ipc/0002-ipc-Added-installation-prefix-feature-to-products.ma.patch
new file mode 100644
index 00000000..58d77c74
--- /dev/null
+++ b/recipes-ti/ipc/ti-ipc/0002-ipc-Added-installation-prefix-feature-to-products.ma.patch
@@ -0,0 +1,38 @@
1From 26d09063063593aec760151393226b96bc7ab9f8 Mon Sep 17 00:00:00 2001
2From: Mrinmayee Hingolikar <mrinmayee@ti.com>
3Date: Thu, 5 Sep 2013 17:01:15 +0530
4Subject: [PATCH] ipc: Added installation prefix feature to products.mak
5
6Signed-off-by: Mrinmayee Hingolikar <mrinmayee@ti.com>
7---
8 ipc-linux.mak | 1 +
9 products.mak | 1 +
10 2 files changed, 2 insertions(+)
11
12diff --git a/ipc-linux.mak b/ipc-linux.mak
13index 788a5a2..01579e4 100644
14--- a/ipc-linux.mak
15+++ b/ipc-linux.mak
16@@ -38,6 +38,7 @@ include products.mak
17 config:
18 @echo "Configuring Linux Ipc ..."
19 ./configure --host=$(TOOLCHAIN_LONGNAME) \
20+ --prefix=$(PREFIX) \
21 CC=$(TOOLCHAIN_PREFIX)gcc \
22 PLATFORM=$(PLATFORM) \
23 CMEM_INSTALL_DIR=$(CMEM_INSTALL_DIR) \
24diff --git a/products.mak b/products.mak
25index e418d2f..4578a1e 100644
26--- a/products.mak
27+++ b/products.mak
28@@ -55,6 +55,7 @@ PLATFORM ?=
29 TOOLCHAIN_LONGNAME = arm-none-linux-gnueabi
30 TOOLCHAIN_INSTALL_DIR = $(DEPOT)/_your_arm_code_gen_install_
31 TOOLCHAIN_PREFIX = $(TOOLCHAIN_INSTALL_DIR)/bin/$(TOOLCHAIN_LONGNAME)-
32+PREFIX = /usr/local
33
34 # Optional: Path to Linux Kernel - needed to build the MmRpc user libraries
35 # (for devices that support it)
36--
371.7.9.5
38
diff --git a/recipes-ti/ipc/ti-ipc_3.21.00.07.bb b/recipes-ti/ipc/ti-ipc_3.21.00.07.bb
new file mode 100644
index 00000000..8131754d
--- /dev/null
+++ b/recipes-ti/ipc/ti-ipc_3.21.00.07.bb
@@ -0,0 +1,31 @@
1DESCRIPTION = "TI Inter Process Communication (IPC) Mechanisms (for Uni- and Multi- Processor Configurations)"
2HOMEPAGE = "https://git.ti.com/ipc/pages/Home"
3LICENSE = "BSD"
4LIC_FILES_CHKSUM = "file://${S}/ipc-linux.mak;beginline=1;endline=30;md5=f2518e421e230f06fe6d449718d02edc"
5
6DEPENDS += "virtual/kernel"
7
8PR = "r1"
9
10PACKAGE_ARCH = "${MACHINE_ARCH}"
11
12PLATFORM_omap5-evm = "OMAP54XX"
13PLATFORM_dra7xx-evm = "DRA7XX"
14
15inherit autotools pkgconfig
16
17SRC_URI = "git://git.ti.com/ipc/ipcdev.git;protocol=git \
18 file://0002-ipc-Added-installation-prefix-feature-to-products.ma.patch \
19 "
20
21SRCREV = "c18fece0c9f0dc76361dc1ee11b7ee2417479847"
22
23S = "${WORKDIR}/git"
24
25FILESEXTRAPATHS_prepend := "${THISDIR}:"
26
27EXTRA_OEMAKE += "KERNEL_INSTALL_DIR=${STAGING_KERNEL_DIR} TOOLCHAIN_INSTALL_DIR=${TOOLCHAIN_PATH} TOOLCHAIN_LONGNAME=${TOOLCHAIN_SYS} PLATFORM=${PLATFORM} PREFIX=${prefix}"
28
29do_configure() {
30 oe_runmake -f ${S}/ipc-linux.mak config
31}