summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorMaupin, Chase <chase.maupin@ti.com>2014-05-23 02:08:33 +0000
committerDenys Dmytriyenko <denys@ti.com>2014-05-23 15:01:27 -0400
commit5548cad9ffb24e06f645c6c8ff843ba1b79c290d (patch)
tree2f850d91d8bfb185c5b7deaf38047da67e10b0a3
parent901b6c2b244ad5dd1c60d3fcbb0631577c051fcd (diff)
downloadmeta-ti-5548cad9ffb24e06f645c6c8ff843ba1b79c290d.tar.gz
linux-ti-staging: Add version 3.15 of TI integration kernel
* Add version 3.15 of the TI integration kernel. Major changes from previous version are: * Config fragments now come primarily from the integration tree. Removed baseport and connectivity fragments for now and the others can be removed as they are added to the integration tree. * Added a non-smp.cfg config to disable SMP for single core devices instead of using a patch to the defconfig file as we did in the past. * Use the right SRCREV Signed-off-by: Chase Maupin <Chase.Maupin@ti.com> Signed-off-by: Denys Dmytriyenko <denys@ti.com>
-rw-r--r--recipes-kernel/linux/linux-ti-staging-3.15/defconfig1
-rw-r--r--recipes-kernel/linux/linux-ti-staging-3.15/ipc.cfg18
-rw-r--r--recipes-kernel/linux/linux-ti-staging-3.15/non-smp.cfg5
-rw-r--r--recipes-kernel/linux/linux-ti-staging-3.15/systest.cfg20
-rw-r--r--recipes-kernel/linux/linux-ti-staging_3.15.bb59
5 files changed, 103 insertions, 0 deletions
diff --git a/recipes-kernel/linux/linux-ti-staging-3.15/defconfig b/recipes-kernel/linux/linux-ti-staging-3.15/defconfig
new file mode 100644
index 00000000..926b35a5
--- /dev/null
+++ b/recipes-kernel/linux/linux-ti-staging-3.15/defconfig
@@ -0,0 +1 @@
use-kernel-config=omap2plus_defconfig
diff --git a/recipes-kernel/linux/linux-ti-staging-3.15/ipc.cfg b/recipes-kernel/linux/linux-ti-staging-3.15/ipc.cfg
new file mode 100644
index 00000000..645dfdfa
--- /dev/null
+++ b/recipes-kernel/linux/linux-ti-staging-3.15/ipc.cfg
@@ -0,0 +1,18 @@
1##################################################
2# IPC config options
3##################################################
4CONFIG_IOMMU_API=y
5CONFIG_IOMMU_SUPPORT=y
6CONFIG_OF_IOMMU=y
7CONFIG_OMAP_IOMMU=y
8CONFIG_OMAP_IOVMM=y
9CONFIG_OMAP_IOMMU_DEBUG=y
10CONFIG_VIRTIO=m
11CONFIG_RPMSG=m
12CONFIG_RPMSG_RPC=m
13CONFIG_REMOTEPROC=m
14CONFIG_OMAP_REMOTEPROC=m
15CONFIG_OMAP_REMOTEPROC_IPU=y
16CONFIG_OMAP_REMOTEPROC_DSP=y
17CONFIG_OMAP_REMOTEPROC_IPU1=y
18CONFIG_OMAP_REMOTEPROC_DSP2=y
diff --git a/recipes-kernel/linux/linux-ti-staging-3.15/non-smp.cfg b/recipes-kernel/linux/linux-ti-staging-3.15/non-smp.cfg
new file mode 100644
index 00000000..d61a4139
--- /dev/null
+++ b/recipes-kernel/linux/linux-ti-staging-3.15/non-smp.cfg
@@ -0,0 +1,5 @@
1##################################################
2# Non-SMP config options
3##################################################
4CONFIG_SMP=n
5CONFIG_NR_CPUS=n
diff --git a/recipes-kernel/linux/linux-ti-staging-3.15/systest.cfg b/recipes-kernel/linux/linux-ti-staging-3.15/systest.cfg
new file mode 100644
index 00000000..e21602f4
--- /dev/null
+++ b/recipes-kernel/linux/linux-ti-staging-3.15/systest.cfg
@@ -0,0 +1,20 @@
1##################################################
2# Systest config options
3##################################################
4CONFIG_DEBUG_SPINLOCK=y
5CONFIG_DEBUG_MUTEXES=y
6CONFIG_DEBUG_KMEMLEAK=y
7CONFIG_DEVKMEM=y
8CONFIG_HAVE_DEBUG_KMEMLEAK=y
9CONFIG_DEBUG_KMEMLEAK_EARLY_LOG_SIZE=400
10CONFIG_DEBUG_KMEMLEAK_TEST=n
11CONFIG_DEBUG_KMEMLEAK_DEFAULT_OFF=n
12CONFIG_DEBUG_LOCK_ALLOC=y
13CONFIG_DEBUG_INFO=y
14CONFIG_DEBUG_FS=y
15CONFIG_DEBUG_KERNEL=y
16CONFIG_PM_DEBUG=y
17CONFIG_DEBUG_GPIO=y
18CONFIG_USB_DEBUG=y
19CONFIG_SND_DEBUG=y
20CONFIG_RTC_DEBUG=y
diff --git a/recipes-kernel/linux/linux-ti-staging_3.15.bb b/recipes-kernel/linux/linux-ti-staging_3.15.bb
new file mode 100644
index 00000000..308a4125
--- /dev/null
+++ b/recipes-kernel/linux/linux-ti-staging_3.15.bb
@@ -0,0 +1,59 @@
1SECTION = "kernel"
2DESCRIPTION = "Linux kernel for TI devices"
3LICENSE = "GPLv2"
4LIC_FILES_CHKSUM = "file://COPYING;md5=d7810fab7487fb0aad327b76f1be7cd7"
5
6inherit kernel
7
8require recipes-kernel/linux/linux-dtb.inc
9require recipes-kernel/linux/setup-defconfig.inc
10
11# Look in the generic major.minor directory for files
12FILESEXTRAPATHS_append := "${THISDIR}/${PN}-3.15:"
13
14# Pull in the devicetree files into the rootfs
15RDEPENDS_kernel-base += "kernel-devicetree"
16
17# Add a run-time dependency for the PM firmware to be installed
18# on the target file system.
19RDEPENDS_kernel-base_append_ti33x = " am33x-cm3"
20RDEPENDS_kernel-base_append_ti43x = " am33x-cm3"
21
22# Add a run-time dependency for the VPE VPDMA firmware to be installed
23# on the target file system.
24RDEPENDS_kernel-base_append_dra7xx-evm = " vpe-vpdma-fw"
25
26# Default is to package all dtb files for ti33x devices unless building
27# for the specific beaglebone machine.
28KERNEL_DEVICETREE_ti33x = "am335x-evm.dtb am335x-evmsk.dtb am335x-bone.dtb am335x-boneblack.dtb"
29KERNEL_DEVICETREE_ti43x = "am43x-epos-evm.dtb am437x-gp-evm.dtb"
30KERNEL_DEVICETREE_beaglebone = "am335x-bone.dtb am335x-boneblack.dtb"
31KERNEL_DEVICETREE_omap5-evm = "omap5-uevm.dtb"
32KERNEL_DEVICETREE_dra7xx-evm = "dra7-evm.dtb"
33
34KERNEL_EXTRA_ARGS += "LOADADDR=${UBOOT_ENTRYPOINT}"
35
36COMPATIBLE_MACHINE = "ti33x|ti43x|omap-a15"
37
38S = "${WORKDIR}/git"
39
40BRANCH = "ti-linux-3.15.y"
41
42SRCREV = "3fd9aad17d3b4d1d7ee50ae788c0a096921e7216"
43PV = "3.14+3.15-rc6"
44
45# Append to the MACHINE_KERNEL_PR so that a new SRCREV will cause a rebuild
46MACHINE_KERNEL_PR_append = "b+gitr${SRCPV}"
47PR = "${MACHINE_KERNEL_PR}"
48
49KERNEL_CONFIG_DIR = "ti_config_fragments"
50KERNEL_CONFIG_FRAGMENTS = "${WORKDIR}/ipc.cfg"
51KERNEL_CONFIG_FRAGMENTS_append_ti33x = "${WORKDIR}/non-smp.cfg"
52KERNEL_CONFIG_FRAGMENTS_append_ti43x = "${WORKDIR}/non-smp.cfg"
53
54SRC_URI = "git://git.ti.com/ti-linux-kernel/ti-linux-kernel.git;protocol=git;branch=${BRANCH} \
55 file://defconfig \
56 file://ipc.cfg \
57 file://systest.cfg \
58 file://non-smp.cfg \
59 "