diff options
author | Denys Dmytriyenko <denys@ti.com> | 2014-02-13 14:43:45 -0500 |
---|---|---|
committer | Denys Dmytriyenko <denys@ti.com> | 2014-02-13 17:58:57 -0500 |
commit | 12482f8f914e7352d91ad72118872cb6836c87b3 (patch) | |
tree | 76acf7ce65a13d208f928fd44b68008383d354df | |
parent | 2506f037aaa0400de7199b705422a6fc6b94db25 (diff) | |
download | meta-ti-12482f8f914e7352d91ad72118872cb6836c87b3.tar.gz |
linux-ti-staging: apply network performance and LCD fixes locally for now
Signed-off-by: Denys Dmytriyenko <denys@ti.com>
8 files changed, 480 insertions, 1 deletions
diff --git a/recipes-kernel/linux/linux-ti-staging/0001-ARM-OMAP2-am43xx-Add-context-offset-for-dss-hwmod.patch b/recipes-kernel/linux/linux-ti-staging/0001-ARM-OMAP2-am43xx-Add-context-offset-for-dss-hwmod.patch new file mode 100644 index 00000000..52594a1a --- /dev/null +++ b/recipes-kernel/linux/linux-ti-staging/0001-ARM-OMAP2-am43xx-Add-context-offset-for-dss-hwmod.patch | |||
@@ -0,0 +1,44 @@ | |||
1 | From 52502d8e52ecd82cd802ee6900942d041f9a79ef Mon Sep 17 00:00:00 2001 | ||
2 | From: Dave Gerlach <d-gerlach@ti.com> | ||
3 | Date: Wed, 12 Feb 2014 16:06:46 -0600 | ||
4 | Subject: [PATCH 1/2] ARM: OMAP2+: am43xx: Add context offset for dss hwmod | ||
5 | |||
6 | Add context_offs to the DSS hwmod for am43xx as the driver uses the | ||
7 | context loss count to determine whether or not to restore context to the | ||
8 | module. Without this the display does not return after a suspend cycle. | ||
9 | |||
10 | Signed-off-by: Dave Gerlach <d-gerlach@ti.com> | ||
11 | --- | ||
12 | arch/arm/mach-omap2/omap_hwmod_33xx_data.c | 1 + | ||
13 | arch/arm/mach-omap2/prcm43xx.h | 3 +++ | ||
14 | 2 files changed, 4 insertions(+) | ||
15 | |||
16 | diff --git a/arch/arm/mach-omap2/omap_hwmod_33xx_data.c b/arch/arm/mach-omap2/omap_hwmod_33xx_data.c | ||
17 | index 978356d..4dcdcef 100644 | ||
18 | --- a/arch/arm/mach-omap2/omap_hwmod_33xx_data.c | ||
19 | +++ b/arch/arm/mach-omap2/omap_hwmod_33xx_data.c | ||
20 | @@ -1921,6 +1921,7 @@ static struct omap_hwmod am43xx_dss_core_hwmod = { | ||
21 | .prcm = { | ||
22 | .omap4 = { | ||
23 | .clkctrl_offs = AM43XX_CM_PER_DSS_CLKCTRL_OFFSET, | ||
24 | + .context_offs = AM43XX_PRM_RM_PER_DSS_CONTEXT, | ||
25 | .modulemode = MODULEMODE_SWCTRL, | ||
26 | }, | ||
27 | }, | ||
28 | diff --git a/arch/arm/mach-omap2/prcm43xx.h b/arch/arm/mach-omap2/prcm43xx.h | ||
29 | index f5344ab..d804228 100644 | ||
30 | --- a/arch/arm/mach-omap2/prcm43xx.h | ||
31 | +++ b/arch/arm/mach-omap2/prcm43xx.h | ||
32 | @@ -25,6 +25,9 @@ | ||
33 | #define AM43XX_PRM_WKUP_INST 0x2000 | ||
34 | #define AM43XX_PRM_DEVICE_INST 0x4000 | ||
35 | |||
36 | +/* PRM.PRM_PER offsets */ | ||
37 | +#define AM43XX_PRM_RM_PER_DSS_CONTEXT 0x1224 | ||
38 | + | ||
39 | /* RM RSTCTRL offsets */ | ||
40 | #define AM43XX_RM_PER_RSTCTRL_OFFSET 0x0010 | ||
41 | #define AM43XX_RM_GFX_RSTCTRL_OFFSET 0x0010 | ||
42 | -- | ||
43 | 1.7.9.5 | ||
44 | |||
diff --git a/recipes-kernel/linux/linux-ti-staging/0001-ARM-config-omap-Sync-up-omap2plus-defconfig-with-sav.patch b/recipes-kernel/linux/linux-ti-staging/0001-ARM-config-omap-Sync-up-omap2plus-defconfig-with-sav.patch new file mode 100644 index 00000000..f6665211 --- /dev/null +++ b/recipes-kernel/linux/linux-ti-staging/0001-ARM-config-omap-Sync-up-omap2plus-defconfig-with-sav.patch | |||
@@ -0,0 +1,195 @@ | |||
1 | From 0e6113030205a51f16944d4f73e166792200def0 Mon Sep 17 00:00:00 2001 | ||
2 | From: Santosh Shilimkar <santosh.shilimkar@ti.com> | ||
3 | Date: Thu, 13 Feb 2014 10:51:55 -0500 | ||
4 | Subject: [PATCH 1/6] ARM: config: omap: Sync up omap2plus defconfig with | ||
5 | savedefconfig | ||
6 | |||
7 | This is preparatory patch for some of the config fragment updates | ||
8 | to be done for network performance issue. | ||
9 | |||
10 | Signed-off-by: Santosh Shilimkar <santosh.shilimkar@ti.com> | ||
11 | --- | ||
12 | arch/arm/configs/omap2plus_defconfig | 67 ++++++++++------------------------ | ||
13 | 1 file changed, 20 insertions(+), 47 deletions(-) | ||
14 | |||
15 | diff --git a/arch/arm/configs/omap2plus_defconfig b/arch/arm/configs/omap2plus_defconfig | ||
16 | index f0484a2..2e8dcb9 100644 | ||
17 | --- a/arch/arm/configs/omap2plus_defconfig | ||
18 | +++ b/arch/arm/configs/omap2plus_defconfig | ||
19 | @@ -23,25 +23,22 @@ CONFIG_PARTITION_ADVANCED=y | ||
20 | CONFIG_ARCH_OMAP2PLUS=y | ||
21 | CONFIG_ARCH_MULTI_V6=y | ||
22 | CONFIG_GPIO_PCA953X=y | ||
23 | +CONFIG_OMAP_RESET_CLOCKS=y | ||
24 | +CONFIG_OMAP_MUX_DEBUG=y | ||
25 | CONFIG_ARCH_OMAP2=y | ||
26 | CONFIG_ARCH_OMAP3=y | ||
27 | CONFIG_ARCH_OMAP4=y | ||
28 | CONFIG_SOC_OMAP5=y | ||
29 | -CONFIG_SOC_AM33XX=y | ||
30 | CONFIG_SOC_AM43XX=y | ||
31 | CONFIG_SOC_DRA7XX=y | ||
32 | -CONFIG_OMAP_RESET_CLOCKS=y | ||
33 | -CONFIG_OMAP_MUX_DEBUG=y | ||
34 | -CONFIG_ARCH_VEXPRESS_CA9X4=y | ||
35 | CONFIG_OMAP4_ERRATA_I688=y | ||
36 | CONFIG_ARM_THUMBEE=y | ||
37 | CONFIG_ARM_ERRATA_411920=y | ||
38 | CONFIG_PCIE_DRA7XX=y | ||
39 | CONFIG_SMP=y | ||
40 | CONFIG_NR_CPUS=2 | ||
41 | -CONFIG_CMA=y | ||
42 | CONFIG_PREEMPT=y | ||
43 | -CONFIG_LEDS=y | ||
44 | +CONFIG_CMA=y | ||
45 | CONFIG_ZBOOT_ROM_TEXT=0x0 | ||
46 | CONFIG_ZBOOT_ROM_BSS=0x0 | ||
47 | CONFIG_ARM_APPENDED_DTB=y | ||
48 | @@ -75,30 +72,13 @@ CONFIG_IP_PNP_RARP=y | ||
49 | # CONFIG_INET_LRO is not set | ||
50 | # CONFIG_IPV6 is not set | ||
51 | CONFIG_NETFILTER=y | ||
52 | -CONFIG_NETFILTER_ADVANCED=y | ||
53 | -CONFIG_NETFILTER_XTABLES=y | ||
54 | -CONFIG_NF_NAT=y | ||
55 | -CONFIG_NF_NAT_NEEDED=y | ||
56 | -CONFIG_NF_NAT_IPV4=y | ||
57 | -CONFIG_NF_DEFRAG_IPV4=y | ||
58 | CONFIG_NF_CONNTRACK=y | ||
59 | CONFIG_NF_CONNTRACK_IPV4=y | ||
60 | -CONFIG_NF_CONNTRACK_PROC_COMPAT=y | ||
61 | CONFIG_IP_NF_IPTABLES=y | ||
62 | CONFIG_IP_NF_FILTER=y | ||
63 | -CONFIG_IP_NF_TARGET_LOG=y | ||
64 | +CONFIG_NF_NAT_IPV4=y | ||
65 | CONFIG_IP_NF_TARGET_MASQUERADE=y | ||
66 | CONFIG_BRIDGE=y | ||
67 | -CONFIG_BRIDGE_IGMP_SNOOPING=y | ||
68 | -CONFIG_BRIDGE_NETFILTER=y | ||
69 | -CONFIG_STP=y | ||
70 | -CONFIG_LLC=y | ||
71 | -CONFIG_INPUT_UINPUT=y | ||
72 | -CONFIG_HAS_IOMEM=y | ||
73 | -CONFIG_HAS_IOPORT=y | ||
74 | -CONFIG_HAS_DMA=y | ||
75 | -CONFIG_NLATTR=y | ||
76 | -CONFIG_AVERAGE=y | ||
77 | CONFIG_VLAN_8021Q=y | ||
78 | CONFIG_CAN=m | ||
79 | CONFIG_CAN_C_CAN=m | ||
80 | @@ -110,16 +90,13 @@ CONFIG_BT_HCIUART_BCSP=y | ||
81 | CONFIG_BT_HCIUART_LL=y | ||
82 | CONFIG_BT_HCIBCM203X=m | ||
83 | CONFIG_BT_HCIBPA10X=m | ||
84 | -CONFIG_NL80211_TESTMODE=y | ||
85 | +CONFIG_BT_WILINK=m | ||
86 | CONFIG_CFG80211=m | ||
87 | +CONFIG_NL80211_TESTMODE=y | ||
88 | CONFIG_MAC80211=m | ||
89 | CONFIG_MAC80211_RC_PID=y | ||
90 | CONFIG_MAC80211_RC_DEFAULT_PID=y | ||
91 | -CONFIG_WL_TI=y | ||
92 | -CONFIG_WL12XX=m | ||
93 | -CONFIG_WL18XX=m | ||
94 | -CONFIG_WLCORE=m | ||
95 | -CONFIG_WLCORE_SDIO=m | ||
96 | +CONFIG_RFKILL=y | ||
97 | CONFIG_UEVENT_HELPER_PATH="/sbin/hotplug" | ||
98 | CONFIG_DEVTMPFS=y | ||
99 | CONFIG_DEVTMPFS_MOUNT=y | ||
100 | @@ -171,6 +148,10 @@ CONFIG_LIBERTAS=m | ||
101 | CONFIG_LIBERTAS_USB=m | ||
102 | CONFIG_LIBERTAS_SDIO=m | ||
103 | CONFIG_LIBERTAS_DEBUG=y | ||
104 | +CONFIG_WL_TI=y | ||
105 | +CONFIG_WL12XX=m | ||
106 | +CONFIG_WL18XX=m | ||
107 | +CONFIG_WLCORE_SDIO=m | ||
108 | CONFIG_INPUT_JOYDEV=y | ||
109 | CONFIG_INPUT_EVDEV=y | ||
110 | CONFIG_KEYBOARD_GPIO=y | ||
111 | @@ -183,6 +164,7 @@ CONFIG_TOUCHSCREEN_TI_AM335X_TSC=y | ||
112 | CONFIG_TOUCHSCREEN_PIXCIR=m | ||
113 | CONFIG_INPUT_MISC=y | ||
114 | CONFIG_INPUT_TWL4030_PWRBUTTON=y | ||
115 | +CONFIG_INPUT_UINPUT=y | ||
116 | # CONFIG_LEGACY_PTYS is not set | ||
117 | CONFIG_SERIAL_8250=y | ||
118 | CONFIG_SERIAL_8250_CONSOLE=y | ||
119 | @@ -226,7 +208,6 @@ CONFIG_MFD_TPS65217=y | ||
120 | CONFIG_MFD_TPS65218=y | ||
121 | CONFIG_MFD_TPS65910=y | ||
122 | CONFIG_TWL6040_CORE=y | ||
123 | -CONFIG_REGULATOR_FIXED_VOLTAGE=y | ||
124 | CONFIG_REGULATOR_PALMAS=y | ||
125 | CONFIG_REGULATOR_PBIAS=y | ||
126 | CONFIG_REGULATOR_TPS65023=y | ||
127 | @@ -240,6 +221,10 @@ CONFIG_MEDIA_SUPPORT=y | ||
128 | CONFIG_MEDIA_CAMERA_SUPPORT=y | ||
129 | CONFIG_MEDIA_USB_SUPPORT=y | ||
130 | CONFIG_USB_VIDEO_CLASS=m | ||
131 | +CONFIG_V4L_PLATFORM_DRIVERS=y | ||
132 | +CONFIG_VIDEO_AM437X_VPFE=y | ||
133 | +# CONFIG_MEDIA_SUBDRV_AUTOSELECT is not set | ||
134 | +CONFIG_VIDEO_OV2659=y | ||
135 | CONFIG_FB=y | ||
136 | CONFIG_FIRMWARE_EDID=y | ||
137 | CONFIG_FB_TILEBLITTING=y | ||
138 | @@ -252,6 +237,7 @@ CONFIG_FB_OMAP2=y | ||
139 | CONFIG_DISPLAY_ENCODER_TFP410=y | ||
140 | CONFIG_DISPLAY_ENCODER_TPD12S015=y | ||
141 | CONFIG_DISPLAY_DRA_EVM_ENCODER_TPD12S015=y | ||
142 | +CONFIG_DISPLAY_ENCODER_SIL9022=y | ||
143 | CONFIG_DISPLAY_CONNECTOR_DVI=y | ||
144 | CONFIG_DISPLAY_CONNECTOR_HDMI=y | ||
145 | CONFIG_DISPLAY_PANEL_DPI=y | ||
146 | @@ -276,6 +262,7 @@ CONFIG_SND_DAVINCI_SOC=m | ||
147 | CONFIG_SND_AM33XX_SOC_EVM=m | ||
148 | CONFIG_SND_AM43XX_SOC_EPOS_EVM=m | ||
149 | CONFIG_SND_OMAP_SOC=m | ||
150 | +CONFIG_SND_OMAP_SOC_DRA7EVM=m | ||
151 | CONFIG_SND_OMAP_SOC_OMAP_TWL4030=m | ||
152 | CONFIG_SND_OMAP_SOC_OMAP_ABE_TWL6040=m | ||
153 | CONFIG_SND_OMAP_SOC_OMAP3_PANDORA=m | ||
154 | @@ -287,7 +274,6 @@ CONFIG_USB_EHCI_HCD=y | ||
155 | CONFIG_USB_MUSB_HDRC=m | ||
156 | CONFIG_USB_MUSB_OMAP2PLUS=m | ||
157 | CONFIG_USB_MUSB_DSPS=m | ||
158 | -CONFIG_USB_MUSB_AM335X_CHILD=m | ||
159 | CONFIG_USB_TI_CPPI41_DMA=y | ||
160 | CONFIG_USB_WDM=y | ||
161 | CONFIG_USB_STORAGE=y | ||
162 | @@ -390,17 +376,11 @@ CONFIG_SCHEDSTATS=y | ||
163 | CONFIG_TIMER_STATS=y | ||
164 | CONFIG_PROVE_LOCKING=y | ||
165 | # CONFIG_DEBUG_BUGVERBOSE is not set | ||
166 | -CONFIG_RFKILL=y | ||
167 | -CONFIG_KEYS=y | ||
168 | -CONFIG_BT_WILINK=m | ||
169 | -CONFIG_WIRELESS_EXT=y | ||
170 | CONFIG_SECURITY=y | ||
171 | -CONFIG_CRYPTO=y | ||
172 | -CONFIG_CRYPTO_ARC4=y | ||
173 | -CONFIG_CRYPTO_ECB=y | ||
174 | -CONFIG_CRYPTO_AES=y | ||
175 | CONFIG_CRYPTO_TEST=m | ||
176 | +CONFIG_CRYPTO_ECB=y | ||
177 | CONFIG_CRYPTO_MICHAEL_MIC=y | ||
178 | +CONFIG_CRYPTO_ARC4=y | ||
179 | # CONFIG_CRYPTO_ANSI_CPRNG is not set | ||
180 | CONFIG_CRYPTO_USER_API_HASH=y | ||
181 | CONFIG_CRYPTO_USER_API_SKCIPHER=y | ||
182 | @@ -415,10 +395,3 @@ CONFIG_LIBCRC32C=y | ||
183 | CONFIG_FONTS=y | ||
184 | CONFIG_FONT_8x8=y | ||
185 | CONFIG_FONT_8x16=y | ||
186 | -CONFIG_SND_OMAP_SOC_DRA7EVM=y | ||
187 | -CONFIG_DISPLAY_ENCODER_SIL9022=y | ||
188 | -CONFIG_VIDEO_V4L2=y | ||
189 | -CONFIG_V4L_PLATFORM_DRIVERS=y | ||
190 | -# CONFIG_MEDIA_SUBDRV_AUTOSELECT is not set | ||
191 | -CONFIG_VIDEO_AM437X_VPFE=y | ||
192 | -CONFIG_VIDEO_OV2659=y | ||
193 | -- | ||
194 | 1.7.9.5 | ||
195 | |||
diff --git a/recipes-kernel/linux/linux-ti-staging/0002-ARM-OMAP2-omap_hwmod-Add-context-ops-to-am43xx-soc_o.patch b/recipes-kernel/linux/linux-ti-staging/0002-ARM-OMAP2-omap_hwmod-Add-context-ops-to-am43xx-soc_o.patch new file mode 100644 index 00000000..02581421 --- /dev/null +++ b/recipes-kernel/linux/linux-ti-staging/0002-ARM-OMAP2-omap_hwmod-Add-context-ops-to-am43xx-soc_o.patch | |||
@@ -0,0 +1,36 @@ | |||
1 | From 8ec77cd15997749f51912e75bd47fad032cd3afe Mon Sep 17 00:00:00 2001 | ||
2 | From: Dave Gerlach <d-gerlach@ti.com> | ||
3 | Date: Wed, 12 Feb 2014 16:05:30 -0600 | ||
4 | Subject: [PATCH 2/2] ARM: OMAP2+: omap_hwmod: Add context ops to am43xx | ||
5 | soc_ops | ||
6 | |||
7 | AM43XX contains PRM_*_CONTEXT registers like OMAP4 did to track loss | ||
8 | of context in modules so utilize the same soc_ops present for OMAP4. | ||
9 | |||
10 | Certain drivers use the context loss count to determine if context was | ||
11 | truly lost during a suspend operation to decide whether or not a | ||
12 | context restore is truly necessary. Without this, some drivers may | ||
13 | choose not to restore context when they have actually lost it and fail | ||
14 | to properly resume. | ||
15 | |||
16 | Signed-off-by: Dave Gerlach <d-gerlach@ti.com> | ||
17 | --- | ||
18 | arch/arm/mach-omap2/omap_hwmod.c | 2 ++ | ||
19 | 1 file changed, 2 insertions(+) | ||
20 | |||
21 | diff --git a/arch/arm/mach-omap2/omap_hwmod.c b/arch/arm/mach-omap2/omap_hwmod.c | ||
22 | index 1f766fd..c03c54d 100644 | ||
23 | --- a/arch/arm/mach-omap2/omap_hwmod.c | ||
24 | +++ b/arch/arm/mach-omap2/omap_hwmod.c | ||
25 | @@ -4296,6 +4296,8 @@ void __init omap_hwmod_init(void) | ||
26 | soc_ops.deassert_hardreset = _omap4_deassert_hardreset; | ||
27 | soc_ops.is_hardreset_asserted = _omap4_is_hardreset_asserted; | ||
28 | soc_ops.init_clkdm = _init_clkdm; | ||
29 | + soc_ops.update_context_lost = _omap4_update_context_lost; | ||
30 | + soc_ops.get_context_lost = _omap4_get_context_lost; | ||
31 | } else if (soc_is_am33xx()) { | ||
32 | soc_ops.enable_module = _am33xx_enable_module; | ||
33 | soc_ops.disable_module = _am33xx_disable_module; | ||
34 | -- | ||
35 | 1.7.9.5 | ||
36 | |||
diff --git a/recipes-kernel/linux/linux-ti-staging/0002-ARM-config-omap-Make-advanced-networking-features-as.patch b/recipes-kernel/linux/linux-ti-staging/0002-ARM-config-omap-Make-advanced-networking-features-as.patch new file mode 100644 index 00000000..5c4ad5f9 --- /dev/null +++ b/recipes-kernel/linux/linux-ti-staging/0002-ARM-config-omap-Make-advanced-networking-features-as.patch | |||
@@ -0,0 +1,54 @@ | |||
1 | From c43131183974d2b02140dce3560cf7bba385b459 Mon Sep 17 00:00:00 2001 | ||
2 | From: Santosh Shilimkar <santosh.shilimkar@ti.com> | ||
3 | Date: Thu, 13 Feb 2014 08:22:42 -0500 | ||
4 | Subject: [PATCH 2/6] ARM: config: omap: Make advanced networking features as | ||
5 | modules | ||
6 | |||
7 | Linux networking supports advanced networking features like IPSEC, NETFILTERS, | ||
8 | BRIDGING etc and should be enabled only when user has specific usecase to | ||
9 | use them. Thats why all typical distro's build them as modules so that all | ||
10 | the standard network usecases don't get any additional overhead and specific | ||
11 | case can load those modules when needed. | ||
12 | |||
13 | Lets align the config accordingly. Created using typical 'savedefconfig' method. | ||
14 | |||
15 | Signed-off-by: Santosh Shilimkar <santosh.shilimkar@ti.com> | ||
16 | --- | ||
17 | arch/arm/configs/omap2plus_defconfig | 18 +++++++++++------- | ||
18 | 1 file changed, 11 insertions(+), 7 deletions(-) | ||
19 | |||
20 | diff --git a/arch/arm/configs/omap2plus_defconfig b/arch/arm/configs/omap2plus_defconfig | ||
21 | index 2e8dcb9..4c96d0c 100644 | ||
22 | --- a/arch/arm/configs/omap2plus_defconfig | ||
23 | +++ b/arch/arm/configs/omap2plus_defconfig | ||
24 | @@ -69,16 +69,20 @@ CONFIG_IP_PNP=y | ||
25 | CONFIG_IP_PNP_DHCP=y | ||
26 | CONFIG_IP_PNP_BOOTP=y | ||
27 | CONFIG_IP_PNP_RARP=y | ||
28 | +CONFIG_INET_XFRM_MODE_TRANSPORT=m | ||
29 | +CONFIG_INET_XFRM_MODE_TUNNEL=m | ||
30 | +CONFIG_INET_XFRM_MODE_BEET=m | ||
31 | # CONFIG_INET_LRO is not set | ||
32 | +CONFIG_INET_DIAG=m | ||
33 | # CONFIG_IPV6 is not set | ||
34 | CONFIG_NETFILTER=y | ||
35 | -CONFIG_NF_CONNTRACK=y | ||
36 | -CONFIG_NF_CONNTRACK_IPV4=y | ||
37 | -CONFIG_IP_NF_IPTABLES=y | ||
38 | -CONFIG_IP_NF_FILTER=y | ||
39 | -CONFIG_NF_NAT_IPV4=y | ||
40 | -CONFIG_IP_NF_TARGET_MASQUERADE=y | ||
41 | -CONFIG_BRIDGE=y | ||
42 | +CONFIG_NF_CONNTRACK=m | ||
43 | +CONFIG_NF_CONNTRACK_IPV4=m | ||
44 | +CONFIG_IP_NF_IPTABLES=m | ||
45 | +CONFIG_IP_NF_FILTER=m | ||
46 | +CONFIG_NF_NAT_IPV4=m | ||
47 | +CONFIG_IP_NF_TARGET_MASQUERADE=m | ||
48 | +CONFIG_BRIDGE=m | ||
49 | CONFIG_VLAN_8021Q=y | ||
50 | CONFIG_CAN=m | ||
51 | CONFIG_CAN_C_CAN=m | ||
52 | -- | ||
53 | 1.7.9.5 | ||
54 | |||
diff --git a/recipes-kernel/linux/linux-ti-staging/0003-ARM-config-omap-Disable-extra-debug-options.patch b/recipes-kernel/linux/linux-ti-staging/0003-ARM-config-omap-Disable-extra-debug-options.patch new file mode 100644 index 00000000..f515524e --- /dev/null +++ b/recipes-kernel/linux/linux-ti-staging/0003-ARM-config-omap-Disable-extra-debug-options.patch | |||
@@ -0,0 +1,47 @@ | |||
1 | From 2d7b208a86b15d2c35336783efa4b604d96ee31e Mon Sep 17 00:00:00 2001 | ||
2 | From: Santosh Shilimkar <santosh.shilimkar@ti.com> | ||
3 | Date: Thu, 13 Feb 2014 08:33:49 -0500 | ||
4 | Subject: [PATCH 3/6] ARM: config: omap: Disable extra debug options | ||
5 | |||
6 | LOCK debug, SCHED debug, PREEMPT debug are very expensive operations and | ||
7 | always in fast path of kernel operations. These are typical kernel development | ||
8 | options and should be disabled in production kernel builds. | ||
9 | |||
10 | Also enable JUMP_LABEL to take advantage of compiler optimisations. | ||
11 | |||
12 | Created using typical 'savedefconfig' method. Hence you see some crypto | ||
13 | option noise which unrelated and no impact on the end config. | ||
14 | |||
15 | Signed-off-by: Santosh Shilimkar <santosh.shilimkar@ti.com> | ||
16 | --- | ||
17 | arch/arm/configs/omap2plus_defconfig | 6 +++--- | ||
18 | 1 file changed, 3 insertions(+), 3 deletions(-) | ||
19 | |||
20 | diff --git a/arch/arm/configs/omap2plus_defconfig b/arch/arm/configs/omap2plus_defconfig | ||
21 | index 4c96d0c..4106761 100644 | ||
22 | --- a/arch/arm/configs/omap2plus_defconfig | ||
23 | +++ b/arch/arm/configs/omap2plus_defconfig | ||
24 | @@ -12,6 +12,7 @@ CONFIG_SLAB=y | ||
25 | CONFIG_PROFILING=y | ||
26 | CONFIG_OPROFILE=y | ||
27 | CONFIG_KPROBES=y | ||
28 | +CONFIG_JUMP_LABEL=y | ||
29 | CONFIG_MODULES=y | ||
30 | CONFIG_MODULE_FORCE_LOAD=y | ||
31 | CONFIG_MODULE_UNLOAD=y | ||
32 | @@ -376,10 +377,9 @@ CONFIG_NLS_ISO8859_1=y | ||
33 | CONFIG_PRINTK_TIME=y | ||
34 | CONFIG_DEBUG_INFO=y | ||
35 | CONFIG_MAGIC_SYSRQ=y | ||
36 | -CONFIG_SCHEDSTATS=y | ||
37 | -CONFIG_TIMER_STATS=y | ||
38 | -CONFIG_PROVE_LOCKING=y | ||
39 | +# CONFIG_SCHED_DEBUG is not set | ||
40 | # CONFIG_DEBUG_BUGVERBOSE is not set | ||
41 | +# CONFIG_FTRACE is not set | ||
42 | CONFIG_SECURITY=y | ||
43 | CONFIG_CRYPTO_TEST=m | ||
44 | CONFIG_CRYPTO_ECB=y | ||
45 | -- | ||
46 | 1.7.9.5 | ||
47 | |||
diff --git a/recipes-kernel/linux/linux-ti-staging/0004-Not-for-merge-ARM-config-omap-Disable-SMP-for-AM335x.patch b/recipes-kernel/linux/linux-ti-staging/0004-Not-for-merge-ARM-config-omap-Disable-SMP-for-AM335x.patch new file mode 100644 index 00000000..3813504f --- /dev/null +++ b/recipes-kernel/linux/linux-ti-staging/0004-Not-for-merge-ARM-config-omap-Disable-SMP-for-AM335x.patch | |||
@@ -0,0 +1,44 @@ | |||
1 | From adf38b7b71b35fcd1e229399e8eea7628be35815 Mon Sep 17 00:00:00 2001 | ||
2 | From: Santosh Shilimkar <santosh.shilimkar@ti.com> | ||
3 | Date: Thu, 13 Feb 2014 08:52:41 -0500 | ||
4 | Subject: [PATCH 4/6] Not-for-merge: ARM: config: omap: Disable SMP for AM335x | ||
5 | build | ||
6 | |||
7 | SMP and SMP_ON_UP introduces some extra barriers and code many fast paths | ||
8 | including kernel lock functions. | ||
9 | |||
10 | Performance sensitive usecases like networking gets impacted because of this. | ||
11 | In typical production kernel which is targeted for single core device | ||
12 | like AM335x family, you don't want to take this hit. | ||
13 | |||
14 | Ideally one should just create a device specific config feed as done by all | ||
15 | typical distro's. Other option is to apply this specifically during build | ||
16 | time using recipe. | ||
17 | |||
18 | Whichever option, one definitely don't want this overhead for performance | ||
19 | critical usecases. | ||
20 | |||
21 | Disabling SMP in the build introduces one warining in cpuidle44xx.c driver | ||
22 | and fix is included in the series | ||
23 | |||
24 | Signed-off-by: Santosh Shilimkar <santosh.shilimkar@ti.com> | ||
25 | --- | ||
26 | arch/arm/configs/omap2plus_defconfig | 2 -- | ||
27 | 1 file changed, 2 deletions(-) | ||
28 | |||
29 | diff --git a/arch/arm/configs/omap2plus_defconfig b/arch/arm/configs/omap2plus_defconfig | ||
30 | index 4106761..bf49ab6 100644 | ||
31 | --- a/arch/arm/configs/omap2plus_defconfig | ||
32 | +++ b/arch/arm/configs/omap2plus_defconfig | ||
33 | @@ -36,8 +36,6 @@ CONFIG_OMAP4_ERRATA_I688=y | ||
34 | CONFIG_ARM_THUMBEE=y | ||
35 | CONFIG_ARM_ERRATA_411920=y | ||
36 | CONFIG_PCIE_DRA7XX=y | ||
37 | -CONFIG_SMP=y | ||
38 | -CONFIG_NR_CPUS=2 | ||
39 | CONFIG_PREEMPT=y | ||
40 | CONFIG_CMA=y | ||
41 | CONFIG_ZBOOT_ROM_TEXT=0x0 | ||
42 | -- | ||
43 | 1.7.9.5 | ||
44 | |||
diff --git a/recipes-kernel/linux/linux-ti-staging/0005-ARM-OMAP-Kill-warning-in-CPUIDLE-code-with-CONFIG_SM.patch b/recipes-kernel/linux/linux-ti-staging/0005-ARM-OMAP-Kill-warning-in-CPUIDLE-code-with-CONFIG_SM.patch new file mode 100644 index 00000000..ef6e0a77 --- /dev/null +++ b/recipes-kernel/linux/linux-ti-staging/0005-ARM-OMAP-Kill-warning-in-CPUIDLE-code-with-CONFIG_SM.patch | |||
@@ -0,0 +1,49 @@ | |||
1 | From a612d323c1e5a88a46323d5ee8547283917dd3b6 Mon Sep 17 00:00:00 2001 | ||
2 | From: Santosh Shilimkar <santosh.shilimkar@ti.com> | ||
3 | Date: Wed, 12 Feb 2014 16:42:39 -0500 | ||
4 | Subject: [PATCH 5/6] ARM: OMAP: Kill warning in CPUIDLE code with !CONFIG_SMP | ||
5 | |||
6 | for non SMP build, NR_CPUS is 1 and hence the code complains with below | ||
7 | warnings. | ||
8 | |||
9 | arch/arm/mach-omap2/cpuidle44xx.c:207:8: warning: array subscript is above array bounds [-Warray-bounds] | ||
10 | arch/arm/mach-omap2/cpuidle44xx.c:212:11: warning: array subscript is above array bounds [-Warray-bounds] | ||
11 | |||
12 | Kill it by making array size fixed. | ||
13 | |||
14 | Signed-off-by: Santosh Shilimkar <santosh.shilimkar@ti.com> | ||
15 | --- | ||
16 | arch/arm/mach-omap2/cpuidle44xx.c | 8 +++++--- | ||
17 | 1 file changed, 5 insertions(+), 3 deletions(-) | ||
18 | |||
19 | diff --git a/arch/arm/mach-omap2/cpuidle44xx.c b/arch/arm/mach-omap2/cpuidle44xx.c | ||
20 | index 4c8982a..5e85f1e 100644 | ||
21 | --- a/arch/arm/mach-omap2/cpuidle44xx.c | ||
22 | +++ b/arch/arm/mach-omap2/cpuidle44xx.c | ||
23 | @@ -23,6 +23,8 @@ | ||
24 | #include "prm.h" | ||
25 | #include "clockdomain.h" | ||
26 | |||
27 | +#define MAX_CPUS 2 | ||
28 | + | ||
29 | /* Machine specific information */ | ||
30 | struct idle_statedata { | ||
31 | u32 cpu_state; | ||
32 | @@ -48,11 +50,11 @@ static struct idle_statedata omap4_idle_data[] = { | ||
33 | }, | ||
34 | }; | ||
35 | |||
36 | -static struct powerdomain *mpu_pd, *cpu_pd[NR_CPUS]; | ||
37 | -static struct clockdomain *cpu_clkdm[NR_CPUS]; | ||
38 | +static struct powerdomain *mpu_pd, *cpu_pd[MAX_CPUS]; | ||
39 | +static struct clockdomain *cpu_clkdm[MAX_CPUS]; | ||
40 | |||
41 | static atomic_t abort_barrier; | ||
42 | -static bool cpu_done[NR_CPUS]; | ||
43 | +static bool cpu_done[MAX_CPUS]; | ||
44 | static struct idle_statedata *state_ptr = &omap4_idle_data[0]; | ||
45 | |||
46 | /* Private functions */ | ||
47 | -- | ||
48 | 1.7.9.5 | ||
49 | |||
diff --git a/recipes-kernel/linux/linux-ti-staging_3.12.bb b/recipes-kernel/linux/linux-ti-staging_3.12.bb index 8254cc30..2a9d089c 100644 --- a/recipes-kernel/linux/linux-ti-staging_3.12.bb +++ b/recipes-kernel/linux/linux-ti-staging_3.12.bb | |||
@@ -40,9 +40,19 @@ SRCREV = "c883f50c5bbf1bf5bfaeb550991caf5fc77a1c4d" | |||
40 | PV = "3.12.10" | 40 | PV = "3.12.10" |
41 | 41 | ||
42 | # Append to the MACHINE_KERNEL_PR so that a new SRCREV will cause a rebuild | 42 | # Append to the MACHINE_KERNEL_PR so that a new SRCREV will cause a rebuild |
43 | MACHINE_KERNEL_PR_append = "b+gitr${SRCPV}" | 43 | MACHINE_KERNEL_PR_append = "c+gitr${SRCPV}" |
44 | PR = "${MACHINE_KERNEL_PR}" | 44 | PR = "${MACHINE_KERNEL_PR}" |
45 | 45 | ||
46 | SRC_URI = "git://git.ti.com/ti-linux-kernel/ti-linux-kernel.git;protocol=git;branch=${BRANCH} \ | 46 | SRC_URI = "git://git.ti.com/ti-linux-kernel/ti-linux-kernel.git;protocol=git;branch=${BRANCH} \ |
47 | file://defconfig \ | 47 | file://defconfig \ |
48 | " | 48 | " |
49 | SRC_URI += "file://0001-ARM-config-omap-Sync-up-omap2plus-defconfig-with-sav.patch \ | ||
50 | file://0002-ARM-config-omap-Make-advanced-networking-features-as.patch \ | ||
51 | file://0003-ARM-config-omap-Disable-extra-debug-options.patch \ | ||
52 | file://0005-ARM-OMAP-Kill-warning-in-CPUIDLE-code-with-CONFIG_SM.patch \ | ||
53 | file://0001-ARM-OMAP2-am43xx-Add-context-offset-for-dss-hwmod.patch \ | ||
54 | file://0002-ARM-OMAP2-omap_hwmod-Add-context-ops-to-am43xx-soc_o.patch \ | ||
55 | " | ||
56 | |||
57 | SRC_URI_append_ti33x = "file://0004-Not-for-merge-ARM-config-omap-Disable-SMP-for-AM335x.patch" | ||
58 | SRC_URI_append_ti43x = "file://0004-Not-for-merge-ARM-config-omap-Disable-SMP-for-AM335x.patch" | ||