summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorFranklin S. Cooper Jr <fcooper@ti.com>2012-09-01 12:45:03 -0500
committerDenys Dmytriyenko <denis@denix.org>2012-10-10 16:23:09 -0400
commitb7b8014c23bc3513e90dccd402b175ae5bdfe989 (patch)
tree2597337b385e8ca1fbdc5c7f49c110a764ed508a
parent3bd7a48f0fdd99d2aa59bb0f0aa71ac4639a0383 (diff)
downloadmeta-ti-b7b8014c23bc3513e90dccd402b175ae5bdfe989.tar.gz
recipes: Fix ti-eula-unpack issue. Tweak sgx modules and libgles recipes.
* Commit d8fc4a686262c50fd0053afa7240020909ec430b addressed an issue where too many newlines characters were being sent since print by default already sends a newline character. This commit however resulted in bin files being installed in the WORKDIR and broke other recipes which commit a94f765b9867abefd5f0bd262b5dddb8782b3187 addressed. This lead to a very cluttered WORKDIR. * This patch updates ti-eula-unpack.inc to switch from using a print to a write. Since write doesn't automatically send newlines it is a bit more obvious when newlines are sent. * Part of the reason that bin files were being installed in the WORKDIR was due to TI_BIN_UNPK_WDEXT being blank for some recipes. For instance in the libgles-omap3 recipes, when the workdir command is set in TI_BIN_UNPK_CMDS the directory that the Graphics SDK will be installed into is workdir+TI_BIN_UNPK_WDEXT. A blank TI_BIN_UNPK_WDEXT means the SDK will be installed in WORKDIR. By setting TI_BIN_UNPK_WDEXT to a proper value the recipes can be sure it is installed in the proper directory. * Determine which file to download based on the defined BINFILE and not a hardcoded value. This idea was taken from arago. Signed-off-by: Franklin S. Cooper Jr <fcooper@ti.com> Acked-by: Chase Maupin <chase.maupin@ti.com> Signed-off-by: Denys Dmytriyenko <denys@ti.com>
-rw-r--r--recipes-bsp/powervr-drivers/omap3-sgx-modules_1.6.16.3977.bb8
-rw-r--r--recipes-graphics/libgles/libgles-omap3.inc4
-rw-r--r--recipes-graphics/libgles/libgles-omap3_4.03.00.02.bb6
-rw-r--r--recipes-graphics/libgles/libgles-omap3_4.05.00.03.bb6
-rw-r--r--recipes-ti/includes/ti-eula-unpack.inc4
5 files changed, 14 insertions, 14 deletions
diff --git a/recipes-bsp/powervr-drivers/omap3-sgx-modules_1.6.16.3977.bb b/recipes-bsp/powervr-drivers/omap3-sgx-modules_1.6.16.3977.bb
index 0affee1e..4f9be7bc 100644
--- a/recipes-bsp/powervr-drivers/omap3-sgx-modules_1.6.16.3977.bb
+++ b/recipes-bsp/powervr-drivers/omap3-sgx-modules_1.6.16.3977.bb
@@ -11,17 +11,17 @@ BINFILE := "Graphics_SDK_setuplinux_${SGXPV}.bin"
11 11
12inherit module 12inherit module
13 13
14MACHINE_KERNEL_PR_append = "a" 14MACHINE_KERNEL_PR_append = "b"
15PR = "${MACHINE_KERNEL_PR}" 15PR = "${MACHINE_KERNEL_PR}"
16 16
17SRC_URI = "http://software-dl.ti.com/dsps/dsps_public_sw/sdo_sb/targetcontent/gfxsdk/${SGXPV}/exports/Graphics_SDK_setuplinux_${SGXPV}.bin \ 17SRC_URI = "http://software-dl.ti.com/dsps/dsps_public_sw/sdo_sb/targetcontent/gfxsdk/${SGXPV}/exports/${BINFILE} \
18 file://Compile-fixes-for-38-kernel.patch \ 18 file://Compile-fixes-for-38-kernel.patch \
19 file://kernel-30.patch \ 19 file://kernel-30.patch \
20 " 20 "
21SRC_URI[md5sum] = "ff8c1f2b8e4cb42f4ced6a613b081ada" 21SRC_URI[md5sum] = "ff8c1f2b8e4cb42f4ced6a613b081ada"
22SRC_URI[sha256sum] = "cdb0bd3964e107733d632aa8224e0537b05c1ffac34befc036423458c8d75255" 22SRC_URI[sha256sum] = "cdb0bd3964e107733d632aa8224e0537b05c1ffac34befc036423458c8d75255"
23 23TI_BIN_UNPK_WDEXT="/Graphics_SDK_${SGXPV}"
24S = "${WORKDIR}/Graphics_SDK_${SGXPV}/GFX_Linux_KM" 24S = "${WORKDIR}${TI_BIN_UNPK_WDEXT}/GFX_Linux_KM"
25 25
26PVRBUILD = "release" 26PVRBUILD = "release"
27export KERNELDIR = "${STAGING_KERNEL_DIR}" 27export KERNELDIR = "${STAGING_KERNEL_DIR}"
diff --git a/recipes-graphics/libgles/libgles-omap3.inc b/recipes-graphics/libgles/libgles-omap3.inc
index 18ee7ff8..b7f563f6 100644
--- a/recipes-graphics/libgles/libgles-omap3.inc
+++ b/recipes-graphics/libgles/libgles-omap3.inc
@@ -3,7 +3,7 @@ LICENSE = "proprietary-binary"
3# 'TSPA.txt' might not be the best file to md5sum 3# 'TSPA.txt' might not be the best file to md5sum
4LIC_FILES_CHKSUM = "file://TSPA.txt;md5=c0d5d9c1e38b41677144c4e24d6ddee1" 4LIC_FILES_CHKSUM = "file://TSPA.txt;md5=c0d5d9c1e38b41677144c4e24d6ddee1"
5 5
6PR = "r31" 6PR = "r33"
7 7
8COMPATIBLE_MACHINE = "(omap3|ti814x|ti816x|ti33x)" 8COMPATIBLE_MACHINE = "(omap3|ti814x|ti816x|ti33x)"
9 9
@@ -11,7 +11,7 @@ DEPENDS = "virtual/libx11 libxau libxdmcp libdrm"
11 11
12PROVIDES += "virtual/egl" 12PROVIDES += "virtual/egl"
13 13
14SRC_URI = "http://software-dl.ti.com/dsps/dsps_public_sw/sdo_sb/targetcontent/gfxsdk/${SGXPV}/exports/OMAP35x_Graphics_SDK_setuplinux_${SGXPV}.bin \ 14SRC_URI = "http://software-dl.ti.com/dsps/dsps_public_sw/sdo_sb/targetcontent/gfxsdk/${SGXPV}/exports/${BINFILE} \
15 file://cputype \ 15 file://cputype \
16 file://rc.pvr \ 16 file://rc.pvr \
17 file://sample.desktop \ 17 file://sample.desktop \
diff --git a/recipes-graphics/libgles/libgles-omap3_4.03.00.02.bb b/recipes-graphics/libgles/libgles-omap3_4.03.00.02.bb
index 97a22fea..e98fe025 100644
--- a/recipes-graphics/libgles/libgles-omap3_4.03.00.02.bb
+++ b/recipes-graphics/libgles/libgles-omap3_4.03.00.02.bb
@@ -15,8 +15,9 @@ require libgles-omap3.inc
15SGXPV = "4_03_00_02" 15SGXPV = "4_03_00_02"
16IMGPV = "1.6.16.3977" 16IMGPV = "1.6.16.3977"
17BINFILE := "Graphics_SDK_setuplinux_${SGXPV}.bin" 17BINFILE := "Graphics_SDK_setuplinux_${SGXPV}.bin"
18TI_BIN_UNPK_WDEXT := "/Graphics_SDK_${SGXPV}"
18 19
19SRC_URI = "http://software-dl.ti.com/dsps/dsps_public_sw/sdo_sb/targetcontent/gfxsdk/${SGXPV}/exports/Graphics_SDK_setuplinux_${SGXPV}.bin \ 20SRC_URI = "http://software-dl.ti.com/dsps/dsps_public_sw/sdo_sb/targetcontent/gfxsdk/${SGXPV}/exports/${BINFILE} \
20 file://cputype \ 21 file://cputype \
21 file://rc.pvr \ 22 file://rc.pvr \
22 file://sample.desktop \ 23 file://sample.desktop \
@@ -26,5 +27,4 @@ SRC_URI = "http://software-dl.ti.com/dsps/dsps_public_sw/sdo_sb/targetcontent/gf
26SRC_URI[md5sum] = "ff8c1f2b8e4cb42f4ced6a613b081ada" 27SRC_URI[md5sum] = "ff8c1f2b8e4cb42f4ced6a613b081ada"
27SRC_URI[sha256sum] = "cdb0bd3964e107733d632aa8224e0537b05c1ffac34befc036423458c8d75255" 28SRC_URI[sha256sum] = "cdb0bd3964e107733d632aa8224e0537b05c1ffac34befc036423458c8d75255"
28 29
29S = "${WORKDIR}" 30S = "${WORKDIR}/Graphics_SDK_${SGXPV}"
30
diff --git a/recipes-graphics/libgles/libgles-omap3_4.05.00.03.bb b/recipes-graphics/libgles/libgles-omap3_4.05.00.03.bb
index d55dd05d..7795e2e0 100644
--- a/recipes-graphics/libgles/libgles-omap3_4.05.00.03.bb
+++ b/recipes-graphics/libgles/libgles-omap3_4.05.00.03.bb
@@ -12,8 +12,9 @@ require libgles-omap3.inc
12SGXPV = "4_05_00_03" 12SGXPV = "4_05_00_03"
13IMGPV = "1.6.16.4117" 13IMGPV = "1.6.16.4117"
14BINFILE := "Graphics_SDK_setuplinux_${SGXPV}.bin" 14BINFILE := "Graphics_SDK_setuplinux_${SGXPV}.bin"
15TI_BIN_UNPK_WDEXT := "/Graphics_SDK_${SGXPV}"
15 16
16SRC_URI = "http://software-dl.ti.com/dsps/dsps_public_sw/sdo_sb/targetcontent/gfxsdk/${SGXPV}/exports/Graphics_SDK_setuplinux_${SGXPV}.bin \ 17SRC_URI = "http://software-dl.ti.com/dsps/dsps_public_sw/sdo_sb/targetcontent/gfxsdk/${SGXPV}/exports/${BINFILE} \
17 file://cputype \ 18 file://cputype \
18 file://rc.pvr \ 19 file://rc.pvr \
19 file://sample.desktop \ 20 file://sample.desktop \
@@ -23,5 +24,4 @@ SRC_URI = "http://software-dl.ti.com/dsps/dsps_public_sw/sdo_sb/targetcontent/gf
23SRC_URI[md5sum] = "0e651eaa92bb91760f0b40a17697a7dc" 24SRC_URI[md5sum] = "0e651eaa92bb91760f0b40a17697a7dc"
24SRC_URI[sha256sum] = "bfe764a8959556195545d6fff76f63a489642f345c105bbbc309a3f243c2dd0e" 25SRC_URI[sha256sum] = "bfe764a8959556195545d6fff76f63a489642f345c105bbbc309a3f243c2dd0e"
25 26
26S = "${WORKDIR}" 27S = "${WORKDIR}/Graphics_SDK_${SGXPV}"
27
diff --git a/recipes-ti/includes/ti-eula-unpack.inc b/recipes-ti/includes/ti-eula-unpack.inc
index 60f5558b..aee88f16 100644
--- a/recipes-ti/includes/ti-eula-unpack.inc
+++ b/recipes-ti/includes/ti-eula-unpack.inc
@@ -14,7 +14,7 @@ python do_unpack () {
14 bb.build.exec_func('ti_bin_do_unpack', d) 14 bb.build.exec_func('ti_bin_do_unpack', d)
15} 15}
16 16
17TI_BIN_UNPK_WDEXT += "" 17TI_BIN_UNPK_WDEXT ?= ""
18python ti_bin_do_unpack() { 18python ti_bin_do_unpack() {
19 19
20 import os 20 import os
@@ -60,7 +60,7 @@ python ti_bin_do_unpack() {
60 wdext = bb.data.getVar('TI_BIN_UNPK_WDEXT', localdata) 60 wdext = bb.data.getVar('TI_BIN_UNPK_WDEXT', localdata)
61 wdext = bb.data.expand(wdext, localdata) 61 wdext = bb.data.expand(wdext, localdata)
62 cmd = workdir+wdext 62 cmd = workdir+wdext
63 print >>f, cmd 63 f.write(cmd+'\n');
64 f.close() 64 f.close()
65 65
66 # Expand the tarball that was created if required 66 # Expand the tarball that was created if required