summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorMurali Karicheri <m-karicheri2@ti.com>2013-01-29 12:14:57 -0500
committerDenys Dmytriyenko <denys@ti.com>2013-01-29 13:25:34 -0500
commit64926476aa88cb7293adcd8f232e75f088934ad1 (patch)
treef0265d05221f0ead8fb25f327da12bc7fd810154
parentd35a191a9176981babf3587e15dfaa622560e4f1 (diff)
downloadmeta-ti-64926476aa88cb7293adcd8f232e75f088934ad1.tar.gz
keystone: update kernel and bootloaders recipes for mcsdk alpha7 release
Signed-off-by: Murali Karicheri <m-karicheri2@ti.com> Signed-off-by: Denys Dmytriyenko <denys@ti.com>
-rw-r--r--conf/machine/include/keystone.inc3
-rw-r--r--recipes-bsp/boot-monitor/boot-monitor_git.bb8
-rw-r--r--recipes-bsp/u-boot/u-boot_2013.01.bb4
-rw-r--r--recipes-kernel/linux/linux-keystone_3.6.6.bb2
4 files changed, 9 insertions, 8 deletions
diff --git a/conf/machine/include/keystone.inc b/conf/machine/include/keystone.inc
index df9318a0..b77bccdf 100644
--- a/conf/machine/include/keystone.inc
+++ b/conf/machine/include/keystone.inc
@@ -5,7 +5,7 @@ require conf/machine/include/tune-cortexa15.inc
5PREFERRED_PROVIDER_virtual/kernel = "linux-keystone" 5PREFERRED_PROVIDER_virtual/kernel = "linux-keystone"
6 6
7# Increase this everytime you change something in the kernel 7# Increase this everytime you change something in the kernel
8MACHINE_KERNEL_PR = "r4" 8MACHINE_KERNEL_PR = "r5"
9 9
10KERNEL_IMAGETYPE = "uImage" 10KERNEL_IMAGETYPE = "uImage"
11 11
@@ -13,3 +13,4 @@ UBOOT_ENTRYPOINT = "0x80008000"
13UBOOT_LOADADDRESS = "0x80008000" 13UBOOT_LOADADDRESS = "0x80008000"
14 14
15EXTRA_IMAGEDEPENDS += "u-boot" 15EXTRA_IMAGEDEPENDS += "u-boot"
16EXTRA_IMAGEDEPENDS += "boot-monitor"
diff --git a/recipes-bsp/boot-monitor/boot-monitor_git.bb b/recipes-bsp/boot-monitor/boot-monitor_git.bb
index dc4d71e7..c8a022a5 100644
--- a/recipes-bsp/boot-monitor/boot-monitor_git.bb
+++ b/recipes-bsp/boot-monitor/boot-monitor_git.bb
@@ -7,20 +7,20 @@ BOOT_MONITOR_BINARY ?= "skern.bin"
7BOOT_MONITOR_IMAGE ?= "skern-${MACHINE}.bin" 7BOOT_MONITOR_IMAGE ?= "skern-${MACHINE}.bin"
8BOOT_MONITOR_MAKE_TARGET ?= "all" 8BOOT_MONITOR_MAKE_TARGET ?= "all"
9 9
10LIC_FILES_CHKSUM = "file://COPYING;md5=b676661788f8c0f8cdeafd2a39467cae" 10LIC_FILES_CHKSUM = "file://COPYING;md5=25fe219a6febf6e5bb45beda1b2eb315"
11 11
12COMPATIBLE_MACHINE = "keystone-evm" 12COMPATIBLE_MACHINE = "keystone-evm"
13 13
14SRC_URI = "git://gtgit01.gt.design.ti.com/git/projects/boot-monitor.git;protocol=git;branch=${BRANCH}" 14SRC_URI = "git://arago-project.org/git/projects/boot-monitor.git;protocol=git;branch=${BRANCH}"
15 15
16PV = "1.0" 16PV = "1.0"
17PR = "r0+gitr${SRCPV}" 17PR = "r1+gitr${SRCPV}"
18 18
19BRANCH = "master" 19BRANCH = "master"
20 20
21S = "${WORKDIR}/git" 21S = "${WORKDIR}/git"
22 22
23SRCREV = "b8014b69e8c7e981e8bc3e067a9d990e2bb603ba" 23SRCREV = "DEV.MCSDK-03.00.00.07"
24 24
25do_compile () { 25do_compile () {
26 unset LDFLAGS 26 unset LDFLAGS
diff --git a/recipes-bsp/u-boot/u-boot_2013.01.bb b/recipes-bsp/u-boot/u-boot_2013.01.bb
index ee443b06..b9e6dafa 100644
--- a/recipes-bsp/u-boot/u-boot_2013.01.bb
+++ b/recipes-bsp/u-boot/u-boot_2013.01.bb
@@ -8,13 +8,13 @@ COMPATIBLE_MACHINE = "keystone"
8 8
9PACKAGE_ARCH = "${MACHINE_ARCH}" 9PACKAGE_ARCH = "${MACHINE_ARCH}"
10 10
11PR = "r1+gitr${SRCPV}" 11PR = "r2+gitr${SRCPV}"
12 12
13SRC_URI = "git://arago-project.org/git/projects/u-boot-keystone.git;protocol=git;branch=${BRANCH}" 13SRC_URI = "git://arago-project.org/git/projects/u-boot-keystone.git;protocol=git;branch=${BRANCH}"
14 14
15BRANCH = "master" 15BRANCH = "master"
16 16
17SRCREV = "DEV.MCSDK-03.00.00.06" 17SRCREV = "DEV.MCSDK-03.00.00.07"
18 18
19EXTRA_OEMAKE = 'CROSS_COMPILE=${TARGET_PREFIX} CC="${TARGET_PREFIX}gcc ${TOOLCHAIN_OPTIONS}"' 19EXTRA_OEMAKE = 'CROSS_COMPILE=${TARGET_PREFIX} CC="${TARGET_PREFIX}gcc ${TOOLCHAIN_OPTIONS}"'
20 20
diff --git a/recipes-kernel/linux/linux-keystone_3.6.6.bb b/recipes-kernel/linux/linux-keystone_3.6.6.bb
index 2aa83e6d..4dd5d15c 100644
--- a/recipes-kernel/linux/linux-keystone_3.6.6.bb
+++ b/recipes-kernel/linux/linux-keystone_3.6.6.bb
@@ -7,7 +7,7 @@ MACHINE_KERNEL_PR_append = "a"
7CORTEXA8FIXUP = "no" 7CORTEXA8FIXUP = "no"
8 8
9# The tree tends to rebase, use literal stable tags 9# The tree tends to rebase, use literal stable tags
10SRCREV = "DEV.MCSDK-03.00.00.06" 10SRCREV = "DEV.MCSDK-03.06.06.07"
11 11
12SRC_URI = "git://arago-project.org/git/projects/linux-keystone.git;protocol=git \ 12SRC_URI = "git://arago-project.org/git/projects/linux-keystone.git;protocol=git \
13 file://defconfig \ 13 file://defconfig \