summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorChase Maupin <Chase.Maupin@ti.com>2013-04-18 12:40:21 -0500
committerDenys Dmytriyenko <denys@ti.com>2013-04-18 15:43:25 -0400
commitf8178078427d17499e1d30a52d7fb896ca4dce27 (patch)
treebb26de034632cac74696e41123461039c535211e
parent2ad1fd65b8cfc8b183bcaa4d28f2064aa4fa2229 (diff)
downloadmeta-ti-f8178078427d17499e1d30a52d7fb896ca4dce27.tar.gz
linux-ti-staging: make cm3 firmware a run-time dependency
* Make the am33x-cm3 firmware a run-time dependency instead of build time since it is no longer required at build time. Signed-off-by: Chase Maupin <Chase.Maupin@ti.com> Signed-off-by: Denys Dmytriyenko <denys@ti.com>
-rw-r--r--recipes-kernel/linux/linux-ti-staging_3.8.bb16
1 files changed, 4 insertions, 12 deletions
diff --git a/recipes-kernel/linux/linux-ti-staging_3.8.bb b/recipes-kernel/linux/linux-ti-staging_3.8.bb
index 77d8e8ae..6cbc2df7 100644
--- a/recipes-kernel/linux/linux-ti-staging_3.8.bb
+++ b/recipes-kernel/linux/linux-ti-staging_3.8.bb
@@ -24,9 +24,9 @@ do_deploy_append() {
24require recipes-kernel/linux/linux-dtb.inc 24require recipes-kernel/linux/linux-dtb.inc
25require recipes-kernel/linux/setup-defconfig.inc 25require recipes-kernel/linux/setup-defconfig.inc
26 26
27# Stage the power management firmware before building the kernel 27# Add a run-time dependency for the PM firmware to be installed
28# for ti33x SOC_FAMILY devices 28# on the target file system.
29DEPENDS_ti33x += "am33x-cm3" 29RDEPENDS_ti33x += "am33x-cm3"
30 30
31# Default is to package all dts files for ti33x devices unless building 31# Default is to package all dts files for ti33x devices unless building
32# for the specific beaglebone machine. 32# for the specific beaglebone machine.
@@ -44,16 +44,8 @@ SRCREV = "881dfafeae47da3a8f5ff8c791753e4b4df8065b"
44PV = "3.8.5" 44PV = "3.8.5"
45 45
46# Append to the MACHINE_KERNEL_PR so that a new SRCREV will cause a rebuild 46# Append to the MACHINE_KERNEL_PR so that a new SRCREV will cause a rebuild
47MACHINE_KERNEL_PR_append = "d+gitr${SRCPV}" 47MACHINE_KERNEL_PR_append = "e+gitr${SRCPV}"
48 48
49SRC_URI = "git://git.ti.com/ti-linux-kernel/ti-linux-kernel.git;protocol=git;branch=${BRANCH} \ 49SRC_URI = "git://git.ti.com/ti-linux-kernel/ti-linux-kernel.git;protocol=git;branch=${BRANCH} \
50 file://defconfig \ 50 file://defconfig \
51 " 51 "
52
53# Copy the am33x-cm3 firmware if it is available for ti33x SOC_FAMILY devices
54do_compile_prepend_ti33x() {
55 if [ -e "${STAGING_DIR_HOST}/${base_libdir}/firmware/am335x-pm-firmware.bin" ]
56 then
57 cp "${STAGING_DIR_HOST}/${base_libdir}/firmware/am335x-pm-firmware.bin" "${S}/firmware"
58 fi
59}