summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorSiddharth Heroor <heroor@ti.com>2013-06-28 13:15:54 -0400
committerDenys Dmytriyenko <denys@ti.com>2013-06-28 13:15:54 -0400
commitef124402251d9d9eadb177784c6c0c1371adbc16 (patch)
tree57a6b42610d066d8fa3ada5f8fdd12c680ed31b6
parent1c09e95bef33b32921f9302ce088ad0cacdde944 (diff)
downloadmeta-ti-ef124402251d9d9eadb177784c6c0c1371adbc16.tar.gz
recipes-kernel: Add GLSDK specific kernel tree for omap-a15
* Machine compatible with only omap-a15 devices. * The TI Staging tree will not be used to maintain K3.8. Instead, this new tree is set up as a production tree. Pending features for 3.8 will be implemented on this tree. - Backported features from linux mainline - Backported bug-fixes from linux mainline and linux-stable. - Features implemented by the GLSDK team which maybe product specific. This is the tree on which GLSDK kernel releases will be made. * This recipe is based off the Core SDK 2013.04.02 released kernel recipe - recipes-kernel/linux/linux-ti-staging_3.8.bb Signed-off-by: Siddharth Heroor <heroor@ti.com> cc: Mrinmayee Hingolikar <mrinmayee@ti.com> Acked-by: Chase Maupin <chase.maupin@ti.com> Signed-off-by: Denys Dmytriyenko <denys@ti.com>
-rw-r--r--recipes-kernel/linux/linux-ti-glsdk/defconfig1
-rw-r--r--recipes-kernel/linux/linux-ti-glsdk_3.8.bb31
2 files changed, 32 insertions, 0 deletions
diff --git a/recipes-kernel/linux/linux-ti-glsdk/defconfig b/recipes-kernel/linux/linux-ti-glsdk/defconfig
new file mode 100644
index 00000000..926b35a5
--- /dev/null
+++ b/recipes-kernel/linux/linux-ti-glsdk/defconfig
@@ -0,0 +1 @@
use-kernel-config=omap2plus_defconfig
diff --git a/recipes-kernel/linux/linux-ti-glsdk_3.8.bb b/recipes-kernel/linux/linux-ti-glsdk_3.8.bb
new file mode 100644
index 00000000..27461887
--- /dev/null
+++ b/recipes-kernel/linux/linux-ti-glsdk_3.8.bb
@@ -0,0 +1,31 @@
1SECTION = "kernel"
2DESCRIPTION = "Linux kernel for TI devices supported by the GLSDK product"
3LICENSE = "GPLv2"
4LIC_FILES_CHKSUM = "file://COPYING;md5=d7810fab7487fb0aad327b76f1be7cd7"
5KERNEL_IMAGETYPE = "uImage"
6
7inherit kernel
8
9require recipes-kernel/linux/linux-dtb.inc
10require recipes-kernel/linux/setup-defconfig.inc
11
12KERNEL_DEVICETREE_omap5-evm = "arch/arm/boot/dts/omap5-sevm.dts arch/arm/boot/dts/omap5-uevm.dts"
13KERNEL_DEVICETREE_dra7xx-evm = "arch/arm/boot/dts/dra7-evm.dts"
14
15COMPATIBLE_MACHINE = "omap-a15"
16
17DEFAULT_PREFERENCE = "-1"
18
19S = "${WORKDIR}/git"
20
21BRANCH = "master"
22
23SRCREV = "4e8193eb3b7465d7f67cd8c7e6c2ed99dad1a483"
24PV = "3.8.13"
25
26# Append to the MACHINE_KERNEL_PR so that a new SRCREV will cause a rebuild
27MACHINE_KERNEL_PR_append = "a+gitr${SRCPV}"
28
29SRC_URI = "git://git.ti.com/ti-linux-kernel/ti-linux-3-8-y-kernel.git;protocol=git;branch=${BRANCH} \
30 file://defconfig \
31 "