summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorFranklin S. Cooper Jr <fcooper@ti.com>2013-06-27 10:57:35 -0500
committerDenys Dmytriyenko <denys@ti.com>2013-07-02 11:59:19 -0400
commitd78b2c21c41a5b8dfe8860900e4aa5e8e716de9c (patch)
tree4740f8b619b24b30362eb9b4dc507370e1993dcd
parentcc368658099d6a1b42df8b1f5bfb9ceb3c2c5066 (diff)
downloadmeta-ti-d78b2c21c41a5b8dfe8860900e4aa5e8e716de9c.tar.gz
linux-am335x-psp: Add 1 GHZ Support for BBB
Signed-off-by: Franklin S. Cooper Jr <fcooper@ti.com> Signed-off-by: Denys Dmytriyenko <denys@ti.com>
-rw-r--r--recipes-kernel/linux/linux-am335x-psp-3.2/0001-am335x-Re-enable-Turbo-and-Nitro-modes-for-Beaglebon.patch41
-rw-r--r--recipes-kernel/linux/linux-am335x-psp_3.2.bb6
2 files changed, 45 insertions, 2 deletions
diff --git a/recipes-kernel/linux/linux-am335x-psp-3.2/0001-am335x-Re-enable-Turbo-and-Nitro-modes-for-Beaglebon.patch b/recipes-kernel/linux/linux-am335x-psp-3.2/0001-am335x-Re-enable-Turbo-and-Nitro-modes-for-Beaglebon.patch
new file mode 100644
index 00000000..17a87af9
--- /dev/null
+++ b/recipes-kernel/linux/linux-am335x-psp-3.2/0001-am335x-Re-enable-Turbo-and-Nitro-modes-for-Beaglebon.patch
@@ -0,0 +1,41 @@
1From ec0ec41418ec1193e4352f1983ab29173f10f855 Mon Sep 17 00:00:00 2001
2From: Steve Kipisz <s-kipisz2@ti.com>
3Date: Wed, 5 Jun 2013 10:10:44 -0500
4Subject: [PATCH] am335x:Re-enable Turbo and Nitro modes for Beaglebone Black
5 The Beaglebone Black boards use a speed binned PG2.0 AM335x
6 that operate up to 1GHz so re-enable those modes for
7 Beaglebone Black.
8
9Signed-off-by: Steve Kipisz <s-kipisz2@ti.com>
10---
11 arch/arm/mach-omap2/board-am335xevm.c | 14 ++++++++++++++
12 1 file changed, 14 insertions(+)
13
14diff --git a/arch/arm/mach-omap2/board-am335xevm.c b/arch/arm/mach-omap2/board-am335xevm.c
15index bac415c..47e5a9d 100644
16--- a/arch/arm/mach-omap2/board-am335xevm.c
17+++ b/arch/arm/mach-omap2/board-am335xevm.c
18@@ -2529,6 +2529,20 @@ static void am335x_evm_setup(struct memory_accessor *mem_acc, void *context)
19
20 am335x_opp_update();
21
22+ /*
23+ * For now, Beaglebone Black uses PG 2.0 that are speed binned and operate
24+ * up to 1GHz. So re-enable Turbo and Nitro modes,
25+ */
26+ if (!strncmp("A335BNLT", config.name, 8)) {
27+ struct device *mpu_dev;
28+
29+ mpu_dev = omap_device_get_by_hwmod_name("mpu");
30+ opp_enable(mpu_dev,
31+ AM33XX_ES2_0_OPPTURBO_FREQ);
32+ opp_enable(mpu_dev,
33+ AM33XX_ES2_0_OPPNITRO_FREQ);
34+ }
35+
36 /* SmartReflex also requires board information. */
37 am33xx_sr_init();
38
39--
401.7.9.5
41
diff --git a/recipes-kernel/linux/linux-am335x-psp_3.2.bb b/recipes-kernel/linux/linux-am335x-psp_3.2.bb
index 257c6dea..eaf788f0 100644
--- a/recipes-kernel/linux/linux-am335x-psp_3.2.bb
+++ b/recipes-kernel/linux/linux-am335x-psp_3.2.bb
@@ -15,7 +15,7 @@ DEPENDS += "am33x-cm3"
15KERNEL_IMAGETYPE = "uImage" 15KERNEL_IMAGETYPE = "uImage"
16 16
17# The main PR is now using MACHINE_KERNEL_PR, for ti33x see conf/machine/include/ti33x.inc 17# The main PR is now using MACHINE_KERNEL_PR, for ti33x see conf/machine/include/ti33x.inc
18MACHINE_KERNEL_PR_append = "g+gitr${SRCPV}" 18MACHINE_KERNEL_PR_append = "h+gitr${SRCPV}"
19 19
20BRANCH = "v3.2-staging" 20BRANCH = "v3.2-staging"
21 21
@@ -88,7 +88,9 @@ PATCHES += "file://0001-am335x-enable-pullup-on-the-WLAN-enable-pin-fo.patch"
88PATCHES += "file://0001-ARM-OMAP2-AM335x-Update-SPI-flash-layout.patch" 88PATCHES += "file://0001-ARM-OMAP2-AM335x-Update-SPI-flash-layout.patch"
89 89
90# Add support for Beaglebone Black 90# Add support for Beaglebone Black
91PATCHES += "file://0001-am335x-Add-minimal-support-for-Beaglebone-Black.patch" 91PATCHES += "file://0001-am335x-Add-minimal-support-for-Beaglebone-Black.patch \
92 file://0001-am335x-Re-enable-Turbo-and-Nitro-modes-for-Beaglebon.patch \
93"
92 94
93# Copy the am33x-cm3 firmware if it is available 95# Copy the am33x-cm3 firmware if it is available
94do_configure_append() { 96do_configure_append() {