summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorFranklin S. Cooper Jr <fcooper@ti.com>2013-04-22 17:31:47 -0500
committerDenys Dmytriyenko <denys@ti.com>2013-04-22 21:36:37 -0400
commit8f5baa2153ee5c1123e54feb0e2077089bd121ae (patch)
treef3fabceb752c076e68e1a601aa2dd6eeb0e49028
parent3b2d0910db367916fdcd5e1fcf5fb4673edbab6d (diff)
downloadmeta-ti-8f5baa2153ee5c1123e54feb0e2077089bd121ae.tar.gz
u-boot: Add am3517 u-boot recipe
* Add correct u-boot recipe for am3517. Signed-off-by: Franklin S. Cooper Jr <fcooper@ti.com> Signed-off-by: Denys Dmytriyenko <denys@ti.com>
-rw-r--r--conf/machine/am3517-evm.conf5
-rw-r--r--recipes-bsp/u-boot/u-boot-am3517_2011.09.bb19
2 files changed, 21 insertions, 3 deletions
diff --git a/conf/machine/am3517-evm.conf b/conf/machine/am3517-evm.conf
index 097e7978..b9b6d17b 100644
--- a/conf/machine/am3517-evm.conf
+++ b/conf/machine/am3517-evm.conf
@@ -17,9 +17,8 @@ USE_VT = "2"
17 17
18PREFERRED_PROVIDER_virtual/kernel = "linux-omap-psp" 18PREFERRED_PROVIDER_virtual/kernel = "linux-omap-psp"
19 19
20# Support for am3517 is in the same tree as am33x 20PREFERRED_PROVIDER_virtual/bootloader = "u-boot-am3517"
21PREFERRED_PROVIDER_virtual/bootloader = "u-boot-am33x" 21PREFERRED_PROVIDER_u-boot = "u-boot-am3517"
22PREFERRED_PROVIDER_u-boot = "u-boot-am33x"
23 22
24UBOOT_MACHINE = "am3517_evm_config" 23UBOOT_MACHINE = "am3517_evm_config"
25XLOAD_MACHINE = "am3517evm_config" 24XLOAD_MACHINE = "am3517evm_config"
diff --git a/recipes-bsp/u-boot/u-boot-am3517_2011.09.bb b/recipes-bsp/u-boot/u-boot-am3517_2011.09.bb
new file mode 100644
index 00000000..6321406d
--- /dev/null
+++ b/recipes-bsp/u-boot/u-boot-am3517_2011.09.bb
@@ -0,0 +1,19 @@
1require u-boot-ti.inc
2
3DESCRIPTION = "u-boot bootloader for ARM MPU devices"
4
5COMPATIBLE_MACHINE = "omap3"
6
7DEFAULT_PREFERENCE = "-1"
8
9PR = "r0+gitr${SRCPV}"
10
11SRC_URI = "git://arago-project.org/git/projects/u-boot-am33x.git;protocol=git;branch=${BRANCH}"
12
13BRANCH = "AM335XPSP_04.06.00.08"
14
15# Lock to the commit corresponding to tag "v2011.09_AM335xPSP_04.06.00.08"
16SRCREV = "1e4626f0d5f3bb04ec974e76a5d9029875269d31"
17
18# Set the name of the SPL that will built so that it is also packaged with u-boot.
19SPL_BINARY = "MLO"