summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorDenys Dmytriyenko <denys@ti.com>2013-06-04 23:15:41 -0400
committerDenys Dmytriyenko <denys@ti.com>2013-06-05 11:54:36 -0400
commit569af06fd2d930ee397f3ae38f5f41fd7eabf8ea (patch)
tree8904ae7a6d713dd6f6404698f5bc08e698f2bf38
parentc49e7d4275322b43f15989b3eb15e4b21e983704 (diff)
downloadmeta-ti-569af06fd2d930ee397f3ae38f5f41fd7eabf8ea.tar.gz
u-boot-dra7xx: add latest u-boot from the integration branch
While the code is being pulled from ti-u-boot integration tree, J6/DRA7xx bring up is being done from a separate branch that does not include all the commits made for am335x. Hence, until those branches are merged with the mainline and unified in a single recipe, a separate recipe just for DRA7xx makes more sense. This recipe should eventually go away and unified under u-boot-ti-staging one. Signed-off-by: Denys Dmytriyenko <denys@ti.com> Acked-by: Chase Maupin <chase.maupin@ti.com>
-rw-r--r--conf/machine/dra7xx-evm.conf7
-rw-r--r--recipes-bsp/u-boot/u-boot-dra7xx_2013.04.bb16
2 files changed, 21 insertions, 2 deletions
diff --git a/conf/machine/dra7xx-evm.conf b/conf/machine/dra7xx-evm.conf
index d968d3b3..5897a5fe 100644
--- a/conf/machine/dra7xx-evm.conf
+++ b/conf/machine/dra7xx-evm.conf
@@ -8,6 +8,11 @@ IMAGE_FSTYPES += "ubi tar.gz"
8 8
9SERIAL_CONSOLE = "115200 ttyO0" 9SERIAL_CONSOLE = "115200 ttyO0"
10 10
11PREFERRED_PROVIDER_virtual/bootloader = "u-boot-dra7xx"
12PREFERRED_PROVIDER_u-boot = "u-boot-dra7xx"
13
14UBOOT_MACHINE = "dra7xx_evm_config"
15
11# UBI information. Note that this is board and kernel specific. Changes 16# UBI information. Note that this is board and kernel specific. Changes
12# in your kernel port may require changes in these variables. For more 17# in your kernel port may require changes in these variables. For more
13# details about this board please see 18# details about this board please see
@@ -29,8 +34,6 @@ MKUBIFS_ARGS = "-F -m 2048 -e 126976 -c 3836"
29# UBI: VID header offset: 2048 (aligned 2048) 34# UBI: VID header offset: 2048 (aligned 2048)
30UBINIZE_ARGS = "-m 2048 -p 128KiB -s 512 -O 2048" 35UBINIZE_ARGS = "-m 2048 -p 128KiB -s 512 -O 2048"
31 36
32UBOOT_MACHINE = "dra7xx_evm_config"
33
34# Currently removing the sgx machine feature because there is no SGX package 37# Currently removing the sgx machine feature because there is no SGX package
35# available for omap5 38# available for omap5
36MACHINE_FEATURES = "kernel26 apm usbgadget usbhost vfat ext2 screen touchscreen" 39MACHINE_FEATURES = "kernel26 apm usbgadget usbhost vfat ext2 screen touchscreen"
diff --git a/recipes-bsp/u-boot/u-boot-dra7xx_2013.04.bb b/recipes-bsp/u-boot/u-boot-dra7xx_2013.04.bb
new file mode 100644
index 00000000..eb3fc05a
--- /dev/null
+++ b/recipes-bsp/u-boot/u-boot-dra7xx_2013.04.bb
@@ -0,0 +1,16 @@
1require u-boot-ti.inc
2
3DESCRIPTION = "u-boot bootloader for TI devices"
4
5COMPATIBLE_MACHINE = "dra7xx-evm"
6
7PR = "r0+gitr${SRCPV}"
8
9SRC_URI = "git://git.ti.com/ti-u-boot/ti-u-boot.git;protocol=git;branch=${BRANCH}"
10
11BRANCH ?= "ti-u-boot-2013.04+"
12
13# This commit corresponds to ti2013.04.02 release tag
14SRCREV = "e2315adf674b60132f0c5c8fe6eac5d109b81688"
15
16SPL_BINARY = "MLO"