summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorFranklin S. Cooper Jr <fcooper@ti.com>2013-06-27 10:57:31 -0500
committerDenys Dmytriyenko <denys@ti.com>2013-07-02 11:59:19 -0400
commit29719b15eededd6a3f9b985d1fa2304d3aa9de77 (patch)
tree27327adcb29e0aa87d96190c5c16ef91d388f0e3
parent68c58484abe74377d905dc4407fbe286e2866a37 (diff)
downloadmeta-ti-29719b15eededd6a3f9b985d1fa2304d3aa9de77.tar.gz
linux-am335x-psp: Enable USB with DMA by default
* Patches have been added to fix some USB with DMA. * Enable support for this by default by removing the patch that disabled it. Signed-off-by: Franklin S. Cooper Jr <fcooper@ti.com> Signed-off-by: Denys Dmytriyenko <denys@ti.com>
-rw-r--r--recipes-kernel/linux/linux-am335x-psp-3.2/0001-am335x_evm_defconfig-turn-off-MUSB-DMA.patch35
-rw-r--r--recipes-kernel/linux/linux-am335x-psp_3.2.bb3
2 files changed, 1 insertions, 37 deletions
diff --git a/recipes-kernel/linux/linux-am335x-psp-3.2/0001-am335x_evm_defconfig-turn-off-MUSB-DMA.patch b/recipes-kernel/linux/linux-am335x-psp-3.2/0001-am335x_evm_defconfig-turn-off-MUSB-DMA.patch
deleted file mode 100644
index 6a32c2c3..00000000
--- a/recipes-kernel/linux/linux-am335x-psp-3.2/0001-am335x_evm_defconfig-turn-off-MUSB-DMA.patch
+++ /dev/null
@@ -1,35 +0,0 @@
1From 95eca5a896c96d0af7188c97825a3b3ef5313ed3 Mon Sep 17 00:00:00 2001
2From: Chase Maupin <Chase.Maupin@ti.com>
3Date: Thu, 2 Feb 2012 16:38:51 -0600
4Subject: [PATCH] am335x_evm_defconfig: turn off MUSB DMA
5
6* Turn off the MUSB DMA in the am335x_evm_defconfig. This way
7 we can pull the default defconfig without enabling the
8 faulty USB DMA.
9
10Signed-off-by: Chase Maupin <Chase.Maupin@ti.com>
11---
12 arch/arm/configs/am335x_evm_defconfig | 6 +++---
13 1 files changed, 3 insertions(+), 3 deletions(-)
14
15diff --git a/arch/arm/configs/am335x_evm_defconfig b/arch/arm/configs/am335x_evm_defconfig
16index d105c61..121dc7f 100644
17--- a/arch/arm/configs/am335x_evm_defconfig
18+++ b/arch/arm/configs/am335x_evm_defconfig
19@@ -1982,11 +1982,11 @@ CONFIG_USB_MUSB_TI81XX_GLUE=y
20 CONFIG_USB_MUSB_TI81XX=y
21 # CONFIG_USB_MUSB_BLACKFIN is not set
22 # CONFIG_USB_MUSB_UX500 is not set
23-CONFIG_USB_TI_CPPI41_DMA_HW=y
24-# CONFIG_MUSB_PIO_ONLY is not set
25+# CONFIG_USB_TI_CPPI41_DMA_HW is not set
26+CONFIG_MUSB_PIO_ONLY=y
27 # CONFIG_USB_INVENTRA_DMA is not set
28 # CONFIG_USB_TI_CPPI_DMA is not set
29-CONFIG_USB_TI_CPPI41_DMA=y
30+# CONFIG_USB_TI_CPPI41_DMA is not set
31 # CONFIG_USB_TUSB_OMAP_DMA is not set
32 # CONFIG_USB_UX500_DMA is not set
33 # CONFIG_USB_RENESAS_USBHS is not set
34--
351.7.0.4
diff --git a/recipes-kernel/linux/linux-am335x-psp_3.2.bb b/recipes-kernel/linux/linux-am335x-psp_3.2.bb
index 00c4b106..7fd69353 100644
--- a/recipes-kernel/linux/linux-am335x-psp_3.2.bb
+++ b/recipes-kernel/linux/linux-am335x-psp_3.2.bb
@@ -15,7 +15,7 @@ DEPENDS += "am33x-cm3"
15KERNEL_IMAGETYPE = "uImage" 15KERNEL_IMAGETYPE = "uImage"
16 16
17# The main PR is now using MACHINE_KERNEL_PR, for ti33x see conf/machine/include/ti33x.inc 17# The main PR is now using MACHINE_KERNEL_PR, for ti33x see conf/machine/include/ti33x.inc
18MACHINE_KERNEL_PR_append = "d+gitr${SRCPV}" 18MACHINE_KERNEL_PR_append = "e+gitr${SRCPV}"
19 19
20BRANCH = "v3.2-staging" 20BRANCH = "v3.2-staging"
21 21
@@ -34,7 +34,6 @@ KERNEL_PATCHES = "${PATCHES}"
34# Add a set of patches that enabled features, fixed bugs or disabled buggy features 34# Add a set of patches that enabled features, fixed bugs or disabled buggy features
35# that weren't part of the official PSP release 35# that weren't part of the official PSP release
36PATCHES = "file://0001-musb-update-PIO-mode-help-information-in-Kconfig.patch \ 36PATCHES = "file://0001-musb-update-PIO-mode-help-information-in-Kconfig.patch \
37 file://0001-am335x_evm_defconfig-turn-off-MUSB-DMA.patch \
38 file://0001-mach-omap2-pm33xx-Disable-VT-switch.patch" 37 file://0001-mach-omap2-pm33xx-Disable-VT-switch.patch"
39 38
40# Add Cryptography support early driver patches while working to get the driver 39# Add Cryptography support early driver patches while working to get the driver