summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorFranklin S. Cooper Jr <fcooper@ti.com>2013-05-06 23:26:03 -0500
committerDenys Dmytriyenko <denys@ti.com>2013-05-07 11:44:25 -0400
commit2091fb4ea2d570eb1787c3d3f03882edba4952f0 (patch)
tree6eae9b0c90b0385ad4e67a43ee7c103099ac954e
parent03397a66d819c1fab116e92219fc442c55cabbd6 (diff)
downloadmeta-ti-2091fb4ea2d570eb1787c3d3f03882edba4952f0.tar.gz
am33x-cm3: Split init script into its own package
* 3.8+ kernels use an init script to load the cm3 firmware. * 3.2 kernel require the cm3 firmware during compile time therefore no init script is needed. * Separate the init script from the main package and place it in its own package. Signed-off-by: Denys Dmytriyenko <denys@ti.com>
-rw-r--r--recipes-bsp/ti/am33x-cm3_git.bb9
-rw-r--r--recipes-kernel/linux/linux-ti-staging_3.8.bb4
2 files changed, 10 insertions, 3 deletions
diff --git a/recipes-bsp/ti/am33x-cm3_git.bb b/recipes-bsp/ti/am33x-cm3_git.bb
index 4829b78c..3549fcdb 100644
--- a/recipes-bsp/ti/am33x-cm3_git.bb
+++ b/recipes-bsp/ti/am33x-cm3_git.bb
@@ -4,7 +4,7 @@ LICENSE = "TI-BSD"
4LIC_FILES_CHKSUM = "file://License.txt;md5=858099c817e47ea63559fc6b67ae8d91" 4LIC_FILES_CHKSUM = "file://License.txt;md5=858099c817e47ea63559fc6b67ae8d91"
5 5
6PV = "04.06.00.10" 6PV = "04.06.00.10"
7PR = "r2" 7PR = "r3"
8 8
9# SRCREV corresponds to tag "AM335xPSP_04.06.00.10-rc1" 9# SRCREV corresponds to tag "AM335xPSP_04.06.00.10-rc1"
10SRCREV = "27ca4643e422245a95723de1df0247a00eada45b" 10SRCREV = "27ca4643e422245a95723de1df0247a00eada45b"
@@ -15,6 +15,10 @@ INITSCRIPT_PARAMS = "defaults 96"
15 15
16inherit update-rc.d 16inherit update-rc.d
17 17
18UPDATERCPN = "${PN}-initscript"
19
20RDEPENDS_${PN}-initscript = "am33x-cm3"
21
18SRC_URI = "git://arago-project.org/git/projects/am33x-cm3.git;protocol=git;branch=${BRANCH} \ 22SRC_URI = "git://arago-project.org/git/projects/am33x-cm3.git;protocol=git;branch=${BRANCH} \
19 file://init-am33x-cm3 \ 23 file://init-am33x-cm3 \
20 " 24 "
@@ -34,5 +38,8 @@ do_install() {
34 install -m 0755 ${WORKDIR}/init-am33x-cm3 ${D}${sysconfdir}/init.d/${INITSCRIPT_NAME} 38 install -m 0755 ${WORKDIR}/init-am33x-cm3 ${D}${sysconfdir}/init.d/${INITSCRIPT_NAME}
35} 39}
36 40
41PACKAGES =+ "${PN}-initscript"
42
37FILES_${PN} += "${base_libdir}/firmware" 43FILES_${PN} += "${base_libdir}/firmware"
38 44
45FILES_${PN}-initscript = "${sysconfdir}/*"
diff --git a/recipes-kernel/linux/linux-ti-staging_3.8.bb b/recipes-kernel/linux/linux-ti-staging_3.8.bb
index 6e64fc5b..4b93932e 100644
--- a/recipes-kernel/linux/linux-ti-staging_3.8.bb
+++ b/recipes-kernel/linux/linux-ti-staging_3.8.bb
@@ -11,7 +11,7 @@ require recipes-kernel/linux/setup-defconfig.inc
11 11
12# Add a run-time dependency for the PM firmware to be installed 12# Add a run-time dependency for the PM firmware to be installed
13# on the target file system. 13# on the target file system.
14RDEPENDS_kernel-base_ti33x += "am33x-cm3" 14RDEPENDS_kernel-base_ti33x += "am33x-cm3 am33x-cm3-initscript"
15 15
16# Default is to package all dts files for ti33x devices unless building 16# Default is to package all dts files for ti33x devices unless building
17# for the specific beaglebone machine. 17# for the specific beaglebone machine.
@@ -30,7 +30,7 @@ SRCREV = "23e7f725a6af4ca44660c06bc3569f6ce705d1d0"
30PV = "3.8.8" 30PV = "3.8.8"
31 31
32# Append to the MACHINE_KERNEL_PR so that a new SRCREV will cause a rebuild 32# Append to the MACHINE_KERNEL_PR so that a new SRCREV will cause a rebuild
33MACHINE_KERNEL_PR_append = "c+gitr${SRCPV}" 33MACHINE_KERNEL_PR_append = "d+gitr${SRCPV}"
34 34
35SRC_URI = "git://git.ti.com/ti-linux-kernel/ti-linux-kernel.git;protocol=git;branch=${BRANCH} \ 35SRC_URI = "git://git.ti.com/ti-linux-kernel/ti-linux-kernel.git;protocol=git;branch=${BRANCH} \
36 file://defconfig \ 36 file://defconfig \