summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorDenys Dmytriyenko <denys@ti.com>2013-06-24 20:14:37 -0400
committerDenys Dmytriyenko <denys@ti.com>2013-06-24 21:50:46 -0400
commit1c09e95bef33b32921f9302ce088ad0cacdde944 (patch)
tree95c6d7b31f4953a9b5060c7ffbd6985b99760e8c
parent9826121536555c2d3a96232b0b40b1d66acfc7cf (diff)
downloadmeta-ti-1c09e95bef33b32921f9302ce088ad0cacdde944.tar.gz
u-boot: add support for SPL UART variant
This is an adaptation of a patch by Carlos Hernandez Signed-off-by: Denys Dmytriyenko <denys@ti.com>
-rw-r--r--recipes-bsp/u-boot/u-boot-ti-staging_2013.01.01.bb3
-rw-r--r--recipes-bsp/u-boot/u-boot-ti.inc24
2 files changed, 26 insertions, 1 deletions
diff --git a/recipes-bsp/u-boot/u-boot-ti-staging_2013.01.01.bb b/recipes-bsp/u-boot/u-boot-ti-staging_2013.01.01.bb
index 5fbd0c97..ea72e4df 100644
--- a/recipes-bsp/u-boot/u-boot-ti-staging_2013.01.01.bb
+++ b/recipes-bsp/u-boot/u-boot-ti-staging_2013.01.01.bb
@@ -2,7 +2,7 @@ require u-boot-ti.inc
2 2
3DESCRIPTION = "u-boot bootloader for TI devices" 3DESCRIPTION = "u-boot bootloader for TI devices"
4 4
5PR = "r4+gitr${SRCPV}" 5PR = "r5+gitr${SRCPV}"
6 6
7SRC_URI = "git://git.ti.com/ti-u-boot/ti-u-boot.git;protocol=git;branch=${BRANCH}" 7SRC_URI = "git://git.ti.com/ti-u-boot/ti-u-boot.git;protocol=git;branch=${BRANCH}"
8 8
@@ -12,3 +12,4 @@ BRANCH ?= "ti-u-boot-2013.01.01"
12SRCREV = "7552b4c906b0a50fbc5225dc43ed0192618e9d5d" 12SRCREV = "7552b4c906b0a50fbc5225dc43ed0192618e9d5d"
13 13
14SPL_BINARY = "MLO" 14SPL_BINARY = "MLO"
15SPL_UART_BINARY = "u-boot-spl.bin"
diff --git a/recipes-bsp/u-boot/u-boot-ti.inc b/recipes-bsp/u-boot/u-boot-ti.inc
index 968f3e41..c024e963 100644
--- a/recipes-bsp/u-boot/u-boot-ti.inc
+++ b/recipes-bsp/u-boot/u-boot-ti.inc
@@ -15,3 +15,27 @@ PKG_${PN}-dbg = "u-boot-dbg"
15S = "${WORKDIR}/git" 15S = "${WORKDIR}/git"
16 16
17UBOOT_SUFFIX = "img" 17UBOOT_SUFFIX = "img"
18
19# SPL (Second Program Loader) to be loaded over UART
20SPL_UART_BINARY ?= ""
21SPL_UART_IMAGE ?= "${SPL_UART_BINARY}-${MACHINE}-${PV}-${PR}"
22SPL_UART_SYMLINK ?= "${SPL_UART_BINARY}-${MACHINE}"
23
24do_install_append () {
25 if [ "x${SPL_UART_BINARY}" != "x" ]
26 then
27 install ${S}/spl/${SPL_UART_BINARY} ${D}/boot/${SPL_UART_IMAGE}
28 ln -sf ${SPL_UART_IMAGE} ${D}/boot/${SPL_UART_BINARY}
29 fi
30}
31
32do_deploy_append () {
33 cd ${DEPLOYDIR}
34 if [ "x${SPL_UART_BINARY}" != "x" ]
35 then
36 install ${S}/spl/${SPL_UART_BINARY} ${DEPLOYDIR}/${SPL_UART_IMAGE}
37 rm -f ${DEPLOYDIR}/${SPL_UART_BINARY} ${DEPLOYDIR}/${SPL_UART_SYMLINK}
38 ln -sf ${SPL_UART_IMAGE} ${DEPLOYDIR}/${SPL_UART_BINARY}
39 ln -sf ${SPL_UART_IMAGE} ${DEPLOYDIR}/${SPL_UART_SYMLINK}
40 fi
41}