summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorDenys Dmytriyenko <denys@ti.com>2015-07-09 01:52:36 +0000
committerDenys Dmytriyenko <denys@ti.com>2015-07-08 18:00:14 -0400
commitee2d74c3e377b984bfcc3ef94c24fb26f4b6639a (patch)
tree940f4221783ef6b2f2c6ddcd8da4c6c2f9357c16
parent796837592ca82f1f18a7167004fc130be65e903f (diff)
downloadmeta-ti-ee2d74c3e377b984bfcc3ef94c24fb26f4b6639a.tar.gz
linux-ti-staging: add version 4.1.1
Signed-off-by: Denys Dmytriyenko <denys@ti.com>
-rw-r--r--recipes-kernel/linux/linux-ti-staging-4.1/configs/systest1
-rw-r--r--recipes-kernel/linux/linux-ti-staging-4.1/defconfig1
-rw-r--r--recipes-kernel/linux/linux-ti-staging_4.1.bb67
3 files changed, 69 insertions, 0 deletions
diff --git a/recipes-kernel/linux/linux-ti-staging-4.1/configs/systest b/recipes-kernel/linux/linux-ti-staging-4.1/configs/systest
new file mode 100644
index 00000000..cfe4f991
--- /dev/null
+++ b/recipes-kernel/linux/linux-ti-staging-4.1/configs/systest
@@ -0,0 +1 @@
use-combined-config=ti_config_fragments/system_test_defconfig_fragment
diff --git a/recipes-kernel/linux/linux-ti-staging-4.1/defconfig b/recipes-kernel/linux/linux-ti-staging-4.1/defconfig
new file mode 100644
index 00000000..990e7f79
--- /dev/null
+++ b/recipes-kernel/linux/linux-ti-staging-4.1/defconfig
@@ -0,0 +1 @@
use-combined-config=ti_config_fragments/defconfig_fragment
diff --git a/recipes-kernel/linux/linux-ti-staging_4.1.bb b/recipes-kernel/linux/linux-ti-staging_4.1.bb
new file mode 100644
index 00000000..c8835c25
--- /dev/null
+++ b/recipes-kernel/linux/linux-ti-staging_4.1.bb
@@ -0,0 +1,67 @@
1SECTION = "kernel"
2DESCRIPTION = "Linux kernel for TI devices"
3LICENSE = "GPLv2"
4LIC_FILES_CHKSUM = "file://COPYING;md5=d7810fab7487fb0aad327b76f1be7cd7"
5
6inherit kernel
7
8require recipes-kernel/linux/linux-dtb.inc
9require recipes-kernel/linux/setup-defconfig.inc
10require recipes-kernel/linux/multi-kernel.inc
11require recipes-kernel/linux/cmem.inc
12
13# Look in the generic major.minor directory for files
14FILESEXTRAPATHS_prepend := "${THISDIR}/${PN}-4.1:"
15
16# Pull in the devicetree files into the rootfs
17RDEPENDS_kernel-base += "kernel-devicetree"
18
19# Add a run-time dependency for the PM firmware to be installed
20# on the target file system.
21RDEPENDS_kernel-base_append_ti33x = " am33x-cm3"
22RDEPENDS_kernel-base_append_ti43x = " am33x-cm3"
23
24# Add a run-time dependency for the VPE VPDMA firmware to be installed
25# on the target file system.
26RDEPENDS_kernel-base_append_dra7xx = " vpdma-fw"
27
28# Default is to package all dtb files for ti33x devices unless building
29# for the specific beaglebone machine.
30KERNEL_DEVICETREE_ti33x = "am335x-evm.dtb am335x-evmsk.dtb am335x-bone.dtb am335x-boneblack.dtb"
31KERNEL_DEVICETREE_ti43x = "am43x-epos-evm.dtb am43x-epos-evm-hdmi.dtb am437x-gp-evm.dtb am437x-gp-evm-hdmi.dtb am437x-sk-evm.dtb"
32KERNEL_DEVICETREE_beaglebone = "am335x-bone.dtb am335x-boneblack.dtb"
33KERNEL_DEVICETREE_omap5-evm = "omap5-uevm.dtb"
34KERNEL_DEVICETREE_dra7xx-evm = "dra7-evm.dtb dra7-evm-lcd10.dtb dra72-evm.dtb dra72-evm-lcd10.dtb"
35KERNEL_DEVICETREE_am57xx-evm = "am57xx-beagle-x15.dtb am57xx-evm.dtb"
36KERNEL_DEVICETREE_omap3 = "omap3-beagle.dtb omap3-beagle-xm.dtb omap3-evm.dtb omap3-evm-37xx.dtb am3517-evm.dtb"
37KERNEL_DEVICETREE_am3517-evm = "am3517-evm.dtb"
38KERNEL_DEVICETREE_am37x-evm = "omap3-evm-37xx.dtb"
39KERNEL_DEVICETREE_beagleboard = "omap3-beagle.dtb omap3-beagle-xm.dtb"
40
41KERNEL_EXTRA_ARGS += "LOADADDR=${UBOOT_ENTRYPOINT}"
42
43COMPATIBLE_MACHINE = "ti33x|ti43x|omap-a15|omap3|omap4"
44
45S = "${WORKDIR}/git"
46
47BRANCH = "ti-linux-4.1.y"
48
49SRCREV = "31ae2ddea8e0ef24a8d952d39f47b82c05c51a45"
50PV = "4.1.1+git${SRCPV}"
51
52# Append to the MACHINE_KERNEL_PR so that a new SRCREV will cause a rebuild
53MACHINE_KERNEL_PR_append = "a"
54PR = "${MACHINE_KERNEL_PR}"
55
56KERNEL_CONFIG_DIR = "${S}/ti_config_fragments"
57
58#KERNEL_CONFIG_FRAGMENTS_append_ti33x = " ${KERNEL_CONFIG_DIR}/am33xx_only.cfg"
59#KERNEL_CONFIG_FRAGMENTS_append_ti43x = " ${KERNEL_CONFIG_DIR}/am43xx_only.cfg"
60
61MULTI_CONFIG_BASE_SUFFIX = ""
62
63KERNEL_GIT_URI = "git://git.ti.com/ti-linux-kernel/ti-linux-kernel.git"
64KERNEL_GIT_PROTOCOL = "git"
65SRC_URI += "${KERNEL_GIT_URI};protocol=${KERNEL_GIT_PROTOCOL};branch=${BRANCH} \
66 file://defconfig \
67 "