summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorJacob Stiffler <j-stiffler@ti.com>2015-07-01 21:19:54 +0000
committerDenys Dmytriyenko <denys@ti.com>2015-07-02 19:11:58 -0400
commitb28b085864b8da9af09b3d8e55e591f475ab3415 (patch)
tree49502eec155d876f147a8cbc19d0d28dbdb2e70f
parent12b8d3c9ec9344135ddb461809ce6695f321a78c (diff)
downloadmeta-ti-b28b085864b8da9af09b3d8e55e591f475ab3415.tar.gz
ti-softhsmv2: Stop recipe from using headers from host build machine.
* Without the "--with-zlib" configure option, the zlib header will be obtained from the build machines "/usr/include" directory if the header exists there. * From ${S}/m4/acx_zlib.m4: AC_DEFUN([ACX_ZLIB],[ AC_ARG_WITH(zlib, AC_HELP_STRING([--with-zlib=PATH],[Specify prefix of path of zlib]), [ ZLIB_PATH="$withval" ], [ ZLIB_PATH="/usr" ]) AC_MSG_CHECKING(what are the zlib includes) ZLIB_INCLUDES="-I$ZLIB_PATH/include" ... * Therefore add configure option to point to staging sysroot for zlib header and add dependency on zlib. Signed-off-by: Jacob Stiffler <j-stiffler@ti.com> Signed-off-by: Denys Dmytriyenko <denys@ti.com>
-rw-r--r--recipes-ti/ti-softhsmv2/ti-softhsmv2_git.bb5
1 files changed, 4 insertions, 1 deletions
diff --git a/recipes-ti/ti-softhsmv2/ti-softhsmv2_git.bb b/recipes-ti/ti-softhsmv2/ti-softhsmv2_git.bb
index 518508c3..329fbaa6 100644
--- a/recipes-ti/ti-softhsmv2/ti-softhsmv2_git.bb
+++ b/recipes-ti/ti-softhsmv2/ti-softhsmv2_git.bb
@@ -7,7 +7,7 @@ mntdir = "/mnt"
7 7
8inherit autotools pkgconfig 8inherit autotools pkgconfig
9 9
10DEPENDS = "openssl libdaemon" 10DEPENDS = "openssl libdaemon zlib"
11COMPATIBLE_MACHINE = "(tci6614-evm|keystone)" 11COMPATIBLE_MACHINE = "(tci6614-evm|keystone)"
12 12
13BRANCH="master" 13BRANCH="master"
@@ -15,12 +15,15 @@ SRC_URI = "git://git.ti.com/keystone-linux/ti-softhsmv2.git;protocol=git;branch=
15#Following commit corresponds to tag DEV.SOFTHSM-01.03.00.01 15#Following commit corresponds to tag DEV.SOFTHSM-01.03.00.01
16SRCREV = "c79d93ac2a326567a7245dda1b903ef340b5650c" 16SRCREV = "c79d93ac2a326567a7245dda1b903ef340b5650c"
17PV = "1.3.0.1" 17PV = "1.3.0.1"
18PR = "r1"
18 19
19S = "${WORKDIR}/git" 20S = "${WORKDIR}/git"
20 21
21CFLAGS += " -mno-unaligned-access" 22CFLAGS += " -mno-unaligned-access"
22CPPFLAGS += " -mno-unaligned-access" 23CPPFLAGS += " -mno-unaligned-access"
23 24
25EXTRA_OECONF += "--with-zlib=${STAGING_DIR_HOST}/usr"
26
24INITSCRIPT_NAME = "softhsm-daemon.sh" 27INITSCRIPT_NAME = "softhsm-daemon.sh"
25INITSCRIPT_PARAMS = "defaults 10" 28INITSCRIPT_PARAMS = "defaults 10"
26 29