summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorJacob Stiffler <j-stiffler@ti.com>2015-05-20 19:40:30 +0000
committerDenys Dmytriyenko <denys@ti.com>2015-06-01 10:30:08 -0400
commitab170d0a0f3a4c6113ba105b8eb6838d6d7d5a64 (patch)
treeb56c6f632835ff14824b4b253af748bb9e0566a8
parent02ca76d89456fc0073f1b3384c06494ac51d1498 (diff)
downloadmeta-ti-ab170d0a0f3a4c6113ba105b8eb6838d6d7d5a64.tar.gz
gdbserver-c6x: Add version 1.1.0
* c6x DSP development files required to support remote gdb debugging. Signed-off-by: Jacob Stiffler <j-stiffler@ti.com> Signed-off-by: Denys Dmytriyenko <denys@ti.com>
-rw-r--r--recipes-devtools/gdbc6x/gdbserver-c6x_git.bb50
1 files changed, 50 insertions, 0 deletions
diff --git a/recipes-devtools/gdbc6x/gdbserver-c6x_git.bb b/recipes-devtools/gdbc6x/gdbserver-c6x_git.bb
new file mode 100644
index 00000000..f4dc51dc
--- /dev/null
+++ b/recipes-devtools/gdbc6x/gdbserver-c6x_git.bb
@@ -0,0 +1,50 @@
1DESCRIPTION = "TI gdb-server to be used with c6xgdb."
2LICENSE = "BSD"
3LIC_FILES_CHKSUM = "file://../debian/copyright;md5=82c616b6c8f9c11c46feaaf8f9a11495"
4
5DEPENDS = "ti-xdais ti-framework-components ti-cgt6x-native ti-sysbios ti-xdctools"
6
7PR = "${INC_PR}.0"
8
9S = "${WORKDIR}/git/gdbserver-c6x/src"
10
11PLATFORM = ""
12PLATFORM_dra7xx = "DRA7xx_PLATFORM"
13PLATFORM_keystone = "KEYSTONE_PLATFORM"
14
15EXTRA_OEMAKE = "PLATFORM=${PLATFORM}"
16
17export XDAIS_DIR = "${XDAIS_INSTALL_DIR}"
18export FC_DIR = "${FC_INSTALL_DIR}"
19export TI_CGT_INSTALL = "${STAGING_DIR_NATIVE}/usr/share/ti/cgt-c6x"
20export BIOS_DIR = "${SYSBIOS_INSTALL_DIR}"
21export XDC_DIR = "${XDC_INSTALL_DIR}"
22
23# The following is to prevent an unused configure.ac from erroneously
24# triggering the QA check for gettext.
25EXTRA_OECONF = "--disable-nls"
26do_configure() {
27 :
28}
29
30do_install() {
31 install -d ${D}${datadir}/ti/gdbc6x/include
32 install -d ${D}${datadir}/ti/gdbc6x/lib
33 cp -f ../include/* ${D}${datadir}/ti/gdbc6x/include
34 cp -f ../lib/* ${D}${datadir}/ti/gdbc6x/lib
35}
36
37COMPATIBLE_MACHINE = "dra7xx|keystone"
38PACKAGE_ARCH = "${MACHINE_ARCH}"
39
40FILES_${PN}-dev += "\
41 ${datadir}/ti/gdbc6x \
42"
43
44include gdbc6x.inc
45
46require recipes-ti/includes/ti-paths.inc
47
48ALLOW_EMPTY_${PN} = "1"
49
50PARALLEL_MAKE = ""