summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorJacob Stiffler <j-stiffler@ti.com>2015-05-27 20:10:38 +0000
committerDenys Dmytriyenko <denys@ti.com>2015-06-01 10:47:02 -0400
commit29eeee9ff4d602a65cd92c4aa95900ae3d46ca42 (patch)
tree43ec5617e3da5001c538d36b01543ea9187d6852
parent78d38afdb9f966dd1224c6fe092b8755f1f37153 (diff)
downloadmeta-ti-29eeee9ff4d602a65cd92c4aa95900ae3d46ca42.tar.gz
common-csl-ip-rtos: Add CSL RTOS package.
Signed-off-by: Jacob Stiffler <j-stiffler@ti.com> Signed-off-by: Denys Dmytriyenko <denys@ti.com>
-rw-r--r--recipes-bsp/common-csl-ip/common-csl-ip-rtos_git.bb33
1 files changed, 33 insertions, 0 deletions
diff --git a/recipes-bsp/common-csl-ip/common-csl-ip-rtos_git.bb b/recipes-bsp/common-csl-ip/common-csl-ip-rtos_git.bb
new file mode 100644
index 00000000..5d4a552a
--- /dev/null
+++ b/recipes-bsp/common-csl-ip/common-csl-ip-rtos_git.bb
@@ -0,0 +1,33 @@
1require common-csl-ip.inc
2
3require recipes-ti/includes/ti-paths.inc
4require recipes-ti/includes/ti-staging.inc
5
6DEPENDS = "ti-xdctools ti-cgt6x-native ti-sysbios"
7
8S = "${WORKDIR}/ti/csl"
9
10export C6X_GEN_INSTALL_PATH="${STAGING_DIR_NATIVE}/usr"
11export XDCCGROOT="${STAGING_DIR_NATIVE}/usr/share/ti/cgt-c6x"
12export XDCPATH="${XDCCGROOT}/include;${XDC_INSTALL_DIR}/packages;${SYSBIOS_INSTALL_DIR}/packages"
13
14do_configure() {
15 sed -i "s/\ \"\.\\\\\\\\\"\ +//" src/Module.xs
16 find -name "*.xs" -exec sed -i "s/ofd6x\.exe/ofd6x/" {} \;
17 find -name "*.xs" -exec sed -i "s/sectti\.exe/sectti/" {} \;
18 find -name "*.xs" -exec sed -i "/\.chm/d" {} \;
19 find -name "*.xs" -exec sed -i "s/pasm\_dos/pasm\_linux/" {} \;
20}
21
22do_compile() {
23 ${XDC_INSTALL_DIR}/xdc .make
24 ${XDC_INSTALL_DIR}/xdc clean
25 ${XDC_INSTALL_DIR}/xdc release
26}
27
28do_install () {
29 install -d ${D}${PDK_INSTALL_DIR_RECIPE}/packages
30 find -name "*.tar" -exec tar xf {} -C ${D}${PDK_INSTALL_DIR_RECIPE}/packages \;
31}
32
33FILES_${PN} += "${PDK_INSTALL_DIR_RECIPE}/packages"