summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorJacob Stiffler <j-stiffler@ti.com>2015-05-28 17:15:28 +0000
committerDenys Dmytriyenko <denys@ti.com>2015-06-01 10:59:16 -0400
commit2621fcec21de6c7c3290f301c9316c37af944184 (patch)
tree8612b47b7f2131a2f16db9993e80d6fd4f9f071c
parent7d01ae47ff7f0243b3601a36a148830bd768df42 (diff)
downloadmeta-ti-2621fcec21de6c7c3290f301c9316c37af944184.tar.gz
omapdrm-pvr: Use kernel mechanism for module installation.
Signed-off-by: Jacob Stiffler <j-stiffler@ti.com> Signed-off-by: Denys Dmytriyenko <denys@ti.com>
-rw-r--r--recipes-bsp/powervr-drivers/omapdrm-pvr_1.9.2253347.bb6
1 files changed, 2 insertions, 4 deletions
diff --git a/recipes-bsp/powervr-drivers/omapdrm-pvr_1.9.2253347.bb b/recipes-bsp/powervr-drivers/omapdrm-pvr_1.9.2253347.bb
index 4ef920ec..39885f8c 100644
--- a/recipes-bsp/powervr-drivers/omapdrm-pvr_1.9.2253347.bb
+++ b/recipes-bsp/powervr-drivers/omapdrm-pvr_1.9.2253347.bb
@@ -5,7 +5,7 @@ LIC_FILES_CHKSUM = "file://eurasia_km/README;beginline=13;endline=22;md5=2b841bf
5 5
6inherit module 6inherit module
7 7
8MACHINE_KERNEL_PR_append = "d" 8MACHINE_KERNEL_PR_append = "e"
9PR = "${MACHINE_KERNEL_PR}" 9PR = "${MACHINE_KERNEL_PR}"
10 10
11BRANCH = "next" 11BRANCH = "next"
@@ -22,7 +22,5 @@ do_compile_prepend() {
22} 22}
23 23
24do_install() { 24do_install() {
25 mkdir -p ${D}/lib/modules/${KERNEL_VERSION}/extra/ 25 make -C ${STAGING_KERNEL_DIR} SUBDIRS=${B}/eurasia_km/eurasiacon/binary2_omap5430_linux_release/target/kbuild INSTALL_MOD_PATH=${D} PREFIX=${STAGING_DIR_HOST} modules_install
26 cp ${S}/eurasia_km/eurasiacon/binary2_omap5430_linux_release/target/kbuild/omapdrm_pvr.ko \
27 ${D}/lib/modules/${KERNEL_VERSION}/extra/
28} 26}