diff options
author | Randolph Sapp <rs@ti.com> | 2024-10-18 11:34:08 -0500 |
---|---|---|
committer | Ryan Eatmon <reatmon@ti.com> | 2024-10-19 14:08:27 -0500 |
commit | dc78e06a6b848eec7e27e97175c1e2ef5ec56146 (patch) | |
tree | c5473ae71b692c9f6a95786cdffb4c03b46b2f38 | |
parent | c82f29cae79c6a4fec79c542649cb832e1fb67ab (diff) | |
download | meta-ti-dc78e06a6b848eec7e27e97175c1e2ef5ec56146.tar.gz |
sgx: breaking things to fix other things
We got a bit more time to do a proper migration this time. A discovery
period to see what actually works and boy, it wasn't much.
This update resolves issues with:
- Macro redefinition
- Sparse NPOT texture allocations
- vec4 reductions
- Mesa image extensions
- Buffer allocations under weston
- Devices with both a RENDER and PRIMARY display node
- Underprivileged users being unable to allocate buffers
- Removed call to drm_map_legacy
- Replace deprecated kernel calls
- Fix some cache attributes for userspace allocations
- About 40 other various errors and warnings
This core was never fully GLES2 conformant. In fact, if you try to run
cts on any of the older releases you'll find yourself in a hardware
recovery loop pretty quickly. We've gotten it to about 94.2% conformance
with these patches.
There are still dragons here, but they are at least a little more
manageable.
Signed-off-by: Randolph Sapp <rs@ti.com>
Signed-off-by: Ryan Eatmon <reatmon@ti.com>
3 files changed, 3 insertions, 3 deletions
diff --git a/meta-ti-bsp/recipes-bsp/powervr-drivers/ti-sgx-ddk-km_1.17.4948957.bb b/meta-ti-bsp/recipes-bsp/powervr-drivers/ti-sgx-ddk-km_1.17.4948957.bb index f112c662..100c10c1 100644 --- a/meta-ti-bsp/recipes-bsp/powervr-drivers/ti-sgx-ddk-km_1.17.4948957.bb +++ b/meta-ti-bsp/recipes-bsp/powervr-drivers/ti-sgx-ddk-km_1.17.4948957.bb | |||
@@ -19,7 +19,7 @@ SRC_URI = "git://git.ti.com/git/graphics/omap5-sgx-ddk-linux.git;protocol=https; | |||
19 | 19 | ||
20 | S = "${WORKDIR}/git" | 20 | S = "${WORKDIR}/git" |
21 | 21 | ||
22 | SRCREV = "2cb2c9609b7740cb2c348e669a96f26e1cc858da" | 22 | SRCREV = "652ae16657cc4acda664e669d0c9b4891252f37f" |
23 | 23 | ||
24 | TARGET_PRODUCT:omap-a15 = "ti572x_linux" | 24 | TARGET_PRODUCT:omap-a15 = "ti572x_linux" |
25 | TARGET_PRODUCT:ti33x = "ti335x_linux" | 25 | TARGET_PRODUCT:ti33x = "ti335x_linux" |
diff --git a/meta-ti-bsp/recipes-graphics/mesa/mesa-pvr_22.3.5.bb b/meta-ti-bsp/recipes-graphics/mesa/mesa-pvr_22.3.5.bb index 09ae0510..c93d01f9 100644 --- a/meta-ti-bsp/recipes-graphics/mesa/mesa-pvr_22.3.5.bb +++ b/meta-ti-bsp/recipes-graphics/mesa/mesa-pvr_22.3.5.bb | |||
@@ -28,7 +28,7 @@ PACKAGECONFIG:append = " \ | |||
28 | ${@bb.utils.contains('PREFERRED_PROVIDER_virtual/gpudriver', 'ti-sgx-ddk-km', 'sgx', '', d)} \ | 28 | ${@bb.utils.contains('PREFERRED_PROVIDER_virtual/gpudriver', 'ti-sgx-ddk-km', 'sgx', '', d)} \ |
29 | " | 29 | " |
30 | 30 | ||
31 | SRCREV = "1be98ba80452ebe38546a7fca26b5a70f2629083" | 31 | SRCREV = "c9f0919367589b38f5682183846de9d60eec082d" |
32 | PV = "22.3.5" | 32 | PV = "22.3.5" |
33 | 33 | ||
34 | PVR_DISPLAY_CONTROLLER_ALIAS ??= "tidss" | 34 | PVR_DISPLAY_CONTROLLER_ALIAS ??= "tidss" |
diff --git a/meta-ti-bsp/recipes-graphics/powervr-umlibs/ti-sgx-ddk-um_1.17.4948957.bb b/meta-ti-bsp/recipes-graphics/powervr-umlibs/ti-sgx-ddk-um_1.17.4948957.bb index d2565318..98bdec08 100644 --- a/meta-ti-bsp/recipes-graphics/powervr-umlibs/ti-sgx-ddk-um_1.17.4948957.bb +++ b/meta-ti-bsp/recipes-graphics/powervr-umlibs/ti-sgx-ddk-um_1.17.4948957.bb | |||
@@ -13,7 +13,7 @@ BRANCH = "${PV}/mesa/glibc-2.35" | |||
13 | SRC_URI = " \ | 13 | SRC_URI = " \ |
14 | git://git.ti.com/git/graphics/omap5-sgx-ddk-um-linux.git;protocol=https;branch=${BRANCH} \ | 14 | git://git.ti.com/git/graphics/omap5-sgx-ddk-um-linux.git;protocol=https;branch=${BRANCH} \ |
15 | " | 15 | " |
16 | SRCREV = "70364424dd496833fad5b243c9e6cc8b077f04ac" | 16 | SRCREV = "84a396a4fb379f10931421e489ac8a199d6a9f2c" |
17 | 17 | ||
18 | INITSCRIPT_NAME = "rc.pvr" | 18 | INITSCRIPT_NAME = "rc.pvr" |
19 | INITSCRIPT_PARAMS = "defaults 8" | 19 | INITSCRIPT_PARAMS = "defaults 8" |