summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorSabeeh Khan <sabeeh-khan@ti.com>2024-06-21 05:52:20 -0500
committerRyan Eatmon <reatmon@ti.com>2024-06-26 19:29:05 -0500
commit6f750ff4a9a0dcde63dd1e44beb25b6fb7c0fb59 (patch)
treea738510c2508ed45ea5d1da51e69d6f822dd514f
parenta5f833be1bc4a8160963e42bfa70e158cb28a570 (diff)
downloadmeta-ti-6f750ff4a9a0dcde63dd1e44beb25b6fb7c0fb59.tar.gz
cc33xx-fw: install cc33xx firmware
Download and install the cc33xx firmware and binaries to be used with the cc33xx drivers. FW Version: 1.7.0.120 Signed-off-by: Sabeeh Khan <sabeeh-khan@ti.com> Signed-off-by: Ryan Eatmon <reatmon@ti.com>
-rw-r--r--meta-ti-extras/recipes-bsp/cc33xx-fw/cc33xx-fw_git.bb22
1 files changed, 22 insertions, 0 deletions
diff --git a/meta-ti-extras/recipes-bsp/cc33xx-fw/cc33xx-fw_git.bb b/meta-ti-extras/recipes-bsp/cc33xx-fw/cc33xx-fw_git.bb
new file mode 100644
index 00000000..9f1de766
--- /dev/null
+++ b/meta-ti-extras/recipes-bsp/cc33xx-fw/cc33xx-fw_git.bb
@@ -0,0 +1,22 @@
1SUMMARY = "Firmware files for use with TI cc33xx"
2LICENSE = "TI-TSPA"
3LIC_FILES_CHKSUM = "file://LICENCE;md5=df68504cbd0a4da1643ebcfd5783dbc9"
4
5SRCREV = "988ded3a7d4d0e46de62e9ebfcb685c502bd9edf"
6SRC_URI = "git://git.ti.com/git/cc33xx-wlan/cc33xx-fw.git;protocol=https;branch=master"
7
8PV = "1.7.0.120"
9
10CLEANBROKEN = "1"
11
12S = "${WORKDIR}/git"
13
14do_compile[no_exec] = "1"
15
16EXTRA_OEMAKE = "DEST_DIR=${D} BASE_LIB_DIR=${nonarch_base_libdir}"
17
18do_install() {
19 oe_runmake install
20}
21
22FILES:${PN} = "${nonarch_base_libdir}/firmware/ti-connectivity/*"