summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorRandolph Sapp <rs@ti.com>2025-03-12 16:38:03 -0500
committerRyan Eatmon <reatmon@ti.com>2025-03-13 05:24:47 -0500
commit5c08a0b51098df17753dce3718eb2fd3511396a9 (patch)
tree2eeab545185d8fbb079443b8f963c66439aca0f2
parenta71cbc549e3e4d93699b1cf0c7dd5e5482e78b12 (diff)
downloadmeta-ti-5c08a0b51098df17753dce3718eb2fd3511396a9.tar.gz
ti-img-rogue-umlibs: ship module blacklist
Well, this is the evil vendor driver. Time to start acting like it. Blacklist the upstream powervr module if this driver is present. This patch also does away with the bin_package components. It was cool and found some interesting bugs, but we might as well start leveraging that Makefile more now that we're starting to get some more common files between devices. Signed-off-by: Randolph Sapp <rs@ti.com> Signed-off-by: Ryan Eatmon <reatmon@ti.com>
-rw-r--r--meta-ti-bsp/recipes-graphics/powervr-umlibs/ti-img-rogue-umlibs_24.2.6643903.bb23
1 files changed, 15 insertions, 8 deletions
diff --git a/meta-ti-bsp/recipes-graphics/powervr-umlibs/ti-img-rogue-umlibs_24.2.6643903.bb b/meta-ti-bsp/recipes-graphics/powervr-umlibs/ti-img-rogue-umlibs_24.2.6643903.bb
index b8153711..565e92eb 100644
--- a/meta-ti-bsp/recipes-graphics/powervr-umlibs/ti-img-rogue-umlibs_24.2.6643903.bb
+++ b/meta-ti-bsp/recipes-graphics/powervr-umlibs/ti-img-rogue-umlibs_24.2.6643903.bb
@@ -3,19 +3,15 @@ HOMEPAGE = "http://git.ti.com/graphics/ti-img-rogue-umlibs"
3LICENSE = "TI-TFL" 3LICENSE = "TI-TFL"
4LIC_FILES_CHKSUM = "file://${WORKDIR}/git/LICENSE;md5=7232b98c1c58f99e3baa03de5207e76f" 4LIC_FILES_CHKSUM = "file://${WORKDIR}/git/LICENSE;md5=7232b98c1c58f99e3baa03de5207e76f"
5 5
6inherit bin_package
7
8INHIBIT_DEFAULT_DEPS = ""
9
10PACKAGE_ARCH = "${MACHINE_ARCH}" 6PACKAGE_ARCH = "${MACHINE_ARCH}"
11COMPATIBLE_MACHINE = "j721e|j721s2|j784s4|j742s2|am62xx|am62pxx|j722s" 7COMPATIBLE_MACHINE = "j721e|j721s2|j784s4|j742s2|am62xx|am62pxx|j722s"
12 8
13PR = "r3" 9PR = "r4"
14 10
15BRANCH = "linuxws/scarthgap/k6.12/${PV}" 11BRANCH = "linuxws/scarthgap/k6.12/${PV}"
16SRC_URI = "git://git.ti.com/git/graphics/ti-img-rogue-umlibs.git;protocol=https;branch=${BRANCH}" 12SRC_URI = "git://git.ti.com/git/graphics/ti-img-rogue-umlibs.git;protocol=https;branch=${BRANCH}"
17SRCREV = "d578666fc6ecd09f7d6c3431747f1d93d128fe28" 13SRCREV = "1ed9ee185cd876200e6747192854015b8e94a7b0"
18S = "${WORKDIR}/git/targetfs/${TARGET_PRODUCT}/${PVR_WS}/${PVR_BUILD}" 14S = "${WORKDIR}/git"
19 15
20TARGET_PRODUCT:j721e = "j721e_linux" 16TARGET_PRODUCT:j721e = "j721e_linux"
21TARGET_PRODUCT:j721s2 = "j721s2_linux" 17TARGET_PRODUCT:j721s2 = "j721s2_linux"
@@ -54,7 +50,12 @@ def get_file_list(package_list_var, d):
54 file_list.append(f"{prefix}{package_file}") 50 file_list.append(f"{prefix}{package_file}")
55 return " ".join(file_list) 51 return " ".join(file_list)
56 52
57do_install:append() { 53EXTRA_OEMAKE += 'BUILD=${PVR_BUILD} TARGET_PRODUCT=${TARGET_PRODUCT} WINDOW_SYSTEM=${PVR_WS}'
54
55do_configure[noexec] = "1"
56do_compile[noexec] = "1"
57do_install() {
58 oe_runmake 'DESTDIR=${D}' install
58 if ${@bb.utils.contains('PACKAGECONFIG', 'opengl', 'false', 'true', d)}; then 59 if ${@bb.utils.contains('PACKAGECONFIG', 'opengl', 'false', 'true', d)}; then
59 for file in ${@get_file_list('GLES_PACKAGES', d)}; do 60 for file in ${@get_file_list('GLES_PACKAGES', d)}; do
60 rm -rf ${file} 61 rm -rf ${file}
@@ -78,6 +79,9 @@ do_install:append() {
78 79
79 # clean up any empty directories 80 # clean up any empty directories
80 find "${D}" -empty -type d -delete 81 find "${D}" -empty -type d -delete
82
83 # fix permissions
84 chown -R root:root "${D}"
81} 85}
82 86
83GLES_PACKAGES = "libgles1-rogue libgles2-rogue libgles3-rogue" 87GLES_PACKAGES = "libgles1-rogue libgles2-rogue libgles3-rogue"
@@ -141,6 +145,9 @@ INSANE_SKIP:${PN}-tools = "ldflags"
141FILES:${PN}-firmware = "${base_libdir}/firmware/*" 145FILES:${PN}-firmware = "${base_libdir}/firmware/*"
142INSANE_SKIP:${PN}-firmware += "arch" 146INSANE_SKIP:${PN}-firmware += "arch"
143 147
148# common libraries
149FILES:${PN} = "${libdir}"
150
144RRECOMMENDS:${PN} += " \ 151RRECOMMENDS:${PN} += " \
145 ${PN}-tools \ 152 ${PN}-tools \
146" 153"