diff options
author | Sabeeh Khan <sabeeh-khan@ti.com> | 2024-06-21 05:52:21 -0500 |
---|---|---|
committer | Ryan Eatmon <reatmon@ti.com> | 2024-07-01 08:58:02 -0500 |
commit | dbfb9a6265dbd7faa1bdd1a140472f77b1d80ab1 (patch) | |
tree | 818d41c057ed3d2ef16d8d9938f36afe26b42ee5 | |
parent | f9e2f462df8029fb1f2f33a654f20a986b9f055b (diff) | |
download | meta-ti-dbfb9a6265dbd7faa1bdd1a140472f77b1d80ab1.tar.gz |
cc33xx-target-scripts: add cc33xx scripts to control TI cc33xx WLAN device
Add scripts and conf files to be used to control and configure
the cc33xx WLAN device. Documentation for these scripts can be found here:
https://www.ti.com/tool/CC33XX-SOFTWARE
Signed-off-by: Sabeeh Khan <sabeeh-khan@ti.com>
Signed-off-by: Ryan Eatmon <reatmon@ti.com>
-rw-r--r-- | meta-ti-extras/recipes-connectivity/cc33xx-target-scripts/cc33xx-target-scripts_git.bb | 20 |
1 files changed, 20 insertions, 0 deletions
diff --git a/meta-ti-extras/recipes-connectivity/cc33xx-target-scripts/cc33xx-target-scripts_git.bb b/meta-ti-extras/recipes-connectivity/cc33xx-target-scripts/cc33xx-target-scripts_git.bb new file mode 100644 index 00000000..87f75653 --- /dev/null +++ b/meta-ti-extras/recipes-connectivity/cc33xx-target-scripts/cc33xx-target-scripts_git.bb | |||
@@ -0,0 +1,20 @@ | |||
1 | SUMMARY = "Scripts and configuration files for TI cc33xx wireless drivers" | ||
2 | LICENSE = "BSD-3-Clause" | ||
3 | LIC_FILES_CHKSUM = "file://COPYING;md5=904443cf7fae5c09c3d5f83f8557c265" | ||
4 | |||
5 | SRCREV = "4371c93ea01b339f6f73f77d6d6bfcc185def8c0" | ||
6 | SRC_URI = "git://git.ti.com/git/cc33xx-wlan/cc33xx-target-scripts.git;protocol=https;branch=master" | ||
7 | |||
8 | S = "${WORKDIR}/git" | ||
9 | |||
10 | FILES:${PN} += "${datadir}/cc33xx/" | ||
11 | |||
12 | do_install() { | ||
13 | install -d ${D}${datadir}/cc33xx/ | ||
14 | |||
15 | scripts=`find ./* -type f -name "*.*"` | ||
16 | for s in $scripts | ||
17 | do | ||
18 | install -m 0755 $s ${D}${datadir}/cc33xx/ | ||
19 | done | ||
20 | } | ||