summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorAndrew Davis <afd@ti.com>2023-10-25 11:56:24 -0500
committerRyan Eatmon <reatmon@ti.com>2023-11-08 17:36:02 -0600
commitf1f741180adabbe28117ca331fa7a1580b15a718 (patch)
tree5a600840e81f431a41716939dafd5aa5eae9c330
parent02263dbf152732a567c2e1a52e3dfa6dbc752d13 (diff)
downloadmeta-ti-f1f741180adabbe28117ca331fa7a1580b15a718.tar.gz
ti-linux-fw: Make CLEANBROKEN and FILES part of common include
These are common for all recipes that include ti-linux-fw.inc, add it to this include file and remove from each recipe. Signed-off-by: Andrew Davis <afd@ti.com> Signed-off-by: Ryan Eatmon <reatmon@ti.com>
-rw-r--r--meta-ti-bsp/recipes-bsp/cadence-mhdp-fw/cadence-mhdp-fw_git.bb4
-rw-r--r--meta-ti-bsp/recipes-bsp/cnm-wave-fw/cnm-wave-fw_git.bb5
-rw-r--r--meta-ti-bsp/recipes-bsp/goodix-fw/goodix-fw_git.bb4
-rw-r--r--meta-ti-bsp/recipes-bsp/prueth-fw/prueth-fw-am65x-sr2_git.bb4
-rw-r--r--meta-ti-bsp/recipes-bsp/prueth-fw/prueth-fw-am65x_git.bb4
-rw-r--r--meta-ti-bsp/recipes-bsp/prueth-fw/prueth-fw_5.6.15.bb5
-rw-r--r--meta-ti-bsp/recipes-bsp/pruhsr-fw/pruhsr-fw-am65x-sr2_git.bb4
-rw-r--r--meta-ti-bsp/recipes-bsp/pruhsr-fw/pruhsr-fw_2.17.25.bb4
-rw-r--r--meta-ti-bsp/recipes-bsp/pruprp-fw/pruprp-fw_2.17.25.bb4
-rw-r--r--meta-ti-bsp/recipes-bsp/prusw-fw/prusw-fw-am65x-sr2_git.bb4
-rw-r--r--meta-ti-bsp/recipes-bsp/prusw-fw/prusw-fw_3.2.9.bb5
-rw-r--r--meta-ti-bsp/recipes-bsp/ti-dm-fw/ti-dm-fw.bb5
-rw-r--r--meta-ti-bsp/recipes-bsp/ti-eth-fw/ti-eth-fw.bb5
-rw-r--r--meta-ti-bsp/recipes-bsp/ti-img-encode-decode/vxd-dec-fw_git.bb4
-rw-r--r--meta-ti-bsp/recipes-bsp/ti-linux-fw/ti-linux-fw.inc5
-rw-r--r--meta-ti-bsp/recipes-bsp/ti-sci-fw/ti-sci-fw_git.bb4
-rw-r--r--meta-ti-bsp/recipes-ti/ti-rtos-bin/ti-rtos-firmware.bb5
17 files changed, 5 insertions, 70 deletions
diff --git a/meta-ti-bsp/recipes-bsp/cadence-mhdp-fw/cadence-mhdp-fw_git.bb b/meta-ti-bsp/recipes-bsp/cadence-mhdp-fw/cadence-mhdp-fw_git.bb
index 5ae0cb7c..4263e40f 100644
--- a/meta-ti-bsp/recipes-bsp/cadence-mhdp-fw/cadence-mhdp-fw_git.bb
+++ b/meta-ti-bsp/recipes-bsp/cadence-mhdp-fw/cadence-mhdp-fw_git.bb
@@ -8,8 +8,6 @@ LIC_FILES_CHKSUM = "file://LICENCE.cadence;md5=009f46816f6956cfb75ede13d3e1cee0"
8PV = "${CADENCE_MHDP_FW_VERSION}" 8PV = "${CADENCE_MHDP_FW_VERSION}"
9PR = "${INC_PR}.0" 9PR = "${INC_PR}.0"
10 10
11CLEANBROKEN = "1"
12
13COMPATIBLE_MACHINE = "j721e|j721s2|j784s4" 11COMPATIBLE_MACHINE = "j721e|j721s2|j784s4"
14 12
15PACKAGE_ARCH = "${MACHINE_ARCH}" 13PACKAGE_ARCH = "${MACHINE_ARCH}"
@@ -21,5 +19,3 @@ do_install() {
21 install -d ${D}${nonarch_base_libdir}/firmware/cadence 19 install -d ${D}${nonarch_base_libdir}/firmware/cadence
22 install -m 0644 ${S}/cadence/${TARGET} ${D}${nonarch_base_libdir}/firmware/cadence/${TARGET} 20 install -m 0644 ${S}/cadence/${TARGET} ${D}${nonarch_base_libdir}/firmware/cadence/${TARGET}
23} 21}
24
25FILES:${PN} = "${nonarch_base_libdir}/firmware"
diff --git a/meta-ti-bsp/recipes-bsp/cnm-wave-fw/cnm-wave-fw_git.bb b/meta-ti-bsp/recipes-bsp/cnm-wave-fw/cnm-wave-fw_git.bb
index e35decee..ef538243 100644
--- a/meta-ti-bsp/recipes-bsp/cnm-wave-fw/cnm-wave-fw_git.bb
+++ b/meta-ti-bsp/recipes-bsp/cnm-wave-fw/cnm-wave-fw_git.bb
@@ -11,8 +11,6 @@ LIC_FILES_CHKSUM = "file://LICENCE.cnm;md5=93b67e6bac7f8fec22b96b8ad0a1a9d0"
11PV = "${CNM_WAVE521_FW_VERSION}" 11PV = "${CNM_WAVE521_FW_VERSION}"
12PR = "${INC_PR}.1" 12PR = "${INC_PR}.1"
13 13
14CLEANBROKEN = "1"
15
16COMPATIBLE_MACHINE = "j721s2|j784s4|am62axx|am62pxx" 14COMPATIBLE_MACHINE = "j721s2|j784s4|am62axx|am62pxx"
17 15
18PACKAGE_ARCH = "${MACHINE_ARCH}" 16PACKAGE_ARCH = "${MACHINE_ARCH}"
@@ -34,9 +32,6 @@ do_install() {
34 install -m 0644 ${S}/cnm/${SOURCE_WAVE521C} ${D}${nonarch_base_libdir}/firmware/cnm/${TARGET_WAVE521C} 32 install -m 0644 ${S}/cnm/${SOURCE_WAVE521C} ${D}${nonarch_base_libdir}/firmware/cnm/${TARGET_WAVE521C}
35} 33}
36 34
37# make sure that lib/firmware, and all its contents are part of the package
38FILES:${PN} = "${nonarch_base_libdir}/firmware"
39
40# we don't want to configure and build the source code 35# we don't want to configure and build the source code
41do_compile[noexec] = "1" 36do_compile[noexec] = "1"
42do_configure[noexec] = "1" 37do_configure[noexec] = "1"
diff --git a/meta-ti-bsp/recipes-bsp/goodix-fw/goodix-fw_git.bb b/meta-ti-bsp/recipes-bsp/goodix-fw/goodix-fw_git.bb
index 00a6e51b..5cd6e131 100644
--- a/meta-ti-bsp/recipes-bsp/goodix-fw/goodix-fw_git.bb
+++ b/meta-ti-bsp/recipes-bsp/goodix-fw/goodix-fw_git.bb
@@ -8,8 +8,6 @@ LIC_FILES_CHKSUM = "file://LICENCE.Spectrum-GT9271;md5=2a6de6be7af1fe46370c684da
8PV = "${GOODIX_FW_VERSION}" 8PV = "${GOODIX_FW_VERSION}"
9PR = "${INC_PR}.0" 9PR = "${INC_PR}.0"
10 10
11CLEANBROKEN = "1"
12
13COMPATIBLE_MACHINE = "dra7xx" 11COMPATIBLE_MACHINE = "dra7xx"
14 12
15PACKAGE_ARCH = "${MACHINE_ARCH}" 13PACKAGE_ARCH = "${MACHINE_ARCH}"
@@ -22,5 +20,3 @@ do_install() {
22 install -d ${D}${nonarch_base_libdir}/firmware 20 install -d ${D}${nonarch_base_libdir}/firmware
23 install -m 0644 ${S}/ti-evm/${ORIGIN} ${D}${nonarch_base_libdir}/firmware/${TARGET} 21 install -m 0644 ${S}/ti-evm/${ORIGIN} ${D}${nonarch_base_libdir}/firmware/${TARGET}
24} 22}
25
26FILES:${PN} = "${nonarch_base_libdir}/firmware"
diff --git a/meta-ti-bsp/recipes-bsp/prueth-fw/prueth-fw-am65x-sr2_git.bb b/meta-ti-bsp/recipes-bsp/prueth-fw/prueth-fw-am65x-sr2_git.bb
index 28c02698..5d95beab 100644
--- a/meta-ti-bsp/recipes-bsp/prueth-fw/prueth-fw-am65x-sr2_git.bb
+++ b/meta-ti-bsp/recipes-bsp/prueth-fw/prueth-fw-am65x-sr2_git.bb
@@ -5,8 +5,6 @@ require recipes-bsp/ti-linux-fw/ti-linux-fw.inc
5PV = "${PRUETH_FW_AM65X_SR2_VERSION}" 5PV = "${PRUETH_FW_AM65X_SR2_VERSION}"
6PR = "${INC_PR}.0" 6PR = "${INC_PR}.0"
7 7
8CLEANBROKEN = "1"
9
10COMPATIBLE_MACHINE = "am65xx-evm|am64xx" 8COMPATIBLE_MACHINE = "am65xx-evm|am64xx"
11 9
12PACKAGE_ARCH = "${MACHINE_ARCH}" 10PACKAGE_ARCH = "${MACHINE_ARCH}"
@@ -29,6 +27,4 @@ do_install() {
29 done 27 done
30} 28}
31 29
32FILES:${PN} = "${nonarch_base_libdir}/firmware"
33
34INSANE_SKIP:${PN} = "arch" 30INSANE_SKIP:${PN} = "arch"
diff --git a/meta-ti-bsp/recipes-bsp/prueth-fw/prueth-fw-am65x_git.bb b/meta-ti-bsp/recipes-bsp/prueth-fw/prueth-fw-am65x_git.bb
index c656ceab..f0d4d16d 100644
--- a/meta-ti-bsp/recipes-bsp/prueth-fw/prueth-fw-am65x_git.bb
+++ b/meta-ti-bsp/recipes-bsp/prueth-fw/prueth-fw-am65x_git.bb
@@ -5,8 +5,6 @@ require recipes-bsp/ti-linux-fw/ti-linux-fw.inc
5PV = "${PRUETH_FW_AM65X_VERSION}" 5PV = "${PRUETH_FW_AM65X_VERSION}"
6PR = "${INC_PR}.0" 6PR = "${INC_PR}.0"
7 7
8CLEANBROKEN = "1"
9
10COMPATIBLE_MACHINE = "am65xx" 8COMPATIBLE_MACHINE = "am65xx"
11 9
12PACKAGE_ARCH = "${MACHINE_ARCH}" 10PACKAGE_ARCH = "${MACHINE_ARCH}"
@@ -27,6 +25,4 @@ do_install() {
27 done 25 done
28} 26}
29 27
30FILES:${PN} = "${nonarch_base_libdir}/firmware"
31
32INSANE_SKIP:${PN} = "arch" 28INSANE_SKIP:${PN} = "arch"
diff --git a/meta-ti-bsp/recipes-bsp/prueth-fw/prueth-fw_5.6.15.bb b/meta-ti-bsp/recipes-bsp/prueth-fw/prueth-fw_5.6.15.bb
index 4f298a2c..c7db85fc 100644
--- a/meta-ti-bsp/recipes-bsp/prueth-fw/prueth-fw_5.6.15.bb
+++ b/meta-ti-bsp/recipes-bsp/prueth-fw/prueth-fw_5.6.15.bb
@@ -4,8 +4,6 @@ require recipes-bsp/ti-linux-fw/ti-linux-fw.inc
4 4
5PR = "${INC_PR}.0" 5PR = "${INC_PR}.0"
6 6
7CLEANBROKEN = "1"
8
9COMPATIBLE_MACHINE = "ti33x|ti43x|am57xx" 7COMPATIBLE_MACHINE = "ti33x|ti43x|am57xx"
10 8
11PACKAGE_ARCH = "${MACHINE_ARCH}" 9PACKAGE_ARCH = "${MACHINE_ARCH}"
@@ -24,7 +22,4 @@ do_install() {
24 done 22 done
25} 23}
26 24
27
28FILES:${PN} = "${nonarch_base_libdir}/firmware"
29
30INSANE_SKIP:${PN} = "arch" 25INSANE_SKIP:${PN} = "arch"
diff --git a/meta-ti-bsp/recipes-bsp/pruhsr-fw/pruhsr-fw-am65x-sr2_git.bb b/meta-ti-bsp/recipes-bsp/pruhsr-fw/pruhsr-fw-am65x-sr2_git.bb
index c31af832..12f7b729 100644
--- a/meta-ti-bsp/recipes-bsp/pruhsr-fw/pruhsr-fw-am65x-sr2_git.bb
+++ b/meta-ti-bsp/recipes-bsp/pruhsr-fw/pruhsr-fw-am65x-sr2_git.bb
@@ -5,8 +5,6 @@ require recipes-bsp/ti-linux-fw/ti-linux-fw.inc
5PV = "${PRUETH_FW_AM65X_SR2_VERSION}" 5PV = "${PRUETH_FW_AM65X_SR2_VERSION}"
6PR = "${INC_PR}.0" 6PR = "${INC_PR}.0"
7 7
8CLEANBROKEN = "1"
9
10COMPATIBLE_MACHINE = "am65xx-evm|am64xx" 8COMPATIBLE_MACHINE = "am65xx-evm|am64xx"
11 9
12PACKAGE_ARCH = "${MACHINE_ARCH}" 10PACKAGE_ARCH = "${MACHINE_ARCH}"
@@ -29,6 +27,4 @@ do_install() {
29 done 27 done
30} 28}
31 29
32FILES:${PN} = "${nonarch_base_libdir}/firmware"
33
34INSANE_SKIP:${PN} = "arch" 30INSANE_SKIP:${PN} = "arch"
diff --git a/meta-ti-bsp/recipes-bsp/pruhsr-fw/pruhsr-fw_2.17.25.bb b/meta-ti-bsp/recipes-bsp/pruhsr-fw/pruhsr-fw_2.17.25.bb
index 69ccb31a..47c272a8 100644
--- a/meta-ti-bsp/recipes-bsp/pruhsr-fw/pruhsr-fw_2.17.25.bb
+++ b/meta-ti-bsp/recipes-bsp/pruhsr-fw/pruhsr-fw_2.17.25.bb
@@ -5,8 +5,6 @@ require recipes-bsp/ti-linux-fw/ti-linux-fw.inc
5PE = "1" 5PE = "1"
6PR = "${INC_PR}.0" 6PR = "${INC_PR}.0"
7 7
8CLEANBROKEN = "1"
9
10COMPATIBLE_MACHINE = "ti33x|ti43x|am57xx" 8COMPATIBLE_MACHINE = "ti33x|ti43x|am57xx"
11 9
12PACKAGE_ARCH = "${MACHINE_ARCH}" 10PACKAGE_ARCH = "${MACHINE_ARCH}"
@@ -25,6 +23,4 @@ do_install() {
25 done 23 done
26} 24}
27 25
28FILES:${PN} = "${nonarch_base_libdir}/firmware"
29
30INSANE_SKIP:${PN} = "arch" 26INSANE_SKIP:${PN} = "arch"
diff --git a/meta-ti-bsp/recipes-bsp/pruprp-fw/pruprp-fw_2.17.25.bb b/meta-ti-bsp/recipes-bsp/pruprp-fw/pruprp-fw_2.17.25.bb
index f774db58..fc8e423e 100644
--- a/meta-ti-bsp/recipes-bsp/pruprp-fw/pruprp-fw_2.17.25.bb
+++ b/meta-ti-bsp/recipes-bsp/pruprp-fw/pruprp-fw_2.17.25.bb
@@ -5,8 +5,6 @@ require recipes-bsp/ti-linux-fw/ti-linux-fw.inc
5PE = "1" 5PE = "1"
6PR = "${INC_PR}.0" 6PR = "${INC_PR}.0"
7 7
8CLEANBROKEN = "1"
9
10COMPATIBLE_MACHINE = "ti33x|ti43x|am57xx" 8COMPATIBLE_MACHINE = "ti33x|ti43x|am57xx"
11 9
12PACKAGE_ARCH = "${MACHINE_ARCH}" 10PACKAGE_ARCH = "${MACHINE_ARCH}"
@@ -25,6 +23,4 @@ do_install() {
25 done 23 done
26} 24}
27 25
28FILES:${PN} = "${nonarch_base_libdir}/firmware"
29
30INSANE_SKIP:${PN} = "arch" 26INSANE_SKIP:${PN} = "arch"
diff --git a/meta-ti-bsp/recipes-bsp/prusw-fw/prusw-fw-am65x-sr2_git.bb b/meta-ti-bsp/recipes-bsp/prusw-fw/prusw-fw-am65x-sr2_git.bb
index e0cf2cb5..208f8764 100644
--- a/meta-ti-bsp/recipes-bsp/prusw-fw/prusw-fw-am65x-sr2_git.bb
+++ b/meta-ti-bsp/recipes-bsp/prusw-fw/prusw-fw-am65x-sr2_git.bb
@@ -5,8 +5,6 @@ require recipes-bsp/ti-linux-fw/ti-linux-fw.inc
5PV = "${PRUETH_FW_AM65X_SR2_VERSION}" 5PV = "${PRUETH_FW_AM65X_SR2_VERSION}"
6PR = "${INC_PR}.0" 6PR = "${INC_PR}.0"
7 7
8CLEANBROKEN = "1"
9
10COMPATIBLE_MACHINE = "am65xx-evm|am64xx" 8COMPATIBLE_MACHINE = "am65xx-evm|am64xx"
11 9
12PACKAGE_ARCH = "${MACHINE_ARCH}" 10PACKAGE_ARCH = "${MACHINE_ARCH}"
@@ -29,6 +27,4 @@ do_install() {
29 done 27 done
30} 28}
31 29
32FILES:${PN} = "${nonarch_base_libdir}/firmware"
33
34INSANE_SKIP:${PN} = "arch" 30INSANE_SKIP:${PN} = "arch"
diff --git a/meta-ti-bsp/recipes-bsp/prusw-fw/prusw-fw_3.2.9.bb b/meta-ti-bsp/recipes-bsp/prusw-fw/prusw-fw_3.2.9.bb
index 5b38a048..68649cf2 100644
--- a/meta-ti-bsp/recipes-bsp/prusw-fw/prusw-fw_3.2.9.bb
+++ b/meta-ti-bsp/recipes-bsp/prusw-fw/prusw-fw_3.2.9.bb
@@ -4,8 +4,6 @@ require recipes-bsp/ti-linux-fw/ti-linux-fw.inc
4 4
5PR = "${INC_PR}.0" 5PR = "${INC_PR}.0"
6 6
7CLEANBROKEN = "1"
8
9COMPATIBLE_MACHINE = "ti33x|ti43x|am57xx" 7COMPATIBLE_MACHINE = "ti33x|ti43x|am57xx"
10 8
11PACKAGE_ARCH = "${MACHINE_ARCH}" 9PACKAGE_ARCH = "${MACHINE_ARCH}"
@@ -24,7 +22,4 @@ do_install() {
24 done 22 done
25} 23}
26 24
27
28FILES:${PN} = "${nonarch_base_libdir}/firmware"
29
30INSANE_SKIP:${PN} = "arch" 25INSANE_SKIP:${PN} = "arch"
diff --git a/meta-ti-bsp/recipes-bsp/ti-dm-fw/ti-dm-fw.bb b/meta-ti-bsp/recipes-bsp/ti-dm-fw/ti-dm-fw.bb
index da44234c..fcb18c03 100644
--- a/meta-ti-bsp/recipes-bsp/ti-dm-fw/ti-dm-fw.bb
+++ b/meta-ti-bsp/recipes-bsp/ti-dm-fw/ti-dm-fw.bb
@@ -17,8 +17,6 @@ require recipes-bsp/ti-linux-fw/ti-linux-fw.inc
17PV = "${TI_DM_FW_VERSION}" 17PV = "${TI_DM_FW_VERSION}"
18PR = "${INC_PR}.0" 18PR = "${INC_PR}.0"
19 19
20CLEANBROKEN = "1"
21
22# Secure Build 20# Secure Build
23inherit ti-secdev 21inherit ti-secdev
24 22
@@ -106,9 +104,6 @@ ALTERNATIVE_TARGET[j784s4-mcu-r5f0_0-fw] = "${INSTALL_DM_FW_DIR}/${DM_FIRMWARE}"
106 104
107ALTERNATIVE_PRIORITY = "10" 105ALTERNATIVE_PRIORITY = "10"
108 106
109# make sure that lib/firmware, and all its contents are part of the package
110FILES:${PN} += "${nonarch_base_libdir}/firmware"
111
112# This is used to prevent the build system to_strip the executables 107# This is used to prevent the build system to_strip the executables
113INHIBIT_PACKAGE_STRIP = "1" 108INHIBIT_PACKAGE_STRIP = "1"
114INHIBIT_SYSROOT_STRIP = "1" 109INHIBIT_SYSROOT_STRIP = "1"
diff --git a/meta-ti-bsp/recipes-bsp/ti-eth-fw/ti-eth-fw.bb b/meta-ti-bsp/recipes-bsp/ti-eth-fw/ti-eth-fw.bb
index b2a6526c..0688aebb 100644
--- a/meta-ti-bsp/recipes-bsp/ti-eth-fw/ti-eth-fw.bb
+++ b/meta-ti-bsp/recipes-bsp/ti-eth-fw/ti-eth-fw.bb
@@ -17,8 +17,6 @@ require recipes-bsp/ti-linux-fw/ti-linux-fw.inc
17PV = "${CORESDK_RTOS_VERSION}" 17PV = "${CORESDK_RTOS_VERSION}"
18PR = "${INC_PR}.0" 18PR = "${INC_PR}.0"
19 19
20CLEANBROKEN = "1"
21
22# Secure Build 20# Secure Build
23inherit ti-secdev 21inherit ti-secdev
24 22
@@ -104,9 +102,6 @@ ALTERNATIVE_TARGET[j784s4-main-r5f0_0-fw-sec] = "${INSTALL_ETH_FW_DIR}/${ETH_FW}
104 102
105ALTERNATIVE_PRIORITY = "5" 103ALTERNATIVE_PRIORITY = "5"
106 104
107# make sure that lib/firmware, and all its contents are part of the package
108FILES:${PN} += "${nonarch_base_libdir}/firmware"
109
110# This is used to prevent the build system to_strip the executables 105# This is used to prevent the build system to_strip the executables
111INHIBIT_PACKAGE_STRIP = "1" 106INHIBIT_PACKAGE_STRIP = "1"
112INHIBIT_SYSROOT_STRIP = "1" 107INHIBIT_SYSROOT_STRIP = "1"
diff --git a/meta-ti-bsp/recipes-bsp/ti-img-encode-decode/vxd-dec-fw_git.bb b/meta-ti-bsp/recipes-bsp/ti-img-encode-decode/vxd-dec-fw_git.bb
index bd103198..7fb8f8f5 100644
--- a/meta-ti-bsp/recipes-bsp/ti-img-encode-decode/vxd-dec-fw_git.bb
+++ b/meta-ti-bsp/recipes-bsp/ti-img-encode-decode/vxd-dec-fw_git.bb
@@ -7,8 +7,6 @@ require recipes-bsp/ti-linux-fw/ti-linux-fw.inc
7PV = "${IMG_DEC_FW_VERSION}" 7PV = "${IMG_DEC_FW_VERSION}"
8PR = "${INC_PR}.0" 8PR = "${INC_PR}.0"
9 9
10CLEANBROKEN = "1"
11
12COMPATIBLE_MACHINE = "j721e" 10COMPATIBLE_MACHINE = "j721e"
13 11
14PACKAGE_ARCH = "${MACHINE_ARCH}" 12PACKAGE_ARCH = "${MACHINE_ARCH}"
@@ -20,5 +18,3 @@ do_install() {
20 install -d ${D}${nonarch_base_libdir}/firmware 18 install -d ${D}${nonarch_base_libdir}/firmware
21 install -m 0644 ${S}/ti-img/${TARGET} ${D}${nonarch_base_libdir}/firmware/${TARGET} 19 install -m 0644 ${S}/ti-img/${TARGET} ${D}${nonarch_base_libdir}/firmware/${TARGET}
22} 20}
23
24FILES:${PN} = "${nonarch_base_libdir}/firmware"
diff --git a/meta-ti-bsp/recipes-bsp/ti-linux-fw/ti-linux-fw.inc b/meta-ti-bsp/recipes-bsp/ti-linux-fw/ti-linux-fw.inc
index b67cdc8a..5d059c99 100644
--- a/meta-ti-bsp/recipes-bsp/ti-linux-fw/ti-linux-fw.inc
+++ b/meta-ti-bsp/recipes-bsp/ti-linux-fw/ti-linux-fw.inc
@@ -25,3 +25,8 @@ BRANCH ?= "ti-linux-firmware"
25SRC_URI = "git://git.ti.com/git/processor-firmware/ti-linux-firmware.git;protocol=https;branch=${BRANCH}" 25SRC_URI = "git://git.ti.com/git/processor-firmware/ti-linux-firmware.git;protocol=https;branch=${BRANCH}"
26 26
27S = "${WORKDIR}/git" 27S = "${WORKDIR}/git"
28
29CLEANBROKEN = "1"
30
31# Make sure that lib/firmware, and all its contents are part of the package
32FILES:${PN} = "${nonarch_base_libdir}/firmware"
diff --git a/meta-ti-bsp/recipes-bsp/ti-sci-fw/ti-sci-fw_git.bb b/meta-ti-bsp/recipes-bsp/ti-sci-fw/ti-sci-fw_git.bb
index 2ad93a5d..0eb03b92 100644
--- a/meta-ti-bsp/recipes-bsp/ti-sci-fw/ti-sci-fw_git.bb
+++ b/meta-ti-bsp/recipes-bsp/ti-sci-fw/ti-sci-fw_git.bb
@@ -14,8 +14,6 @@ LD[unexport] = "1"
14PV = "${TI_SYSFW_VERSION}" 14PV = "${TI_SYSFW_VERSION}"
15PR = "${INC_PR}.0" 15PR = "${INC_PR}.0"
16 16
17CLEANBROKEN = "1"
18
19do_install() { 17do_install() {
20 install -d ${D}${nonarch_base_libdir}/firmware/ti-sysfw 18 install -d ${D}${nonarch_base_libdir}/firmware/ti-sysfw
21 install -m 644 ${S}/ti-sysfw/ti-sci-firmware-* ${D}${nonarch_base_libdir}/firmware/ti-sysfw 19 install -m 644 ${S}/ti-sysfw/ti-sci-firmware-* ${D}${nonarch_base_libdir}/firmware/ti-sysfw
@@ -23,8 +21,6 @@ do_install() {
23 install -m 644 ${S}/ti-sysfw/ti-fs-stub-firmware-* ${D}${nonarch_base_libdir}/firmware/ti-sysfw 21 install -m 644 ${S}/ti-sysfw/ti-fs-stub-firmware-* ${D}${nonarch_base_libdir}/firmware/ti-sysfw
24} 22}
25 23
26FILES:${PN} = "${nonarch_base_libdir}/firmware"
27
28do_deploy(){ 24do_deploy(){
29} 25}
30 26
diff --git a/meta-ti-bsp/recipes-ti/ti-rtos-bin/ti-rtos-firmware.bb b/meta-ti-bsp/recipes-ti/ti-rtos-bin/ti-rtos-firmware.bb
index 8d40cffe..b10f2f57 100644
--- a/meta-ti-bsp/recipes-ti/ti-rtos-bin/ti-rtos-firmware.bb
+++ b/meta-ti-bsp/recipes-ti/ti-rtos-bin/ti-rtos-firmware.bb
@@ -29,8 +29,6 @@ require recipes-bsp/ti-linux-fw/ti-linux-fw.inc
29PV = "${CORESDK_RTOS_VERSION}" 29PV = "${CORESDK_RTOS_VERSION}"
30PR = "${INC_PR}.1" 30PR = "${INC_PR}.1"
31 31
32CLEANBROKEN = "1"
33
34# Secure Build 32# Secure Build
35inherit ti-secdev 33inherit ti-secdev
36 34
@@ -369,9 +367,6 @@ ALTERNATIVE_TARGET[j784s4-c71_3-fw-sec] = "${INSTALL_IPC_FW_DIR}/${C7X_4_FW}.sig
369 367
370ALTERNATIVE_PRIORITY = "10" 368ALTERNATIVE_PRIORITY = "10"
371 369
372# make sure that lib/firmware, and all its contents are part of the package
373FILES:${PN} += "${nonarch_base_libdir}/firmware"
374
375# This is used to prevent the build system to_strip the executables 370# This is used to prevent the build system to_strip the executables
376INHIBIT_PACKAGE_STRIP = "1" 371INHIBIT_PACKAGE_STRIP = "1"
377INHIBIT_SYSROOT_STRIP = "1" 372INHIBIT_SYSROOT_STRIP = "1"