summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorRandolph Sapp <rs@ti.com>2023-10-27 17:21:59 -0500
committerRyan Eatmon <reatmon@ti.com>2023-10-30 16:53:44 -0500
commitd10e4b81719adcbc6ae15e1db2a7c32ba40b5fce (patch)
treeccecf56bb42cb8c442ceb776f8e32c565d109858
parent48000c11148e7a22931e9e2e4b6a03964874667c (diff)
downloadmeta-ti-d10e4b81719adcbc6ae15e1db2a7c32ba40b5fce.tar.gz
ti-img-rogue-*: add am62p support
Add the configuration options for am62pxx-evm. This also adds support for new devicetree properties to override the clock value of the device. See the kernel module modifications [1] and dt bindings for more information. [1] https://git.ti.com/cgit/graphics/ti-img-rogue-driver/log/?h=linuxws/kirkstone/k6.1/23.2.6460340 Signed-off-by: Randolph Sapp <rs@ti.com> Signed-off-by: Ryan Eatmon <reatmon@ti.com>
-rw-r--r--meta-ti-bsp/recipes-bsp/powervr-drivers/ti-img-rogue-driver_23.2.6460340.bb3
-rw-r--r--meta-ti-bsp/recipes-graphics/powervr-umlibs/ti-img-rogue-umlibs_23.2.6460340.bb3
2 files changed, 4 insertions, 2 deletions
diff --git a/meta-ti-bsp/recipes-bsp/powervr-drivers/ti-img-rogue-driver_23.2.6460340.bb b/meta-ti-bsp/recipes-bsp/powervr-drivers/ti-img-rogue-driver_23.2.6460340.bb
index d46699ca..a74cc7b8 100644
--- a/meta-ti-bsp/recipes-bsp/powervr-drivers/ti-img-rogue-driver_23.2.6460340.bb
+++ b/meta-ti-bsp/recipes-bsp/powervr-drivers/ti-img-rogue-driver_23.2.6460340.bb
@@ -12,7 +12,7 @@ PR = "${MACHINE_KERNEL_PR}"
12 12
13PACKAGE_ARCH = "${MACHINE_ARCH}" 13PACKAGE_ARCH = "${MACHINE_ARCH}"
14 14
15COMPATIBLE_MACHINE = "j721e|j721s2|j784s4|am62xx" 15COMPATIBLE_MACHINE = "j721e|j721s2|j784s4|am62xx|am62pxx"
16 16
17DEPENDS = "virtual/kernel" 17DEPENDS = "virtual/kernel"
18 18
@@ -28,6 +28,7 @@ TARGET_PRODUCT:j721e = "j721e_linux"
28TARGET_PRODUCT:j721s2 = "j721s2_linux" 28TARGET_PRODUCT:j721s2 = "j721s2_linux"
29TARGET_PRODUCT:j784s4 = "j784s4_linux" 29TARGET_PRODUCT:j784s4 = "j784s4_linux"
30TARGET_PRODUCT:am62xx = "am62_linux" 30TARGET_PRODUCT:am62xx = "am62_linux"
31TARGET_PRODUCT:am62pxx = "am62p_linux"
31PVR_BUILD = "release" 32PVR_BUILD = "release"
32PVR_WS = "lws-generic" 33PVR_WS = "lws-generic"
33 34
diff --git a/meta-ti-bsp/recipes-graphics/powervr-umlibs/ti-img-rogue-umlibs_23.2.6460340.bb b/meta-ti-bsp/recipes-graphics/powervr-umlibs/ti-img-rogue-umlibs_23.2.6460340.bb
index 3ce39f00..18182590 100644
--- a/meta-ti-bsp/recipes-graphics/powervr-umlibs/ti-img-rogue-umlibs_23.2.6460340.bb
+++ b/meta-ti-bsp/recipes-graphics/powervr-umlibs/ti-img-rogue-umlibs_23.2.6460340.bb
@@ -8,7 +8,7 @@ inherit bin_package
8INHIBIT_DEFAULT_DEPS = "" 8INHIBIT_DEFAULT_DEPS = ""
9 9
10PACKAGE_ARCH = "${MACHINE_ARCH}" 10PACKAGE_ARCH = "${MACHINE_ARCH}"
11COMPATIBLE_MACHINE = "j721e|j721s2|j784s4|am62xx" 11COMPATIBLE_MACHINE = "j721e|j721s2|j784s4|am62xx|am62pxx"
12 12
13PR = "r2" 13PR = "r2"
14 14
@@ -21,6 +21,7 @@ TARGET_PRODUCT:j721e = "j721e_linux"
21TARGET_PRODUCT:j721s2 = "j721s2_linux" 21TARGET_PRODUCT:j721s2 = "j721s2_linux"
22TARGET_PRODUCT:j784s4 = "j784s4_linux" 22TARGET_PRODUCT:j784s4 = "j784s4_linux"
23TARGET_PRODUCT:am62xx = "am62_linux" 23TARGET_PRODUCT:am62xx = "am62_linux"
24TARGET_PRODUCT:am62pxx = "am62p_linux"
24PVR_BUILD = "release" 25PVR_BUILD = "release"
25PVR_WS = "lws-generic" 26PVR_WS = "lws-generic"
26 27